Results 1 to 3 of 3

Thread: Zimbra self signed zertificates

  1. #1
    Join Date
    Dec 2009
    Posts
    24
    Rep Power
    5

    Default Zimbra self signed zertificates

    Hi

    My System:
    Debian 5
    Zimbra 6.0.10 OSE

    Because of the fact that Outlook always asks for the "unsecure" ssl certificate I now would install the ca certificate of zimbra to my desktop.

    So at first I recreate the server certificate of zimbra (Zimbra Admin UI).
    Tools -> certificate
    I set "self signed" certificate valid for 3650 days (10 years).

    This works perfectly.

    In "/opt/zimbra/ssl/zimbra/" is everything I need.
    In the "server" folder I found the "server.crt" file.
    I checked it with:
    Code:
    cd /opt/zimbra/ssl/zimbra/server/
    openssl x509 -in server.crt -noout -text
    I can see that the certificate is valid from "2011" to "2021".

    I also have tested the chain:
    Code:
    cd /opt/zimbra/ssl/zimbra/ca
    openssl verify -CAfile ca.pem /opt/zimbra/ssl/zimbra/server/server.crt
    /opt/zimbra/ssl/zimbra/server/server.crt: OK
    But my problem is now:
    Code:
    cd /opt/zimbra/ssl/zimbra/ca
    openssl x509 -in ca.pem -noout -text
    The Zimbra ca certificate is only valid from December 2010 to December 2011 (one year).

    If the ca certificate is invalid also my server certificate is invalid.
    Why does does zimbra sign an 10 year server zertificate with an 1 year ca certificate?
    Is it possible to change this? I have only found "zmzertmgr createca [-new]".

    yogg

  2. #2
    Join Date
    May 2007
    Location
    Piscataway NJ
    Posts
    62
    Rep Power
    8

    Default

    I have the same issue. any luck with it?

  3. #3
    Join Date
    Dec 2009
    Posts
    75
    Rep Power
    5

    Default

    Found nothing for this until now
    Release 7.1.2_GA_3268.UBUNTU8_64 UBUNTU8_64 NETWORK edition.

Similar Threads

  1. Replies: 9
    Last Post: 03-01-2008, 08:21 PM
  2. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 02:00 AM
  3. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM
  4. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 12:34 PM
  5. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •