Results 1 to 2 of 2

Thread: Zimbra RemoteManager "vs" non-standard SSH install on Ubuntu 10LTS?

  1. #1
    Join Date
    Mar 2011
    Posts
    7
    Rep Power
    4

    Question Zimbra RemoteManager "vs" non-standard SSH install on Ubuntu 10LTS?

    Hi,

    I've installed Zimbra 7.0.1_GA to Ubuntu 10.04 LTS/64 in a Xen DomU guest.

    No errors I noticed in the install.

    When I nav to my admin panel, all services show on/green.

    When I click "Server Settings", I get a dialog:

    "Message: system failure: exception during auth {RemoteManager: zimbra.dchil.loc->zimbra@zimbra.dchil.loc:22} Error code: service.FAILURE Details:soap:Receiver"

    Reading posts like:

    https://www.zimbra.com/forums/instal...-22-issue.html

    I see that it's SSH-related. On that matter, here's my situation.

    My Ubuntu installation (as do all my VMs) run a non-standard SSH install ... my own, built from source:

    ssh -V
    OpenSSH_5.8p1, OpenSSL 1.0.0d 8 Feb 2011
    which ssh
    /usr/local/bin/ssh

    with configs in

    /usr/local/etc/ssh

    and sshd is launched by an xinetd script, rather than the usual init.d.

    Given my config, I can ssh -- using PubKey auth -- into the Ubuntu VM at will from my local LAN.

    I suspect that I need to get Zimbra to acknowledge/use *my* ssh bins, config, and certs.

    My questions are --
    (1) can I do this? or do I have to unwind 'my' ssh and revert to Ubuntu's standard install?
    (2) if I can, how do I go about it?

    THanks.

    DChil

  2. #2
    Join Date
    Mar 2011
    Posts
    7
    Rep Power
    4

    Default

    I've gotten my ssh & zimbra to cooperate. At least to the point that I can login using PubKey auth,

    ssh -vi .ssh/zimbra_identity -o strictHostKeyChecking=no zimbra@zimbra.dchil.loc -p 22
    ...
    Last login: Thu Mar 31 21:10:39 2011 from 10.128.128.10
    zimbra@zimbra:~$

    But, I still see the dialog:

    "Message: system failure: exception during auth {RemoteManager: zimbra.dchil.loc->zimbra@zimbra.dchil.loc:22} Error code: service.FAILURE Details:soap:Receiver"

    When I click "Server Settings" in the Admin interface.

Similar Threads

  1. Issues after upgrading from 6.0.10 to 7
    By rhorist in forum Administrators
    Replies: 8
    Last Post: 02-25-2011, 07:38 AM
  2. Old Backup stay in TO_DELETE status and no clearing..
    By bartounet in forum Administrators
    Replies: 0
    Last Post: 10-05-2010, 07:40 AM
  3. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 01:00 AM
  4. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  5. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •