Page 4 of 4 FirstFirst ... 234
Results 31 to 37 of 37

Thread: High Java CPU usage question

  1. #31
    Join Date
    Jan 2012
    Posts
    41
    Rep Power
    3

    Default

    Quote Originally Posted by bhwong View Post
    Hi Stasouv,

    Please share where are the Java components in the lib folders that we can move out.
    Well, it's been long so my memory fails me, but you could start looking in:

    Code:
    /opt/zimbra/lib/jars
    /opt/zimbra/lib/ext*/*
    /opt/zimbra/zimlet*
    Hint: Check the dates... Old components should date way back then the new ones.

  2. #32
    Join Date
    Oct 2007
    Posts
    57
    Rep Power
    8

    Default

    Thank you Stasouv and bhwong, this might be the problemsolver.
    So weird no Zimbra-teammember is helping us out here.

    Roderick
    FC11 x64 / Centos 6.2 - Zimbra 7.2.0 Open Source version - ESX 5.0

  3. #33
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by mrcoffee11 View Post
    So weird no Zimbra-teammember is helping us out here.
    Why? These are Community support forums not official Zimbra support and people post here voluntarily and when they have the time.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #34
    Join Date
    Feb 2009
    Location
    Singapore
    Posts
    503
    Rep Power
    7

    Default

    This option, especially PermSize, help to prevent Java for mailboxd from hitting 100% too:

    zmlocalconfig -e mailboxd_java_options="-server -Djava.awt.headless=true \
    -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:NewRatio=2 \
    -XX:PermSize=196m -XX:MaxPermSize=350m -XX:SoftRefLRUPolicyMSPerMB=1 \
    -verbose:gc -XX:+PrintGCDetails -XX:+PrintGCTimeStamps \
    -XX:+PrintGCApplicationStoppedTime \
    -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/opt/zimbra/log \
    -XX:ErrorFile=/opt/zimbra/log”

  5. #35
    Join Date
    Feb 2009
    Location
    Singapore
    Posts
    503
    Rep Power
    7

    Default

    If you are on single server, ensure that memcached is not running too.

    Check which services are running and installed:
    zmprov gs `zmhostname` | grep zimbraServiceEnabled
    zmprov gs `zmhostname` | grep zimbraServiceInstalled

    disable and remove memcached:
    zmprov ms `zmhostname` -zimbraServiceEnabled memcached
    zmprov ms `zmhostname` -zimbraServiceInstalled memcached
    zmcontrol stop
    zmcontrol start

  6. #36
    Join Date
    Oct 2007
    Posts
    57
    Rep Power
    8

    Default

    Quote Originally Posted by phoenix View Post
    Why? These are Community support forums not official Zimbra support and people post here voluntarily and when they have the time.
    I see, thanks. This problem has been out there for years in several threads and so many people tried different solutions but it was never solved, so that's why I placed my remark the community needed input from the Zimbra team.
    FC11 x64 / Centos 6.2 - Zimbra 7.2.0 Open Source version - ESX 5.0

  7. #37
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by mrcoffee11 View Post
    I see, thanks. This problem has been out there for years in several threads and so many people tried different solutions but it was never solved, so that's why I placed my remark the community needed input from the Zimbra team.
    Various problems with java have been addressed in previous releases of Zimbra, if you want to get the attention of Zimbra developers then file a bug report - that's the correct place for bug if you think that's what is happening on your server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. [SOLVED] High cpu load, only on one core?.. java..
    By ducommun in forum Administrators
    Replies: 1
    Last Post: 02-25-2011, 06:40 AM
  2. High CPU usage on server and client
    By jack-Z in forum Administrators
    Replies: 10
    Last Post: 01-07-2009, 10:12 PM
  3. Replies: 5
    Last Post: 02-04-2008, 05:55 PM
  4. HIGH CPU use
    By brwatters in forum Administrators
    Replies: 3
    Last Post: 07-05-2006, 09:47 AM
  5. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •