Results 1 to 3 of 3

Thread: zmmailboxdctl is not running.

  1. #1
    Join Date
    Sep 2009
    Rep Power

    Default zmmailboxdctl is not running.

    Hi All,

    My server had a disk fault and upon running fsck, my zimbra service experienced a setback and LDAP getting corrupted. Have gone through the varios threads and have been able to repair it.
    But upon re-installing zimbra from my backup, zmmailboxdctl service is not running. Have tried to search the various forums to no success.

    Find below the varios log files - zimbra.log and zmmailboxd.out .

    After zmcontrol stop and start
    Find it attached - it is huge

    CompilerOracle: exclude com/zimbra/cs/session/SessionMap.putAndPrune
    CompilerOracle: exclude com/zimbra/cs/mailbox/MailItem.delete
    CompilerOracle: exclude org/apache/xerces/impl/XMLDocumentFragmentScannerImpl$FragmentContentDisp atcher.dispatch
    0 INFO [main] log - Logging to org.slf4j.impl.Log4jLoggerAdapter(org.mortbay.log) via org.mortbay.log.Slf4jLog
    Total time for which application threads were stopped: 0.0001280 seconds
    Total time for which application threads were stopped: 0.0001230 seconds
    Zimbra server reserving server socket port=110 bindaddr=null ssl=false
    Zimbra server reserving server socket port=995 bindaddr=null ssl=true
    Zimbra server reserving server socket port=143 bindaddr=null ssl=false
    Zimbra server reserving server socket port=993 bindaddr=null ssl=true
    Zimbra server reserving server socket port=7025 bindaddr=null ssl=false
    1205 WARN [main] log - Config error at <Set name="useDirectBuffers"/>
    1205 WARN [main] log - Config error at <Call name="addConnector"><Arg>
    <New id="http" class="org.mortbay.jetty.nio.SelectChannelConnecto r"><Set name="port"><SystemProperty name="jetty.port" default="80"/></Set><Set name="maxIdleTime">30000</Set><Set name="lowResourceMaxIdleTime">1000</Set><Set name="Acceptors">2</Set><Set name="confidentialPort">443</Set><Set name="useDirectBuffers"/></New>
    1206 WARN [main] log - EXCEPTION
    java.lang.NoSuchMethodException: class org.mortbay.jetty.nio.SelectChannelConnector.setUs eDirectBuffers(class java.lang.Object)
    at org.mortbay.xml.XmlConfiguration.set(XmlConfigurat
    at org.mortbay.xml.XmlConfiguration.configure(XmlConf
    at org.mortbay.xml.XmlConfiguration.newObj(XmlConfigu
    at org.mortbay.xml.XmlConfiguration.itemValue(XmlConf
    at org.mortbay.xml.XmlConfiguration.value(XmlConfigur
    at org.mortbay.xml.XmlConfiguration.configure(XmlConf
    at org.mortbay.xml.XmlConfiguration.configure(XmlConf
    at org.mortbay.xml.XmlConfiguration.main(XmlConfigura
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De
    at java.lang.reflect.Method.invoke(
    at org.mortbay.start.Main.invokeMain(
    at org.mortbay.start.Main.start(
    at org.mortbay.start.Main.start(
    at org.mortbay.start.Main.main(
    par new generation total 135488K, used 36150K [0x873f0000, 0x906f0000, 0x906f0000)
    eden space 120448K, 30% used [0x873f0000, 0x8973da98, 0x8e990000)
    from space 15040K, 0% used [0x8e990000, 0x8e990000, 0x8f840000)
    to space 15040K, 0% used [0x8f840000, 0x8f840000, 0x906f0000)
    concurrent mark-sweep generation total 451584K, used 0K [0x906f0000, 0xabff0000, 0xabff0000)
    concurrent-mark-sweep perm gen total 131072K, used 6792K [0xabff0000, 0xb3ff0000, 0xb3ff0000)

    Kindly Please help
    Attached Files Attached Files

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    Your log file has these entries in it:

    Oct 15 19:06:14 webmail zimbramon[19134]: 19134:info: Starting memcached via zmcontrol
    Oct 15 19:06:15 webmail zimbramon[19134]: 19134:info: Starting imapproxy via zmcontrol
    If this is a single server why do you have those services installed and enabled? They should not be used on a single server and they should be removed and disabled (details on how to do that are in the forums/wiki if you search).

    You also have this:
    Oct 15 19:09:05 webmail amavis[24388]: (24388-01) extra modules loaded: /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/auto/Net/SSL
    eay/autosplit.ix, /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/auto/Net/SSLeay/, IO/Socket/, Net/LDAP/Extension
    .pm, Net/
    That indicates you're using a 64 bit system, is that correct? Update your forum profile with the output of the following command:

    zmcontrol -v


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Sep 2009
    Rep Power


    Let me uninstall the two services installed.

    Am on a 32 bit installation not 64 bit.

    Let me update my profile.

Similar Threads

  1. [SOLVED] Unable to start all of the blackberry services
    By scasperson in forum Zimbra Connector for BlackBerry
    Replies: 8
    Last Post: 11-18-2011, 06:30 AM
  2. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM
  3. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 08:22 AM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts