Results 1 to 2 of 2

Thread: Restoring a zimbra server without proper backup

Hybrid View

  1. #1
    Join Date
    Jan 2006
    Posts
    88
    Rep Power
    9

    Default Restoring a zimbra server without proper backup

    Hello,

    Before I started doing my regular zimbra network edition backups I had a basic disk level backup of the main zimbra server run every night.

    When it came time to actually use one of these backups to restore some data I had a rude awakening. My thought was that I could just restore the backup to a subdirectory of my primary workstation, and then use the zm tools to extract out the messages I needed.

    I didnt think about the mysql dependency in that the database is needed to know what messages go in what folder. So without starting up the zimbra service in total, there seemed to be no way to extract the messages.

    Does anyone have any tips for getting this zimbra install up and running on another machine? I tried building a fresh CENTOS install and just overlaying the /opt/zimbra subfolder onto it, but I couldnt get zimbra to start up, it seemed to hang when running the startup script.

    One of our users needs an old copy of his mailbox, so any help people could provide would be appreciated.

  2. #2
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default zmlmtpinject

    Your best bet is to do a grep through the user's saved store directory to find the message(s), then use zmlmtpinject to add them to the user's mailbox. The messages re-injected in this manner will appear as if they were just received, but otherwise should be identical.
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. Replies: 9
    Last Post: 03-01-2008, 08:21 PM
  2. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 12:34 PM
  3. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  4. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 10:19 AM
  5. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •