Results 1 to 7 of 7

Thread: DKIM non_smtpd_milters='' Under Zimbra 7.0

  1. #1
    Join Date
    Apr 2011
    Posts
    6
    Rep Power
    4

    Default DKIM non_smtpd_milters='' Under Zimbra 7.0

    Hi i follow many links about this subject and i have one mistake than i can't resolve

    After a zmmtactl restart it rewrite fine smtpd_milters but non_smtpd_milters stay empty in /opt/zimbra/postfix/conf/main.cf

    Code:
    smtpd_milters = inet:localhost:8891
    non_smtpd_milters = 
    milter_default_action = accept
    milter_protocol = 2
    And it give me two errors
    milter.log
    Code:
    ERROR [main] [] milter - Unable to start milter server: system failure: Could not bind to port=8891 bindaddr= ssl=false useChannels=true
    zimbra.log
    Code:
    postfix/smtpd[2059]: warning: connect to Milter service inet:127.0.0.1:8891: Connection refused
    ¿ Could you help me with this information, or do you need all steps i do?
    Best Regards

  2. #2
    Join Date
    Apr 2011
    Posts
    19
    Rep Power
    4

    Default

    What's the output of
    Code:
    netstat -antup | grep 8891
    Seems like some service/app is lstening to that very port, but I might be wrong...

  3. #3
    Join Date
    Apr 2011
    Posts
    6
    Rep Power
    4

    Default

    Hi, thanks for the answer, it only listen DKIM
    # netstat -antup | grep 8891
    tcp 0 0 XXX.XXX.19.242:8891 0.0.0.0:* LISTEN 1613/dkim-filter

  4. #4
    Join Date
    Apr 2011
    Posts
    19
    Rep Power
    4

    Default

    Try to restart milter-dkim service or even, change your listening socket port to something different than 8891 that is not already in use.
    What howto you were using while setting this? What exactly did you do?

  5. #5
    Join Date
    Apr 2011
    Posts
    6
    Rep Power
    4

    Default

    Hi kaosmonk, this is what i do.

    1.- I follow the instruction from Debian Tutorual for DKIM steps 1 to 8

    2.- Restart Zimbra
    Code:
    su - zimbra
    zmmtactl restart
    And Zimbra reconfigure information from /opt/zimbra/postfix/conf/main.cf to look like that
    Code:
    milter_default_action = accept
    milter_protocol = 2
    smtpd_milters=
    non_smtpd_milters=
    3.- Verify Milter Port on Zimbra and change to 8091 following this link Change default Milter Port
    Code:
    zmprov gs mail.servermail.com zimbraMilterBindPort
    # name mail.servermail.com
    #zimbraMilterBindPort: 7026
    
    zmprov ms mail.servermail.com zimbraMilterBindPort 8091
    # name mail.servermail.com
    #zimbraMilterBindPort: 8891
    4.- Activate Milter Server following this link DKIM Milter not Workon Zimbra Admin Console

    'Server Settings' > 'MTA' tab > and check the 'Milter Server' box.
    Code:
    zmmtactl restart
    And Zimbra reconfigure information from /opt/zimbra/postfix/conf/main.cf to look like that
    Code:
    milter_default_action = accept
    milter_protocol = 2
    smtpd_milters = inet:127.0.0.1:8891
    non_smtpd_milters=
    5.- I have milter.log and zimbra.log with errors

    I hope with this you can figurate what am i doing wrong

    Best Regards

  6. #6
    Join Date
    Apr 2011
    Posts
    6
    Rep Power
    4

    Default

    DKIM Steps

    Hi kaosmonk, vavai, i don't know what i do but my last post dont appears.


    It seems that you already bind port 8891 to another milter, possibly the default milter on Zimbra Admin | Global Setting | MTA. Try to resetting the default port of Zimbra milter, 7026 and then restart your Zimbra Service
    Hi Vavai you are correct i try to use another milter because i want my domain being authenticated using DKIM, using the default port 7026 i don't have MTA errors, but it did'nt authenticated my domain

    Hi kaosmonk, this are the steps i do

    1.- I Follow Setup DKIM Postfix from 1 to 8 steps

    2.- Restart zmmtactl
    Code:
    su - zimbra
    zmmtactl restart
    3.- Check /opt/zimbra/postfix/conf/main.cf and i have
    Code:
    milter_default_action = accept
    milter_protocol = 2
    smtpd_milters =
    non_smtpd_milters=
    4.- Change port of Zimbra Milter SOLVE Change default milter

    Code:
    zmprov gs mail.server.com zimbraMilterBindPort
    # name mail.server.com
    #zimbraMilterBindPort: 7026
    
    zmprov ms mail.server.com zimbraMilterBindPort 8091
    # name mail.server.com
    #zimbraMilterBindPort: 8891
    5.- In Zimbra Admin Console go 'Server Settings' > 'MTA' tab > and check the 'Milter Server' box. Add your hostname/IP, save your settings and issue a 'zmmtactl restart'. SOLVE DKIM Milter not Working

    Restart zmmtactl
    Code:
    su - zimbra
    zmmtactl restart
    6.- Check again /opt/zimbra/postfix/conf/main.cf
    Code:
    milter_default_action = accept
    milter_protocol = 2
    smtpd_milters = inet:127.0.0.1:8891
    non_smtpd_milters=
    I hope whit this you know what am i doing wrong

    Best Regards

  7. #7
    Join Date
    Apr 2011
    Posts
    6
    Rep Power
    4

    Default

    Hi, i change dkim-filter for opendkim and Zimbra dont show any errors , but when i send an email to autorespond+dkim@dk.elandsys.com to test, it return to me

    Code:
    DKIM Signature validation: not available
    DomainKeys Signature validation: not available
    DomainKeys Policy: no DNS record for _domainkey.nibi.com
    DKIM Author Domain Signing Practices: no DNS record for _adsp._domainkey.nibi.com
    But im my DNS i have
    Code:
    nibi.com.   IN TXT          "v=spf1 a mx include:nibi.com ~all"
    selector._domainkey IN TXT "v=DKIM1; g=*; k=rsa; p=MIGfMA0GCSqGSIb3D...."
    My logic say, the problem is not on Zimbra, because there are no errors and i can send and recive mails, but my DNS look fine

    Code:
    dig any selector._domainkey.nibi.com
    selector._domainkey.nibi.com. 86317 IN TXT	"v=DKIM1\; g=*\; k=rsa\; p=MIGfMA0GCSqGSIb3D...."
    Any idea, of what i missing?

    Best Regards

Similar Threads

  1. Replies: 9
    Last Post: 03-01-2008, 07:21 PM
  2. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 01:00 AM
  3. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 04:43 AM
  4. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  5. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •