Results 1 to 4 of 4

Thread: [SOLVED] cbpolicyd crashed zimbra

  1. #1
    andretapxure Guest

    Default [SOLVED] cbpolicyd crashed zimbra

    Hi, there!
    I'm Running Zimbra 7.0 in CentOS 5.5. Following the tip in this thread

    http://www.zimbra.com/forums/install...up-7-0-ga.html

    I enabled cbpolicyd in my zimbra running
    zmprov ms correio.mydomain.com zimbraServiceEnabled cbpolicyd
    and now when I try to start zimbra I get the following thing

    [zimbra@correio ~]$ zmcontrol start
    Host correio.mydomain.com
    Starting ldap...Done.
    Starting zmconfigd...Done.
    Starting cbpolicyd...Done.
    [zimbra@correio ~]$

    If I try to disable running
    zmprov ms correio.mydomain.com zimbraServiceDisabled cbpolicyd
    I get the message (once zimbra is stopped)

    cbpolicyd[] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)

    the last line in cbpolicyd.log is
    [2011/04/30-08:52:26 - 4082] [CORE] NOTICE: Setting gid to "500 500"
    [2011/04/30-08:52:26 - 4082] [CORE] INFO: Setting up serialization via flock
    [2011/04/30-08:52:26 - 4082] [CORE] INFO: Beginning prefork (4 processes)
    [2011/04/30-08:52:26 - 4082] [CORE] INFO: Starting "4" children

    And all I have in zimbra.log is
    Apr 30 08:51:38 correio zimbramon[3621]: 3621:info: Starting services initiated by zmcontrol
    Apr 30 08:51:38 correio slapd[3669]: @(#) $OpenLDAP: slapd 2.4.23 (Jan 7 2011 12:29:29) $ build@zre-rhel5-64.eng.vmware.com:/home/build/p4/HELIX/ThirdParty/openldap/openlda
    Apr 30 08:51:38 correio slapd[3670]: slapd starting
    Apr 30 08:51:43 correio slapd[3670]: connection_read(13): no connection!
    Apr 30 08:51:43 correio slapd[3670]: connection_read(13): no connection!
    Apr 30 08:51:47 correio zimbramon[3621]: 3621:info: Starting zmconfigd via zmcontrol
    Apr 30 08:52:26 correio zimbramon[3621]: 3621:info: Starting cbpolicyd via zmcontrol

  2. #2
    andretapxure Guest

    Default I found out what stupid thing I did

    When I asked zimbra to
    zmprov ms correio.mydomain.com zimbraServiceEnabled cbpolicyd
    Without the '+' sign, I told him to only enable the cbpolicyd service.
    The sollution for this problem was re enable the rest of the services now with the '+' sign

  3. #3
    Join Date
    Jul 2010
    Posts
    2
    Rep Power
    5

    Default

    The sollution for this problem was re enable the rest of the services now with the '+' sign

    -------
    How about the following error :
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)

    i was re enable the rest of the services with the '+' sign but i got this error. This is possible because ldap is not running but I have to manually start but did not succeed.
    Last edited by lonurhazve; 03-09-2012 at 10:39 AM.

  4. #4
    Join Date
    Jul 2010
    Posts
    2
    Rep Power
    5

    Default

    SOLVED
    --------

    I'm try this command :

    zimbra@mail:~$zmprov -l ms `zmhostname` -- +zimbraServiceEnabled ldap
    zimbra@mail:~$zmprov -l ms `zmhostname` -- +zimbraServiceEnabled mailbox
    ..
    ..
    ..

Similar Threads

  1. My Zimbra Server crashed this morning...
    By glitch23 in forum Administrators
    Replies: 3
    Last Post: 04-07-2008, 01:28 PM
  2. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 08:56 PM
  3. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  4. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •