zmprov ms mail.server.org zimbraMtaRelayHost mail.server.com:25;
echo mail.server.com uid@server.comassword > /opt/zimbra/conf/relay_password;

postmap hash:/opt/zimbra/conf/relay_password;
postmap -q mail.server.com /opt/zimbra/conf/relay_password;
postconf -e smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password;

postconf -e smtp_sasl_auth_enable=yes;
postconf -e smtp_use_tls=yes;
postfix reload;
postconf -e smtp_cname_overrides_servername=no;
postconf -e smtp_sasl_security_options=noanonymous;
postfix reload;

zmlocalconfig -e postfix_smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password;
zmlocalconfig -e postfix_smtp_sasl_auth_enable=yes;
zmlocalconfig -e postfix_smtp_use_tls=yes;
zmlocalconfig -e postfix_smtp_cname_overrides_servername=no;
zmlocalconfig -e postfix_smtp_sasl_security_options=noanonymous;

zmprov mcf zimbraLastLogonTimestampFrequency 1h;
zmprov mcf zimbraDefaultDomainName server.org;
zmprov mc default zimbraFeatureCalendarReminderDeviceEmailEnabled TRUE;

Guys, I use the above script to have zimbra authenticate and send emails outbound just fine. The problem now is that the ISP started to block port 25. The account is running on a dynamic IP. All worked well until the ISP started blocking port 25.

Now, is there a way to tell my script to use port 587. I've tried to just add 587 everyplace there is a reference to mail.server.com:587. That didn't work.

thanks in advance