Results 1 to 5 of 5

Thread: Moving index and store folders to a nas

  1. #1
    Join Date
    Mar 2011
    Location
    Athens - Greece
    Posts
    7
    Rep Power
    4

    Default Moving index and store folders to a nas

    Dear All,

    I have installed Zimbra Open source 7.0.1 and Upgrated it to 7.1.0 without any problems using Ubuntu x86_64

    I wanted to put the index and store folder of zimbra installation in a network drive.

    So i created a new folder in the /media folder named mailstore.

    Then i tried to mount a network path located in the network.
    I gave the command as root :
    smbclient -L 192.168.1.5 -U%
    and got the following :

    Domain=[MyDomain] OS=[EMC-SNAS:T5.6.50.2] Server=[NT1]

    Sharename Type Comment
    --------- ---- -------
    Technical_Dep Disk Technical Department Files
    HOMEDIRROOT$ Disk
    mailstore Disk
    HOME Disk Home Directory of MyDomain\
    CHECK$ Disk Virus Checking Service
    C$ Disk Root Service
    IPC$ IPC IPC Service
    session request to 192.168.1.5 failed (Called name not present)
    session request to 192 failed (Called name not present)
    Domain=[MyDomain] OS=[EMC-SNAS:T5.6.50.2] Server=[NT1]

    Server Comment
    --------- -------

    Workgroup Master
    --------- -------


    Then i gave the command as root :
    smbmount //192.168.1.5/mailstore /media/mailstore -o username=xxxxxxx,password=xxxxxxx,uid=1001,mask=00 0

    (The uid=1001 is the id that the zimbra user showing up after giving the id command.)

    All went ok. Running th df -k command i get :
    root@poseidon:~# df -k
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/sda1 67516008 17886444 46199884 28% /
    none 4092676 232 4092444 1% /dev
    none 4097184 164 4097020 1% /dev/shm
    none 4097184 88 4097096 1% /var/run
    none 4097184 0 4097184 0% /var/lock
    none 4097184 0 4097184 0% /lib/init/rw
    //192.168.1.5/mailstore
    1864125440 1625368344 238757096 88% /media/mailstore


    Then gave the commands:
    su - zimbra
    zmcontrol stop
    cp -rp /opt/zimbra /06-05-2011_Zimbra_Backup (Just to have everything backed up.)

    Then i took the folder index and store and copied them to my share folder which is link to /media/mailstore
    I renamed the index nd store folders under /opt/zimbra just to keep them

    Then i created some symbolik links :
    ln -s /media/mailstore/index /opt/zimbra/index
    ln -s /media/mailstore/store /opt/zimbra/store


    As root i gave the command:
    chown -R zimbra:zimbra /opt/zimbra/index
    chown -R zimbra:zimbra /opt/zimbra/store


    and as zimbra user gave the command:
    /opt/zimbra/libexec/zmfixperms

    Then i gave the command:
    zmcontrol start
    And I got the following :
    Host poseidon.mcasim.gr
    Starting ldap...Done.
    Starting zmconfigd...Done.
    Starting logger...Done.
    df: no file systems processed
    WARNING: Disk space below threshold for /opt/zimbra/store.
    df: no file systems processed
    WARNING: Disk space below threshold for /opt/zimbra/index.
    Starting mailbox...Done.
    Starting memcached...Done.
    Starting imapproxy...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...Done.
    Starting spell...Done.
    Starting mta...Done.
    Starting stats...Done.


    I have 227.6 GB of disk space in the shared folders (Soon to be replaced by a DELL Poweredge 3100 with 11Tb and iscsi controller)... (What on Earth is wrong with this ???)

    So After some minutes i am able to see all my e-mails.... BUT i cannot receive any new ones. They all stack in the Mail Spool. Tried to flush them but .. no luck.

    From the terminal logged as zimbra user (su - zimbra) i can copy from the root partition any file i like to the network folders without any problem:
    /media/mailstore
    /media/mailstore/index
    /media/mailstore/store


    PLEASE PLEASE PLEASE ....
    Could Anyone please help me out with this ????
    YES i know.. I should use DAS - isci connection to some raid 6 storage but we really need to work firstly to NAS and after bying that Dell with iscsi, wee will change everything.

    I just saw that i get this error messages when i give the command tail -f /var/log/mail.log
    May 6 18:20:01 poseidon postfix/lmtp[25620]: 661806271D: to=<admin@mcasim.gr>, relay=poseidon.mcasim.gr[192.168.1.15]:7025, delay=0.1, delays=0.01/0/0/0.09, dsn=4.0.0, status=deferred (host poseidon.mcasim.gr[192.168.1.15] said: 451 4.0.0 Temporary message delivery failure try again (in reply to end of DATA command))
    May 6 18:20:11 poseidon postfix/scache[25617]: statistics: start interval May 6 18:16:50
    May 6 18:20:11 poseidon postfix/scache[25617]: statistics: domain lookup hits=1 miss=11 success=8%
    May 6 18:20:11 poseidon postfix/scache[25617]: statistics: address lookup hits=0 miss=11 success=0%
    May 6 18:20:11 poseidon postfix/scache[25617]: statistics: max simultaneous domains=1 addresses=1 connection=11
    May 6 18:20:19 poseidon zmmailboxdmgr[26622]: status requested
    May 6 18:20:19 poseidon zmmailboxdmgr[26622]: status OK
    May 6 18:21:42 poseidon postfix/anvil[26173]: statistics: max connection rate 2/60s for (smtp:192.168.254.82) at May 6 18:18:22
    May 6 18:21:42 poseidon postfix/anvil[26173]: statistics: max connection count 1 for (smtp:192.168.254.82) at May 6 18:18:21
    May 6 18:21:42 poseidon postfix/anvil[26173]: statistics: max cache size 1 at May 6 18:18:21
    May 6 18:22:10 poseidon zmmailboxdmgr[27027]: status requested
    May 6 18:22:10 poseidon zmmailboxdmgr[27027]: status OK
    May 6 18:23:22 poseidon postfix/smtpd[26178]: timeout after END-OF-MESSAGE from localhost.localdomain[127.0.0.1]
    May 6 18:23:22 poseidon postfix/smtpd[26178]: disconnect from localhost.localdomain[127.0.0.1]
    May 6 18:23:23 poseidon postfix/smtpd[26181]: timeout after END-OF-MESSAGE from localhost.localdomain[127.0.0.1]
    May 6 18:23:23 poseidon postfix/smtpd[26181]: disconnect from localhost.localdomain[127.0.0.1]
    May 6 18:23:44 poseidon postfix/qmgr[8044]: 316FC62712: from=<nagios@localhost.localdomain>, size=1715, nrcpt=1 (queue active)
    May 6 18:23:44 poseidon postfix/qmgr[8044]: 37ABB6270B: from=<zimbra@poseidon.mcasim.gr>, size=1120, nrcpt=1 (queue active)
    May 6 18:23:44 poseidon postfix/qmgr[8044]: 1B6D262718: from=<nagios@localhost.localdomain>, size=1723, nrcpt=1 (queue active)
    May 6 18:23:44 poseidon postfix/lmtp[27187]: 316FC62712: to=<sper@mcasim.gr>, relay=poseidon.mcasim.gr[192.168.1.15]:7025, delay=322, delays=322/0.03/0/0.1, dsn=4.0.0, status=deferred (host poseidon.mcasim.gr[192.168.1.15] said: 451 4.0.0 Temporary message delivery failure try again (in reply to end of DATA command))
    May 6 18:23:44 poseidon postfix/lmtp[27188]: 37ABB6270B: to=<admin@mcasim.gr>, relay=poseidon.mcasim.gr[192.168.1.15]:7025, delay=823, delays=823/0.02/0.01/0.13, dsn=4.0.0, status=deferred (host poseidon.mcasim.gr[192.168.1.15] said: 451 4.0.0 Temporary message delivery failure try again (in reply to end of DATA command))
    May 6 18:23:44 poseidon postfix/lmtp[27189]: 1B6D262718: to=<hassim@mcasim.gr>, relay=poseidon.mcasim.gr[192.168.1.15]:7025, delay=321, delays=321/0.03/0/0.15, dsn=4.0.0, status=deferred (host poseidon.mcasim.gr[192.168.1.15] said: 451 4.0.0 Temporary message delivery failure try again (in reply to end of DATA command))
    May 6 18:24:10 poseidon zmmailboxdmgr[27430]: status requested
    May 6 18:24:10 poseidon zmmailboxdmgr[27430]: status OK

    Something is wrong here, right?
    Last edited by Whisperer; 05-06-2011 at 09:25 AM.

  2. #2
    Join Date
    Apr 2008
    Location
    Maryland
    Posts
    15
    Rep Power
    7

    Default

    I would suspect permission problems with the share you are using on the mount point. The space error messages are just because the df command they are using does not show space for NFS mount points.

    I don't know much about smbmount and how the Windows permissions are mapped to linux permissions. I am using NFS mounts for zimbra, but not from a windows based NAS. I am using a NetApp and that supports nfs so all the linux permissions are mapped correctly.

    As the zimbra users, can you go to /media/mailstore and create files and directories? what about /media/mailstore/index and /media/mailstore/data? The zimbra user and group must be able to access the files/folders correctly. Windows handles permissions in a completely different way than linux.

    I would not trust SMB in general (permissions or otherwise) for zimbra. NFS from a Enterprise NAS device is very different from a performance as well as a reliability perspective.

  3. #3
    Join Date
    Mar 2011
    Location
    Athens - Greece
    Posts
    7
    Rep Power
    4

    Default

    Thank you very much fro the quick reply tyarmas.

    Yes the zimbra user has access to create-copy-delete files and folders in the /media/mailstore and in the /media/mailstore/index and /media/mailstore/store folders.
    Also i logged using me web-browser and created a new folder with success and also i copied and move some mails. It worked ok up to that.

    Maybe i should change everything back to normal as they were this morning, and i will ask from the guys of EMC to give me some nfs space for testing.

    Have a great weekend.

  4. #4
    Join Date
    Jul 2008
    Location
    UK
    Posts
    171
    Rep Power
    7

    Default

    Re. permissions:

    Don't use cp to move zimbra around, use rsync -aH to preserve file ownership, permissions, hard and soft links - took me about 3 days to find out htis is why my migration was failing!

  5. #5
    Join Date
    Mar 2011
    Location
    Athens - Greece
    Posts
    7
    Rep Power
    4

    Default

    Thank you Very much jonallport.

    Tomorrow i will try it, as i'm planning to backup the op/zimbra and rebuilt the server from the beginning.

    Have a great day and thank you again !

Similar Threads

  1. Replies: 0
    Last Post: 03-22-2011, 12:15 PM
  2. Automatic system delete index?
    By mikiso in forum Administrators
    Replies: 0
    Last Post: 10-16-2010, 03:54 PM
  3. Using a message store backup from another server
    By entorno in forum Administrators
    Replies: 1
    Last Post: 02-22-2008, 08:42 AM
  4. the index store: how is it big?
    By GoTo in forum Administrators
    Replies: 2
    Last Post: 07-07-2006, 07:36 AM
  5. Moving the Database
    By bens750 in forum Installation
    Replies: 2
    Last Post: 05-24-2006, 11:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •