Results 1 to 2 of 2

Thread: [SOLVED] zmrestore with target '-t'

  1. #1
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    5

    Default [SOLVED] zmrestore with target '-t'

    I am trying to restore an account from a backup that's stored in my secondary drive (was copied over when default backup target was exhausted). This is not in my default zimbra backup drive so I am trying to restore the account with -t switch that specifies the target location from where it should search out the backup. But it is not working as it should be.

    Tried the following orders

    $ zmrestore -ca -a acc@domain.com -pre new_ -t /zimbra/sessions
    Error occurred: invalid request: Account map file /zimbra/sessions/accounts.xml is missing. Specify a full backup label to restore from.

    $ zmrestore -ca -a acc@domain.com -pre new_ -t /zimbra/sessions -lb full-20110411.151402.024
    Error occurred: backup full-20110411.151402.024 not found

    Backing up through front end is broken, so pls don't tell me that. I am trying cli. Tried giving -t alone, and with -lb. Can someone please verify this?

  2. #2
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    5

    Default

    I managed to restore it by specifying the mount point of the secondary drive where it was stored. As follows ..

    zmrestore -ca -a acc@domain.com -pre new_ -lb full-20110411.151402.024 -t /zimbra

    /zimbra is where the disk was mounted and within it was the 'sessions' directory that I created to keep backups (like how zimbra deals with the default backup target).
    Last edited by fyd; 06-12-2011 at 09:54 AM.

Similar Threads

  1. zmrestore point-in-time recovery not working
    By Rich Graves in forum Administrators
    Replies: 9
    Last Post: 12-12-2007, 08:47 PM
  2. zmrestore -restoreToTime not working
    By jeffw in forum Administrators
    Replies: 2
    Last Post: 12-11-2007, 09:13 AM
  3. [SOLVED] Changed Backup Target Did Not Change For LDAP
    By rfoster in forum Administrators
    Replies: 4
    Last Post: 11-13-2007, 04:42 PM
  4. zmrestore restoreToTime problem
    By magsuser2007 in forum Administrators
    Replies: 5
    Last Post: 10-15-2007, 02:41 PM
  5. Set default backup target for zmschedulebackup?
    By Kirkaiya in forum Administrators
    Replies: 2
    Last Post: 04-11-2006, 03:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •