Results 1 to 5 of 5

Thread: server status is red on only 1 server

  1. #1
    Join Date
    May 2011
    Posts
    9
    Rep Power
    4

    Default server status is red on only 1 server

    hi guys, i have read also this problem in other posts but i cannot find anything useful or something escapes me.. then excuse me if i'm going to be repetitive
    i have installed zimbra zcs 7 open on ubuntu 10.04 lts serveron 2 vmware virtual machines, the 1st ah the role of mailbox ldap imap pop3 and the 2nd MTA imap/pop/http proxy.

    the installation has gone smoothly and all server is working properly except for the server status of the MTA server. on the server status page from the mailbox server admin interface it show as red...but it is working correct.
    pls can you suggest me how i need to check to try to solve this problem.

    Thanks in advance

  2. #2
    Join Date
    Apr 2011
    Location
    Slovakia
    Posts
    18
    Rep Power
    4

    Default

    Hi Gullio,

    have you configured SSH keys and logging after installing multiple servers? Please have a look at the multi-server installation guide at part "Multiple-Server Installation" - "Final Set-Up" here:
    http://www.zimbra.com/docs/os/latest...%20Set-Up.html
    This should help.
    Michal Belica - IT consultant
    www.beli.sk

  3. #3
    Join Date
    Jun 2010
    Posts
    198
    Rep Power
    5

    Default

    Quote Originally Posted by gullio View Post
    hi guys, i have read also this problem in other posts but i cannot find anything useful or something escapes me.. then excuse me if i'm going to be repetitive
    i have installed zimbra zcs 7 open on ubuntu 10.04 lts serveron 2 vmware virtual machines, the 1st ah the role of mailbox ldap imap pop3 and the 2nd MTA imap/pop/http proxy.

    the installation has gone smoothly and all server is working properly except for the server status of the MTA server. on the server status page from the mailbox server admin interface it show as red...but it is working correct.
    pls can you suggest me how i need to check to try to solve this problem.

    Thanks in advance
    did you tried the zmsyslogsetup command?

    please update here, what all steps did you tried.

  4. #4
    Join Date
    May 2011
    Posts
    9
    Rep Power
    4

    Default

    hi guys thanks for your replies, now i try to explain what i have do:

    i have done on all node
    Code:
    zmsshkeygen
    next i have issued
    Code:
    zmupdateauthkeys
    and at least i have runned as root
    Code:
    /opt/zimbra/libexec/zmsyslogsetup.
    all script has been executed successfully. infact i can access through web interface to both server(i think without ssh keys i cannot access the other server).

    here i try to append all related files:

    .ssh/authorized_keys on both server

    Code:
    command="/opt/zimbra/libexec/zmrcd" ssh-dss AAAAB3NzaC1kc3MAAACBALx8wsGUKLyiX06R
    61WtdVfIWC05zL5kbguceABGNKHgR+jCwQxGRjCEorl85pTqvPpZKk8Jp+6R5NLRDBqptSnYl65/If1J
    WpMVDIrv+Hg0TeHEdFPf+KvLaqndE9WoZIBwOX3twFa05yif+3fDoX2KwfCW1S37zFsGXXfzfDMHAAAA
    FQDEKOKE35Nt0rm6kDsmVfsXNGv2SQAAAIAys2AyoTnzhFsMsyQPeaDV6mSiVfPk0XYL6eeGW+UdCxJf
    M49epms965PkureXkz9Qd51TCaosGvPJKFFel3QgvYrtnq9iArP63sZOivjutQ34ymY5PegvnTttznh7
    Q6CXfmSd872Jrn0gIY9rHkrBHtGa8sHcpOqWl6f+2fDRMgAAAIEAiwtvGkP4gj4nP6G5dJby7G7tyGb/
    6AsbiroJxpgFUB68q46qHyMtZQpp+Az8SyOtXsbTMlX8QyHzYemlRgK8wLJc0JHzcMEsEADSBQCogIwb
    U0vTz2azz2jRtpSBO1UWhNKaKWD3DLMRr7Un+z/4BB+HsbGAfo6LvultiKYkN+o= mail1
    command="/opt/zimbra/libexec/zmrcd" ssh-dss AAAAB3NzaC1kc3MAAACBAMQYUgUC1WoYV5l5
    JlUkXaUMsNvkUu2ZJlOryoMp0UT0UYcchm6xuY0DgmG90IhZmPKbW6yZaw4trxPbfcOIpwbvNDpOLX4k
    sdlAU+DKJVIs1vVKzq5Zozn/rC+SXfpKAGJEtD69t1+JICnFBz82W1zLCPFeSeW8fvsn1o2FJTCJAAAA
    FQD0pxnsi2cl69LmNfSDlr+qnHuaqQAAAIEAmSgxC0JKLgGSQZwKgJA3LRuagj7cBQt0PFr1TP10hyPz
    VHRzxtaCmKhd0stQWhb2D0iaz7OiimW2uWd+3E4o8j366hx8zb6R0dQ3Tgt7DZBLsnzriztb7qGZWOr3
    bDmYUNegtcjGGL2r8r+BRz425LFJ50xsr5VPhaS2rfzXo8sAAACBAK+vIlutSP8/Xe0LICpcFexcs6qo
    zjYfaqiqbD03RQ5f/pcmlXJv2vFPqOxPFwgW1XDZ8RxP6lxE4MZ50H28aM4360g9L53O41NKNhf7Ytln
    U7hTPooz9V2JN6w1STF2zjsnAUhqa84YsQP1Je+/49ML3XNzCZiQjeZuFKWVuGxs mail2
    Code:
    grep "STATUS" /var/log/zimbra-stats.log | grep stats | head -n1
    (2st server)
    May 23 06:56:10 mail2 zimbramon[30849]: 30849:info: 2011-05-23 06:56:01, STATUS: mail2: stats: Running

    (1st server)
    May 23 06:50:17 mail1 zimbramon[6641]: 6641:info: 2011-05-23 06:50:02, STATUS: mail1: stats: Running

    the things i cannot understand is why the mail1 dosn't receive in his log the status of mail2 services, but mail2 log is full of stats:running.
    maybe rsyslog setup???

    here the conf of rsyslog that zimbra modify after zmsyslogsetup:

    (1st server)

    Code:
    #  Default rules for rsyslog.
    #
    #			For more information see rsyslog.conf(5) and /etc/rsyslo
    g.conf
    
    #
    # First some standard log files.  Log by facility.
    #
    auth,authpriv.*			/var/log/auth.log
    *.*;auth,authpriv.none;local0.none;local1.none;mail.none		-/var/lo
    g/syslog
    #cron.*				/var/log/cron.log
    daemon.*			-/var/log/daemon.log
    kern.*				-/var/log/kern.log
    lpr.*				-/var/log/lpr.log
    mail.*				-/var/log/mail.log
    user.*				-/var/log/user.log
    
    #
    # Logging for the mail system.  Split it up so that
    # it is easy to write scripts to parse these files.
    #
    mail.info			-/var/log/mail.info
    mail.warn			-/var/log/mail.warn
    mail.err			/var/log/mail.err
    
    #
    # Logging for INN news system.
    #
    news.crit			/var/log/news/news.crit
    news.err			/var/log/news/news.err
    news.notice			-/var/log/news/news.notice
    
    #
    # Some "catch-all" log files.
    #
    *.=debug;\
    	local0,local1.none;\
    	auth,authpriv.none;\
    	news.none	-/var/log/debug
    *.=info;*.=notice;*.=warn;\
    	local0,local1.none;\
    	auth,authpriv.none;\
    	cron,daemon.none;\
    	mail,news.none		-/var/log/messages
    
    #
    # Emergencies are sent to everybody logged in.
    #
    *.emerg				*
    
    #
    # I like to have messages displayed on the console, but only on a virtual
    # console I usually leave idle.
    #
    #daemon,mail.*;\
    #	news.=crit;news.=err;news.=notice;\
    #	*.=debug;*.=info;\
    #	*.=notice;*.=warn	/dev/tty8
    
    # The named pipe /dev/xconsole is for the `xconsole' utility.  To use it,
    # you must invoke `xconsole' with the `-file' option:
    # 
    #    $ xconsole -file /dev/xconsole [...]
    #
    # NOTE: adjust the list below, or you'll go crazy if you have a reasonably
    #      busy site..
    #
    daemon.*;mail.*;\
    	news.err;\
    	*.=debug;*.=info;\
    	*.=notice;*.=warn	|/dev/xconsole
    (2nd server)


    Code:
    #  Default rules for rsyslog.
    #
    #			For more information see rsyslog.conf(5) and /etc/rsyslo
    g.conf
    
    #
    # First some standard log files.  Log by facility.
    #
    auth,authpriv.*			/var/log/auth.log
    *.*;auth,authpriv.none;local0.none;local1.none;mail.none		-/var/lo
    g/syslog
    #cron.*				/var/log/cron.log
    daemon.*			-/var/log/daemon.log
    kern.*				-/var/log/kern.log
    lpr.*				-/var/log/lpr.log
    mail.*				-/var/log/mail.log
    user.*				-/var/log/user.log
    
    #
    # Logging for the mail system.  Split it up so that
    # it is easy to write scripts to parse these files.
    #
    mail.info			-/var/log/mail.info
    mail.warn			-/var/log/mail.warn
    mail.err			/var/log/mail.err
    
    #
    # Logging for INN news system.
    #
    news.crit			/var/log/news/news.crit
    news.err			/var/log/news/news.err
    news.notice			-/var/log/news/news.notice
    
    #
    # Some "catch-all" log files.
    #
    *.=debug;\
    	local0,local1.none;\
    	auth,authpriv.none;\
    	news.none	-/var/log/debug
    *.=info;*.=notice;*.=warn;\
    	local0,local1.none;\
    	auth,authpriv.none;\
    	cron,daemon.none;\
    	mail,news.none		-/var/log/messages
    
    #
    # Emergencies are sent to everybody logged in.
    #
    *.emerg				*
    
    #
    # I like to have messages displayed on the console, but only on a virtual
    # console I usually leave idle.
    #
    #daemon,mail.*;\
    #	news.=crit;news.=err;news.=notice;\
    #	*.=debug;*.=info;\
    #	*.=notice;*.=warn	/dev/tty8
    
    # The named pipe /dev/xconsole is for the `xconsole' utility.  To use it,
    # you must invoke `xconsole' with the `-file' option:
    # 
    #    $ xconsole -file /dev/xconsole [...]
    #
    # NOTE: adjust the list below, or you'll go crazy if you have a reasonably
    #      busy site..
    #
    daemon.*;mail.*;\
    	news.err;\
    	*.=debug;*.=info;\
    	*.=notice;*.=warn	|/dev/xconsole
    all need to be logged on 1st server then i think that the 1st server ip need to be placed on rsyslog, but no ip show on configuration.

    can you help me?

  5. #5
    Join Date
    May 2011
    Posts
    9
    Rep Power
    4

    Default

    any news guys???

    pls advice

Similar Threads

  1. server status page in admin console shows red
    By ben1967 in forum Administrators
    Replies: 0
    Last Post: 05-12-2011, 12:14 PM
  2. Mailbox Stopped zmmailboxdctl is not running
    By kallicho in forum Administrators
    Replies: 5
    Last Post: 01-14-2011, 06:10 AM
  3. [SOLVED] mysql.server not running
    By king0770 in forum Administrators
    Replies: 23
    Last Post: 07-25-2009, 04:07 PM
  4. LDAP Cannot bind on migration to new server
    By neekster in forum Migration
    Replies: 23
    Last Post: 03-09-2009, 03:08 AM
  5. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 09:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •