I'm still having trouble getting things going. I believe I have everything configured properly, but the mail just isn't getting sent.

Relevant lines from /var/log/zimbra.log when I attempt to send mail to the list

Oct 18 18:16:19 cssc postfix/smtpd[11465]: connect from my.server.net[66.34.60.1]

Oct 18 18:16:19 cssc postfix/trivial-rewrite[11467]: warning: do not list domain server.com in BOTH mydestination and virtual_mailbox_domains
Oct 18 18:16:19 cssc postfix/trivial-rewrite[11467]: warning: do not list domain server.com in BOTH mydestination and virtual_mailbox_domains
...
Oct 18 18:16:20 cssc amavis[6532]: (06532-01) FWD via SMTP: <user@domain.com> -> <list@domain.com>, 250 2.6.0 Ok, id=06532-01, from MTA([127.0.0.1]:10025): 250 Ok: queued as 0EC54ED06BD
Oct 18 18:16:20 cssc amavis[6532]: (06532-01) Passed CLEAN, [66.34.60.1] [66.34.60.1] <user@domain.com> -> <list@domain.com>, Message-ID: <2969645.31161213379366.JavaMail.root@my.server.ne t>, mail_id: THs2mFclTyrS, Hits: -1.54, 465 ms
Oct 18 18:16:20 cssc postfix/smtp[11469]: A2341ED06BC: to=<list@domain.com>, relay=127.0.0.1[127.0.0.1], delay=1, status=sent (250 2.6.0 Ok, id=06532-01, from MTA([127.0.0.1]:10025): 250 Ok: queued as 0EC54ED06BD)
...

Oct 18 18:16:21 cssc postfix/local[11792]: 0EC54ED06BD: to=<list@domain.com>, relay=local, delay=1, status=sent (delivered to command: /usr/local/mailman/mail/mailman post list)
Oct 18 18:16:21 cssc postfix/qmgr[7697]: 0EC54ED06BD: removed

so right there, it's being sent, and mailman is processing it. that's good.

From the log file in /opt/zimbra/log/zimbra.log

2006-10-18 18:22:47,060 INFO [http-8080-Processor99] [mid=2;ip=69.168.6.158;name=user@domain.com;] SendMsg - <SendMsg> LC(mbox=9bf45b17-39af-44f6-baeb-30fa107d9944, sessions=[1])
2006-10-18 18:22:47,093 INFO [http-8080-Processor99] [mid=2;ip=69.168.6.158;name=user@domain.com;] FileBlobStore - Stored size=375 wrote=375 path=/opt/zimbra/store/incoming/1161212580624-5.msg vol=1 digest=2I6zqqXShjuSH+Pm39xaO2h0zv0=
2006-10-18 18:22:47,112 INFO [http-8080-Processor99] [mid=2;ip=69.168.6.158;name=user@domain.com;] FileBlobStore - Renamed id=2443 mbox=2 oldpath=/opt/zimbra/store/incoming/1161212580624-5.msg newpath=/opt/zimbra/store/0/2/msg/0/2443-5604.msg
2006-10-18 18:22:47,234 INFO [http-8080-Processor99] [mid=2;ip=69.168.6.158;name=user@domain.com;] mailbox - Added message id=2443 digest=2I6zqqXShjuSH+Pm39xaO2h0zv0= mailbox=2 rcpt=:API:


so if I look in /opt/zimbra/store/0/2/msg/0/ for my message, I see it there. i assume that's good too -- but it never winds up in my mailbox.

nothing of note in the mailman error log.

i have subscribers on this list on the local machine, and in the outside world. the mail never makes it, nor is it put into mailman's archives.

i've tried with and without the mydestination line in the main.cf. the results above are with. pretty much the same behavior without the line though.

does anyone have any idea what else might be wrong, why mail isn't getting delivered, or where else i can look to diagnose what the problem is?

Thanks in advance..