Results 1 to 2 of 2

Thread: Zimbra does not notify us when MX lookup failed.

  1. #1
    Join Date
    May 2011
    Posts
    1
    Rep Power
    4

    Default Zimbra does not notify us when MX lookup failed.

    Had a problem today where our DNS server did not resolve the MX record of the domain of an email address we are trying to send to. The DNS server has been fix now, but the problem with Zimbra is that we are not aware of this problem until one of our client said that they did not get an email from us.

    Now if I do send an email to invalid@invalid.invalid, zimbra does tell us about this in an email:

    Code:
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to postmaster.
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                       The mail system
    
    <invalid@invalid.invalid>: Host or domain name not found. Name service error
        for name=invalid.invalid type=A: Host not found
    Is it possible to configure Zimbra to send us a message if it for any reason were not able to send an email?

    Relevant logs: (client address replaced by example@example.org)

    Code:
    May 30 15:53:29 zimbra postfix/smtp[5974]: 0FA8F9E0333:
    to=<example@example.org>, relay=none, delay=0.04,
    delays=0.01/0.01/0.02/0, dsn=4.4.3, status=deferred (Host or domain name not
    found. Name service error for name=example.org type=MX: Host not found,
    try again)
    
    May 30 16:01:19 zimbra postfix/smtp[8009]: 0FA8F9E0333:
    to=<example@example.org>, relay=none, delay=470, delays=470/0.01/0/0,
    dsn=4.4.3, status=deferred (Host or domain name not found. Name service
    error for name=example.org type=MX: Host not found, try again)
    
    May 31 15:14:40 zimbra postfix/smtp[13238]: F3E429E04CF:
    to=<invalid@invalid.invalid>, relay=none, delay=0.25, de
    lays=0/0/0.24/0, dsn=5.4.4, status=bounced (Host or domain name not found.
    Name service error for name=invalid.in
    valid type=A: Host not found)

  2. #2
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    You may want to lower your delay warning time as described here.

Similar Threads

  1. Replies: 12
    Last Post: 02-25-2008, 06:28 PM
  2. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  3. Replies: 8
    Last Post: 02-27-2007, 03:10 AM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 12:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •