Results 1 to 10 of 10

Thread: Stats stop reason?

  1. #1
    Join Date
    Feb 2009
    Location
    Singapore
    Posts
    503
    Rep Power
    7

    Default Stats stop reason?

    Our Zimbra Server stats services used to keep stopping every few days in the past. We resolve it temporary by restarting the services:

    zmcontrol stop
    zmcontrol start

    At one time, restarting the service could not get it running again and it was found that wrong permission caused it: http://www.zimbra.com/forums/adminis...-stopping.html

    The weird thing is why is the wrong permission suddenly happen when we did not do any permission amendment?

    Yesterday, our stats got stopped again. I search the forum and found that swap storage may cause this: http://www.zimbra.com/forums/adminis...annot-run.html

    Is this normal?

    btw, is it possible to restart just the stats service without having to stop all the services? This is to minimize affecting our users even if it's just a short downtime.

  2. #2
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    214
    Rep Power
    6

    Default

    Not much help, but I've given up on stats in our 6 server ZCS6 deployment. It will die sooner or later, no matter what you do (I've tried, really).

    Otherwise, I'm a perfectly happy ZCS admin by the way

  3. #3
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    5

    Default

    Quote Originally Posted by bhwong View Post
    btw, is it possible to restart just the stats service without having to stop all the services? This is to minimize affecting our users even if it's just a short downtime.
    su - zimbra ; zmstatctl stop/start

  4. #4
    Join Date
    Feb 2009
    Location
    Singapore
    Posts
    503
    Rep Power
    7

    Default

    Thanks fyd. However, I can't restart stats service this time...again. And it's not permission or swap storage issue. What could be the problem this time? Do I have to restart the whole server just to get it up?

    Maybe I should just give up on this like Hivos did.

  5. #5
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    5

    Default

    Quote Originally Posted by bhwong View Post
    Thanks fyd. However, I can't restart stats service this time...again. And it's not permission or swap storage issue. What could be the problem this time? Do I have to restart the whole server just to get it up?

    Maybe I should just give up on this like Hivos did.
    I think you shouldn't restart the whole server but look into what could be the problem with stats. Did you find anything in mailbox.log, or zimbra.log when the restart is done?

  6. #6
    Join Date
    Feb 2009
    Location
    Singapore
    Posts
    503
    Rep Power
    7

    Default

    Here's the log from Zimbra.log just minutes before the stats is stopped:

    May 31 23:59:13 zimbra postfix/smtpd[11861]: warning: 118.68.159.134: hostname adsl-dynamic-pool-xxx.hcm.fpt.vn verification failed: Name or service not known
    May 31 23:59:13 zimbra postfix/smtpd[11861]: connect from unknown[118.68.159.134]
    May 31 23:59:15 zimbra postfix/smtpd[11861]: NOQUEUE: reject: RCPT from unknown[118.68.159.134]: 554 5.7.1 Service unavailable; Client host [118.68.159.134] blocked using zen.spamhaus.org; http://www.spamhaus.org/query/bl?ip=118.68.159.134; from=<boomqi267@remni-avtovoz.ru> to=<biopolis3@crescendas.sg> proto=ESMTP helo=<dynamic-pool-xxx.hcm.fpt.vn>
    May 31 23:59:21 zimbra postfix/smtpd[11861]: lost connection after DATA from unknown[118.68.159.134]
    May 31 23:59:21 zimbra postfix/smtpd[11861]: disconnect from unknown[118.68.159.134]
    May 31 23:59:49 zimbra postfix/smtpd[11861]: warning: 118.68.159.134: hostname adsl-dynamic-pool-xxx.hcm.fpt.vn verification failed: Name or service not known
    May 31 23:59:49 zimbra postfix/smtpd[11861]: connect from unknown[118.68.159.134]
    May 31 23:59:49 zimbra postfix/smtpd[11861]: NOQUEUE: reject: RCPT from unknown[118.68.159.134]: 554 5.7.1 Service unavailable; Client host [118.68.159.134] blocked using zen.spamhaus.org; http://www.spamhaus.org/query/bl?ip=118.68.159.134; from=<crabbiestn941@tisasoft.ru> to=<biopolis3@crescendas.sg> proto=ESMTP helo=<dynamic-pool-xxx.hcm.fpt.vn>
    May 31 23:59:50 zimbra postfix/smtpd[11861]: lost connection after DATA from unknown[118.68.159.134]
    May 31 23:59:50 zimbra postfix/smtpd[11861]: disconnect from unknown[118.68.159.134]
    Jun 1 00:00:02 zimbra zimbramon[17074]: 17074:info: 2011-06-01 00:00:01, QUEUE: 44 7
    Jun 1 00:00:07 zimbra zmmailboxdmgr[18036]: status requested
    Jun 1 00:00:07 zimbra zmmailboxdmgr[18036]: status OK
    Jun 1 00:00:19 zimbra zimbramon[3603]: 3603:err: Service status change: zimbra.dc1.crescendas.com stats changed from running to stopped

  7. #7
    Join Date
    Feb 2009
    Location
    Singapore
    Posts
    503
    Rep Power
    7

    Default

    zmstat.out is filled with:

    Use of uninitialized value in subtraction (-) at /opt/zimbra/libexec/zmstat-allprocs line 118.

    and:

    sh: /opt/zimbra/zmstat//2011-05-31/xxx.csv.gz: Permission denied
    Unable to move /opt/zimbra/zmstat/xxx.csv to /opt/zimbra/zmstat//2011-05-31/xxx.csv.gz at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Zmstat.pm line 256.

  8. #8
    Join Date
    Feb 2009
    Location
    Singapore
    Posts
    503
    Rep Power
    7

    Default

    Ok, problem solved. It's permission issue again: http://www.zimbra.com/forums/adminis...rmissions.html

    I notice 2011-05-31 and all June folders are having root:root instead of Zimbra:Zimbra permission.

    I can start stats after typing this command as root:

    chown -R zimbra.zimbra /opt/zimbra/zmstat/2010-*

  9. #9
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    5

    Default

    Quote Originally Posted by bhwong View Post
    zmstat.out is filled with:

    Use of uninitialized value in subtraction (-) at /opt/zimbra/libexec/zmstat-allprocs line 118.

    and:

    sh: /opt/zimbra/zmstat//2011-05-31/xxx.csv.gz: Permission denied
    Unable to move /opt/zimbra/zmstat/xxx.csv to /opt/zimbra/zmstat//2011-05-31/xxx.csv.gz at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Zmstat.pm line 256.
    Good find bhwong!!

  10. #10
    Join Date
    Feb 2009
    Location
    Singapore
    Posts
    503
    Rep Power
    7

    Default

    Our stats stop running again! This time, I found out that zmstat-fd-real.pid is owned by root:root under /opt/zimbra/zmstat/pid and despite changing ownership to zimbra:zimbra, whenever I execute zmstatctl start, it will automatically changed back to root:root! So frustrating!

    zmstatctl status reveal this:

    process xxxx in /opt/zimbra/zmstat/pid/zmstat-df.pid not running.

    btw, heard that this bug is resolved in version 6.0.7. Anyone can verify this?

Similar Threads

  1. Zimbra .pids / service monitoring
    By bin2hex in forum Administrators
    Replies: 24
    Last Post: 04-03-2010, 09:12 PM
  2. stats Stopped but not really
    By mcesari in forum Administrators
    Replies: 0
    Last Post: 01-29-2008, 07:29 AM
  3. zmlogger not stopping on zimbra stop
    By holunde in forum Installation
    Replies: 2
    Last Post: 12-17-2007, 04:27 PM
  4. Web client logon fails (INVALID_PDU)
    By jermxx in forum Installation
    Replies: 8
    Last Post: 02-20-2007, 01:20 PM
  5. Tomcat broken after upgrade to 4
    By dotslashroot in forum Migration
    Replies: 13
    Last Post: 01-31-2007, 05:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •