Results 1 to 2 of 2

Thread: Java out of memory error

  1. #1
    Join Date
    Nov 2005
    Posts
    175
    Rep Power
    10

    Default Java out of memory error

    Hey guys,

    About an hour ago, out of nowhere we had a problem start where the mailbox service would quit running. The pertinent section of mailbox.log is as follows --

    2011-06-02 15:07:29,410 INFO [main] [] index - Initialized Index for mailbox 42 directory: LuceneIndex{mbox=42, dir=org.apache.lucene.store.NIOFSDirectory@/opt/zimbra/index/0/42/index/0 lockFactory=org.apache.lucene.store.SingleInstance LockFactory@2f8bbc98} Analyzer=com.zimbra.cs.index.ZimbraAnalyzer@226e85 04
    2011-06-02 15:07:29,410 INFO [main] [] cache - initializing folder and tag caches for mailbox 42
    2011-06-02 15:07:29,540 INFO [main] [] mbxmgr - Mailbox 42 account 7d0f742b-6483-4f12-834c-d77149c45f96 LOADED
    2011-06-02 15:07:29,726 INFO [main] [] cache - setting message cache size to 2000
    2011-06-02 15:07:30,046 INFO [main] [] zimlet - Loaded class com.zimbra.cs.zimlet.handler.NANPHandler
    2011-06-02 15:07:30,049 INFO [main] [] zimlet - Loaded class com.zimbra.cs.zimlet.handler.RegexHandler
    2011-06-02 15:07:42,902 FATAL [main] [] system - out of memory
    java.lang.OutOfMemoryError: Java heap space
    at java.util.Arrays.copyOf(Arrays.java:2882)
    at java.lang.AbstractStringBuilder.expandCapacity(Abs tractStringBuilder.java:100)
    at java.lang.AbstractStringBuilder.append(AbstractStr ingBuilder.java:390)
    at java.lang.StringBuilder.append(StringBuilder.java: 119)
    at java.lang.StringBuilder.append(StringBuilder.java: 115)
    at com.zimbra.common.util.StringUtil.join(StringUtil. java:658)
    at com.zimbra.cs.mime.ParsedMessage.getMainBodyLucene Document(ParsedMessage.java:896)
    at com.zimbra.cs.mime.ParsedMessage.analyzeNonBodyPar ts(ParsedMessage.java:413)
    at com.zimbra.cs.mime.ParsedMessage.analyzeFully(Pars edMessage.java:439)
    at com.zimbra.cs.mailbox.Message.generateIndexData(Me ssage.java:1078)
    at com.zimbra.cs.mailbox.IndexHelper.indexItemList(In dexHelper.java:844)
    at com.zimbra.cs.mailbox.IndexHelper.indexDeferredIte msInternal(IndexHelper.java:361)
    at com.zimbra.cs.mailbox.IndexHelper.indexDeferredIte ms(IndexHelper.java:278)
    at com.zimbra.cs.mailbox.IndexHelper.maybeIndexDeferr edItems(IndexHelper.java:234)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:4665)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:4658)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:4646)
    at com.zimbra.cs.redolog.op.CreateMessage.redo(Create Message.java:427)
    at com.zimbra.cs.redolog.RedoPlayer.runCrashRecovery( RedoPlayer.java:420)
    at com.zimbra.cs.redolog.RedoLogManager.start(RedoLog Manager.java:229)
    at com.zimbra.cs.redolog.DefaultRedoLogProvider.start up(DefaultRedoLogProvider.java:41)
    at com.zimbra.cs.util.Zimbra.startup(Zimbra.java:215)
    at com.zimbra.cs.util.Zimbra.startup(Zimbra.java:123)
    at com.zimbra.soap.SoapServlet.init(SoapServlet.java: 128)
    at javax.servlet.GenericServlet.init(GenericServlet.j ava:241)
    at org.mortbay.jetty.servlet.ServletHolder.initServle t(ServletHolder.java:440)
    at org.mortbay.jetty.servlet.ServletHolder.doStart(Se rvletHolder.java:263)
    at org.mortbay.component.AbstractLifeCycle.start(Abst ractLifeCycle.java:50)
    at org.mortbay.jetty.servlet.ServletHandler.initializ e(ServletHandler.java:685)
    at org.mortbay.jetty.servlet.Context.startContext(Con text.java:140)
    at org.mortbay.jetty.webapp.WebAppContext.startContex t(WebAppContext.java:1254)
    at org.mortbay.jetty.handler.ContextHandler.doStart(C ontextHandler.java:517)

    The failure in the mailbox service obviously takes our mail server completely down. I see the "out of memory" error. I know at least that the server itself is not out of memory - I have 8GB memory and top shows 4GB free (not counting cached and buffers). Importantly, this error is ALWAYS triggered by the same mailbox. I was able to prevent the problem from happening by locking the account in question -- which is obviously only a temporary fix, since the account in question just so happens to be the CEO...

    zmcontrol -v

    Release 7.0.0_GA_3077.RHEL5_64_20110127201852 CentOS5_64 FOSS edition.

    Also, the mailbox is 20GB, but we have users with 40GB+ with no problem.
    Last edited by bjquinn; 06-02-2011 at 02:46 PM.

  2. #2
    Join Date
    Feb 2011
    Posts
    17
    Rep Power
    4

    Default

    I work with bjquinn

    to update ...

    we upgraded zimbra to 7.1.1 and it fixed the issue, I don't know the bug report off the top of my head but there is a test email included as an attachment that will crash the server.

Similar Threads

  1. Replies: 5
    Last Post: 05-11-2012, 03:16 PM
  2. [SOLVED] I broke my server trying to optimize... HELP!
    By myriad in forum Administrators
    Replies: 9
    Last Post: 09-17-2011, 07:46 AM
  3. Replies: 6
    Last Post: 03-14-2011, 05:21 AM
  4. [SOLVED] New zcs 7 install : database errors founds
    By dkbk in forum Administrators
    Replies: 4
    Last Post: 03-01-2011, 06:49 AM
  5. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •