Results 1 to 2 of 2

Thread: mailboxd/zmmailboxdctl won't start - "Invalid initial eden size"

  1. #1
    Join Date
    Apr 2011
    Posts
    4
    Rep Power
    4

    Default mailboxd/zmmailboxdctl won't start - "Invalid initial eden size"

    I'm running Zimbra 7.1 OSE on OpenVZ on CentOS 5.4. I know this is not an officially supported platform but it is the only option we have at the moment. I was doing a local backup using rsync and the disk ran out of space. We added more disk space for the VM but then Zimbra would not restart. After tweaking a number of settings, bumping the RAM up higher in the VM and significantly increasing the privvmpages for the VM, everything starts except mailboxd:

    Code:
    ./zmcontrol status
    Host es1.insightls.com
    	antispam                Running
    	antivirus               Running
    	imapproxy               Running
    	ldap                    Running
    	logger                  Running
    	mailbox                 Stopped
    		zmmailboxdctl is not running.
    	memcached               Running
    	mta                     Running
    	snmp                    Running
    	spell                   Running
    	stats                   Running
    	zmconfigd               Running
    When I check the mailboxd.out file, the last entries all show this:

    Code:
    Invalid initial eden size: -Xmn0m
    Could not create the Java virtual machine.
    I have no idea where to look to fix this. Any ideas?

  2. #2
    Join Date
    Apr 2011
    Posts
    4
    Rep Power
    4

    Default

    Fixed it. It turns out we had tweaked some settings too low and returning them to the defaults solved the problem:

    Code:
    zmlocalconfig -e mailboxd_java_heap_new_size_percent=25
    zmlocalconfig -e mailboxd_java_heap_size=1971

Similar Threads

  1. The installer was interrupted...
    By spiderbo in forum Zimbra Connector for Outlook
    Replies: 9
    Last Post: 05-23-2013, 07:33 AM
  2. Errors installing Outlook Connector
    By Tim G in forum Zimbra Connector for Outlook
    Replies: 57
    Last Post: 05-05-2011, 03:27 PM
  3. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  4. Error Installing Outlook Connector
    By DanO in forum Zimbra Connector for Outlook
    Replies: 17
    Last Post: 08-28-2007, 10:35 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •