Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: [SOLVED] Very high CPU usage with 7.1.1

  1. #11
    Join Date
    Jun 2011
    Posts
    7
    Rep Power
    4

    Default

    Just little thing...

    After apply PATCH 2 for 7.1.1 my cpu start again to overload et ~40% of cpu.. I saw that zmconfigd not running... even after the patch.

    I read and read i that forum and find someone that wrote to install "nc"

    So i did:

    Code:
    yum install nc
    
    /etc/init.d/zimbra restart
    And now.. zmconfigd is running and my cpu back to ~5% usage... i don't really understand but it work..

  2. #12
    Join Date
    Jun 2011
    Posts
    68
    Rep Power
    4

    Default

    i cant see how installing nc would have resolved this... - what made you even think of installing it in the first place? - sounds like coincidence if yours was working fine

  3. #13
    Join Date
    Jun 2011
    Posts
    7
    Rep Power
    4

    Default

    You right is may be a coincidence... and still not sure of the cause of this problem.

    Is where i read not information.. why zmconfigd is not running.. how to fix it.. ?

    http://www.zimbra.com/forums/adminis...sible-fix.html
    Attached Images Attached Images

  4. #14
    Join Date
    Aug 2011
    Posts
    1
    Rep Power
    4

    Default

    i'm on Release 7.1.2_GA_3268.RHEL6_64_20110804131406 UNKNOWN_64 FOSS edition.

    Nothing worked to fix the problem so i reverted to a script to kill the zimbra log process that uses all the CPU. It's a bit brute force, but that's the only thing that works. I schedule that script in the cron every 15minutes.


    kill_high_cpu_zimbra_log.pl
    -------------------------------------------
    #!/usr/bin/perl
    my $loop=0;
    # get process from zimbra user that uses more than 95% cpu
    my $cpuhigh=&check_zimbra_log();
    # if none
    if ($cpuhigh<0) {
    print "all good\n";
    exit;
    }
    # loop 5 times with a sleep of 5 check the same process is still high, then kill -9
    while ((&check_zimbra_log()==$cpuhigh) && ($loop<5))
    {
    print "HIGH : pid=$cpuhigh - loop $loop\n";
    $loop++;
    print "sleep 5\n";
    sleep 5;
    if ($loop==5) {
    my $kill="kill -9 $cpuhigh";
    print "$kill\n";
    `$kill`;
    }
    }

    # --------------
    # return pid or -1
    sub check_zimbra_log ()
    {
    my $cmd="ps axo pid,user,pcpu,cmd | grep zimbra | sort -n -k 3 | tail -1";
    my $cmd_res=`$cmd`;
    my $res=0;

    if ($cmd_res=~/([0-9]+) zimbra[\s]+([0-9\.]+)(.*)/) {
    $res=$1;
    my $cpu=int($2);
    if ($cpu>95) {
    if (index($cmd_res,"java -XX:ErrorFile=/opt/zimbra/log")>0) {
    return $res;
    }
    }
    }
    $return -1;
    }
    #------------------------

  5. #15
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by espresscafe View Post
    i'm on Release 7.1.2_GA_3268.RHEL6_64_20110804131406 UNKNOWN_64 FOSS edition.
    You don't mention whether you've applied any of the patches to your installed version, in any case I'd suggest you upgrade to the most recent release of Zimbra and see if it still occurs.
    Last edited by phoenix; 11-20-2011 at 08:53 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #16
    Join Date
    Nov 2011
    Posts
    3
    Rep Power
    3

    Unhappy Same problem here

    Hi,

    I have a zimbra installation (Open Source server) v7.1.3 on Ubuntu 10.04.1 x64.

    I am also experiencing this memory problem...

    top - 17:16:04 up 3 days, 3:19, 2 users, load average: 60.31, 60.04, 60.68
    Tasks: 572 total, 2 running, 570 sleeping, 0 stopped, 0 zombie
    Cpu(s): 1.1%us, 2.7%sy, 0.0%ni, 83.9%id, 12.1%wa, 0.1%hi, 0.1%si, 0.0%st
    Mem: 8178456k total, 7558816k used, 619640k free, 124396k buffers
    Swap: 19780600k total, 17148k used, 19763452k free, 3152192k cached

    This is a dedicated server with no other services running, only Zimbra Open Source edition.

    The server is shutting down at random (when there is no more memory).

    Any ideas?

Similar Threads

  1. High CPU usage on server and client
    By jack-Z in forum Administrators
    Replies: 10
    Last Post: 01-07-2009, 09:12 PM
  2. Replies: 8
    Last Post: 08-08-2008, 06:18 AM
  3. tomcat/catalina frozen with high cpu
    By eddie in forum Installation
    Replies: 5
    Last Post: 09-22-2006, 05:21 AM
  4. HIGH CPU use
    By brwatters in forum Administrators
    Replies: 3
    Last Post: 07-05-2006, 08:47 AM
  5. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •