Results 1 to 7 of 7

Thread: cannot start postfix

  1. #1
    Join Date
    Dec 2009
    Posts
    4
    Rep Power
    5

    Default cannot start postfix

    Hi

    I have had Zimbra running for year on an Ubuntu 8.04 box. Recently the SSL cert expired. I have followed a number of suggestions in this forum including running as root /opt/zimbra/libexec/zmfixperms and even re-running the installation from the original tarball I used when I set this up.

    My system is using Release 6.0.6_GA_2330.UBUNTU8_64 UBUNTU8_64 FOSS edition.

    I have attached the zimbra.log snippets from running : zimbra@mail:~$ zmcontrol start (zimbra.log.startup.txt) and the output of zimbra@mail:~$ zmcontrol status (zmcontrol.status.txt)

    It looks like postfix is already running but when I issue a zimbra@mail:~$ zmcontrol stop then check there is no postfix process.

    Can anyone suggest to me how to fix this?

    regards
    Attached Files Attached Files

  2. #2
    Join Date
    Apr 2010
    Location
    Germany
    Posts
    28
    Rep Power
    5

    Default

    Hi Paul,

    looking in your logfiles you can read, that postfix is already running ..
    Jun 16 16:58:40 mail postfix/postfix-script[6717]: fatal: the Postfix mail system is already running
    ZCS has an own postfixserver.
    And this zimbra-postfix wont start, if there is another postfix installed and running.
    So please check the following:

    # apt-show-versions -r postfix

    And if listed, then remove:

    # apt-get install postfix-

  3. #3
    Join Date
    Dec 2009
    Posts
    4
    Rep Power
    5

    Default

    Thanks for that firemike,

    root@mail:~# apt-show-versions -r postfix

    returns nothing...

    What is strange it that it was working for a year. I have not installed postfix outside of the ZCS installation. Could running the installer again have somehow caused this?

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by paulororke View Post
    I have not installed postfix outside of the ZCS installation. Could running the installer again have somehow caused this?
    Run the following command:

    Code:
    zmcontrol stop
    When you've done that, check to see if there are any zimbra services (or postfix) still running and kill them if there is. When you've done that try starting zimbra again.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Dec 2009
    Posts
    4
    Rep Power
    5

    Default

    Thanks for the suggestion. I had thought of that. In my original post I mentioned:

    It looks like postfix is already running but when I issue a zimbra@mail:~$ zmcontrol stop then check there is no postfix process.

    That's why I'm stuck...

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Are there any other Zimbra processes running after you stop Zimbra? Is there any other MTA running on port 25?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Dec 2009
    Posts
    4
    Rep Power
    5

    Default

    Hi Pheonix,

    Code:
    zimbra@mail:~$ zmcontrol stop
    Host mail.paulororke.net
            Stopping stats...Done.
            Stopping mta...Done.
            Stopping spell...Done.
            Stopping snmp...Done.
            Stopping archiving...Done.
            Stopping antivirus...Done.
            Stopping antispam...Done.
            Stopping imapproxy...Done.
            Stopping memcached...Done.
            Stopping mailbox...Done.
            Stopping logger...Done.
            Stopping ldap...Done.

    Code:
    zimbra@mail:~$ netstat --listening
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN
    Active UNIX domain sockets (only servers)
    Proto RefCnt Flags       Type       State         I-Node   Path
    Code:
    root@mail:~# ps aux
    USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
    root         1  0.0  0.0   4020   876 ?        Ss   Jun15   0:01 /sbin/init
    root         2  0.0  0.0      0     0 ?        S<   Jun15   0:00 [kthreadd]
    root         3  0.0  0.0      0     0 ?        S<   Jun15   5:02 [migration/0]
    root         4  0.0  0.0      0     0 ?        S<   Jun15   0:13 [ksoftirqd/0]
    root         5  0.0  0.0      0     0 ?        S<   Jun15   0:00 [watchdog/0]
    root         6  0.0  0.0      0     0 ?        S<   Jun15   6:13 [migration/1]
    root         7  0.0  0.0      0     0 ?        S<   Jun15   0:12 [ksoftirqd/1]
    root         8  0.0  0.0      0     0 ?        S<   Jun15   0:00 [watchdog/1]
    root         9  0.0  0.0      0     0 ?        S<   Jun15   0:11 [events/0]
    root        10  0.0  0.0      0     0 ?        S<   Jun15   0:21 [events/1]
    root        11  0.0  0.0      0     0 ?        S<   Jun15   0:00 [khelper]
    root        44  0.0  0.0      0     0 ?        S<   Jun15   0:17 [kblockd/0]
    root        45  0.0  0.0      0     0 ?        S<   Jun15   0:15 [kblockd/1]
    root        48  0.0  0.0      0     0 ?        S<   Jun15   0:00 [kacpid]
    root        49  0.0  0.0      0     0 ?        S<   Jun15   0:00 [kacpi_notify]
    root       181  0.0  0.0      0     0 ?        S<   Jun15   0:00 [kseriod]
    root       230  0.0  0.0      0     0 ?        S<   Jun15   0:00 [kswapd0]
    root       273  0.0  0.0      0     0 ?        S<   Jun15   0:00 [aio/0]
    root       274  0.0  0.0      0     0 ?        S<   Jun15   0:00 [aio/1]
    root      1017  0.0  0.0      0     0 ?        S    Jun19   0:34 [pdflush]
    root      1319  0.0  0.0      0     0 ?        S<   Jun15   0:00 [ksnapd]
    root      1542  0.0  0.0      0     0 ?        S<   Jun15   0:00 [ata/0]
    root      1543  0.0  0.0      0     0 ?        S<   Jun15   0:00 [ata/1]
    root      1544  0.0  0.0      0     0 ?        S<   Jun15   0:00 [ata_aux]
    root      1555  0.0  0.0      0     0 ?        S<   Jun15   0:00 [scsi_eh_0]
    root      1556  0.0  0.0      0     0 ?        S<   Jun15   0:00 [scsi_eh_1]
    root      1593  0.0  0.0      0     0 ?        S<   Jun15   0:00 [ksuspend_usbd]
    root      1598  0.0  0.0      0     0 ?        S<   Jun15   0:00 [khubd]
    root      2489  0.0  0.0      0     0 ?        S<   Jun15   0:00 [scsi_eh_2]
    root      2711  0.0  0.0      0     0 ?        S<   Jun15   6:59 [kjournald]
    root      2867  0.0  0.0  16868   980 ?        S<s  Jun15   0:03 /sbin/udevd --daemon
    root      3317  0.0  0.0      0     0 ?        S<   Jun15   0:00 [kpsmoused]
    root      4296  0.0  0.0      0     0 ?        S<   Jun15   0:00 [kjournald]
    root      4302  0.0  0.0      0     0 ?        S<   Jun15   0:00 [vmhgfs]
    root      4622  0.0  0.0   3864   588 tty4     Ss+  Jun15   0:00 /sbin/getty 38400 tty4
    root      4623  0.0  0.0   3864   584 tty5     Ss+  Jun15   0:00 /sbin/getty 38400 tty5
    root      4626  0.0  0.0   3864   584 tty2     Ss+  Jun15   0:00 /sbin/getty 38400 tty2
    root      4632  0.0  0.0   3864   588 tty3     Ss+  Jun15   0:00 /sbin/getty 38400 tty3
    root      4634  0.0  0.0   3864   588 tty6     Ss+  Jun15   0:00 /sbin/getty 38400 tty6
    syslog    4673  0.0  0.0  12296   768 ?        Ss   Jun15   1:31 /sbin/syslogd -u syslog
    root      4692  0.0  0.0   8132   588 ?        S    Jun15   0:00 /bin/dd bs 1 if /proc/kmsg of /var/run/klogd/kmsg
    klog      4694  0.0  0.1   6004  2752 ?        Ss   Jun15   0:00 /sbin/klogd -P /var/run/klogd/kmsg
    root      4860  0.0  0.0      0     0 ?        S<   Jun15   0:21 [vmmemctl]
    root      4969  0.1  0.0  22960  1428 ?        Ss   Jun15  10:50 /usr/lib/vmware-tools/sbin64/vmware-guestd --background /var/run/vmware-guestd.pid
    daemon    5011  0.0  0.0  16428   432 ?        Ss   Jun15   0:00 /usr/sbin/atd
    root      5022  0.0  0.0  18616   984 ?        Ss   Jun15   0:07 /usr/sbin/cron
    root     12578  0.0  0.0   3864   584 tty1     Ss+  Jun15   0:00 /sbin/getty 38400 tty1
    root     14054  0.0  0.1  67972  2904 ?        Ss   13:46   0:00 sshd: paul [priv]
    paul     14139  0.0  0.0  68112  1780 ?        R    13:46   0:00 sshd: paul@pts/0
    paul     14143  0.1  0.1  20616  3572 pts/0    Ss   13:46   0:00 -bash
    root     14301  0.0  0.0  34540  1364 pts/0    S    13:46   0:00 su -
    root     14454  0.0  0.0  18868  2052 pts/0    S    13:46   0:00 -su
    root     18602  0.0  0.0  15064  1092 pts/0    R+   14:01   0:00 ps aux
    root     25488  0.0  0.0      0     0 ?        S    Jun18   0:25 [pdflush]
    root     27667  0.0  0.0  50916  1160 ?        Ss   Jun16   0:00 /usr/sbin/sshd
    root@mail:~#
    Sure looks to me like everyting is stopped. I appreciate your input.

Similar Threads

  1. postdrop fail to create file after upgrade to 5.0.3
    By echoadisan in forum Installation
    Replies: 23
    Last Post: 07-15-2013, 04:02 PM
  2. The installer was interrupted...
    By spiderbo in forum Zimbra Connector for Outlook
    Replies: 9
    Last Post: 05-23-2013, 07:33 AM
  3. Unable to start Postfix & Mailbox + trouble on upgrade
    By tamilnandhu in forum Installation
    Replies: 8
    Last Post: 11-01-2007, 10:40 AM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •