Results 1 to 5 of 5

Thread: GAL Sync / No Such Contact Error

  1. #1
    Join Date
    Sep 2008
    Rep Power

    Default GAL Sync / No Such Contact Error


    I'm having some trouble with my GAL lately. For some reason a contact is missing and I would like to know how I can rebuild the galsync list or fix this issue some other way. Details below:

    2011-06-18 09:36:02,178 INFO [ScheduledTask-6] [;mid=78;ds=_intern al;] datasource - Requested import.
    2011-06-18 09:36:02,178 INFO [ScheduledTask-6] [;mid=78;ds=_intern al;] datasource - Importing data for data source '_internal'
    2011-06-18 09:36:02,317 ERROR [ScheduledTask-6] [;mid=78;ds=_intern al;] gal - Error executing gal search
    com.zimbra.cs.mailbox.MailServiceException$NoSuchI temException: no such contact: 6496
    Code:mail.NO_SUCH_CONTACT ArgitemId, IID, "6496")
    at com.zimbra.cs.mailbox.MailServiceException.NO_SUCH _CONTACT(
    at com.zimbra.cs.mailbox.MailItem.noSuchItem(MailItem .java:1312)
    at com.zimbra.cs.db.DbMailItem.getById(DbMailItem.jav a:2282)
    at com.zimbra.cs.mailbox.MailItem.getById(MailItem.ja va:1251)
    at com.zimbra.cs.mailbox.MailItem.getById(MailItem.ja va:1247)
    at com.zimbra.cs.mailbox.Mailbox.getItemById(Mailbox. java:2092)
    at com.zimbra.cs.mailbox.Mailbox.getItemById(Mailbox. java:2063)
    at com.zimbra.cs.mailbox.Mailbox.getItemById(Mailbox. java:2054)
    at com.zimbra.cs.mailbox.Mailbox.getContactById(Mailb
    at$GalSearchVisitor.visit (
    at com.zimbra.cs.account.Provisioning$VisitorSearchGa lResult.addMatch(
    at com.zimbra.cs.account.ldap.LdapUtil.searchGal(Ldap
    at com.zimbra.cs.account.ldap.LdapUtil.doGalSearch(Ld
    at com.zimbra.cs.account.ldap.LdapUtil.galSearch(Ldap
    at va:149)
    at va:108)
    at ava:58)
    at com.zimbra.cs.datasource.DataSourceManager.importD ata(
    at com.zimbra.cs.datasource.DataSourceManager.importD ata(
    at com.zimbra.common.util.TaskScheduler$ ll(
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu
    at a:138)
    at java.util.concurrent.ScheduledThreadPoolExecutor$S cheduledFutureTask.access$301(ScheduledThreadPoolE
    at java.util.concurrent.ScheduledThreadPoolExecutor$S .java:206)
    at java.util.concurrent.ThreadPoolExecutor$ Task(
    at java.util.concurrent.ThreadPoolExecutor$ (
    2011-06-18 09:36:02,318 INFO [ScheduledTask-6] [;mid=78;ds=_intern al;] datasource - Import completed for data source '_internal'

  2. #2
    Join Date
    Jun 2011
    Rep Power


    I'm having a similar problem whith user account and I dont have solution. The problem occurs when send email, the user works only from webmail. I try reindexing mail account but isn't solution. The error is:

    method:	[unknown]
    msg:	no such contact: 183102
    code:	mail.NO_SUCH_CONTACT
    detail:	soap:Sender
    trace:	com.zimbra.cs.mailbox.MailServiceException$NoSuchItemException: no such contact: 183102 ExceptionId:btpool0-36537:// Code:mail.NO_SUCH_CONTACT ArgitemId, IID, "183102") at com.zimbra.cs.mailbox.MailServiceException.NO_SUCH_CONTACT( at com.zimbra.cs.mailbox.MailItem.noSuchItem( at com.zimbra.cs.db.DbMailItem.getById( at com.zimbra.cs.mailbox.MailItem.getById( at com.zimbra.cs.mailbox.MailItem.getById( at com.zimbra.cs.mailbox.Mailbox.getItemById( at com.zimbra.cs.mailbox.Mailbox.getItemById( at com.zimbra.cs.mailbox.Mailbox.getItemById( at com.zimbra.cs.mailbox.Mailbox.getContactById( at com.zimbra.cs.service.mail.ParseMimeMessage.attachContact( at com.zimbra.cs.service.mail.ParseMimeMessage.handleAttachments( at com.zimbra.cs.service.mail.ParseMimeMessage.parseMimeMsgSoap( at com.zimbra.cs.service.mail.ParseMimeMessage.parseMimeMsgSoap( at com.zimbra.cs.service.mail.SaveDraft.handle( at com.zimbra.soap.SoapEngine.dispatchRequest( at com.zimbra.soap.SoapEngine.dispatch( at com.zimbra.soap.SoapEngine.dispatch( at com.zimbra.soap.SoapServlet.doWork( at com.zimbra.soap.SoapServlet.doPost( at javax.servlet.http.HttpServlet.service( at com.zimbra.cs.servlet.ZimbraServlet.service( at javax.servlet.http.HttpServlet.service( at org.mortbay.jetty.servlet.ServletHolder.handle( at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter( at com.zimbra.cs.servlet.SetHeaderFilter.doFilter( at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter( at org.mortbay.servlet.UserAgentFilter.doFilter( at org.mortbay.servlet.GzipFilter.doFilter( at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter( at org.mortbay.jetty.servlet.ServletHandler.handle( at at org.mortbay.jetty.servlet.SessionHandler.handle( at org.mortbay.jetty.handler.ContextHandler.handle( at org.mortbay.jetty.webapp.WebAppContext.handle( at org.mortbay.jetty.handler.ContextHandlerCollection.handle( at org.mortbay.jetty.handler.HandlerCollection.handle( at org.mortbay.jetty.handler.HandlerWrapper.handle( at org.mortbay.jetty.handler.rewrite.RewriteHandler.handle( at org.mortbay.jetty.handler.HandlerWrapper.handle( at org.mortbay.jetty.handler.DebugHandler.handle( at org.mortbay.jetty.handler.HandlerWrapper.handle( at org.mortbay.jetty.Server.handle( at org.mortbay.jetty.HttpConnection.handleRequest( at org.mortbay.jetty.HttpConnection$RequestHandler.content( at org.mortbay.jetty.HttpParser.parseNext( at org.mortbay.jetty.HttpParser.parseAvailable( at org.mortbay.jetty.HttpConnection.handle( at at org.mortbay.thread.BoundedThreadPool$
    My Zimbra server is 7.0.0 64 Bits.

    Thanks a lot

  3. #3
    Join Date
    May 2010
    Rep Power



    I know its an older thread but i had that Problem today myself.

    In my Case it wasnt a GAL Issue even if it looks like.
    I had set to Upload a VCARD within my Signature

    For Some Reson that Contact was changed - which result in the Error

    Soooo with no such contact the VCARD Contact in the SIgnatue was ment not the GAL Contact

  4. #4
    andretapxure Guest


    I deleted the default signature and recreated then the problem is gone

  5. #5
    Join Date
    Aug 2011
    Rep Power


    We've seen this on a single user too - it was related no to Galsync but to a funky signature with a picture he had created. With a regular text signature everything went back to normal.

Similar Threads

  1. Replies: 5
    Last Post: 05-11-2012, 02:16 PM
  2. [SOLVED] I broke my server trying to optimize... HELP!
    By myriad in forum Administrators
    Replies: 9
    Last Post: 09-17-2011, 06:46 AM
  3. Replies: 6
    Last Post: 03-14-2011, 04:21 AM
  4. [SOLVED] New zcs 7 install : database errors founds
    By dkbk in forum Administrators
    Replies: 4
    Last Post: 03-01-2011, 05:49 AM
  5. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts