Results 1 to 8 of 8

Thread: [SOLVED] display first name and last name

  1. #1
    Join Date
    Jun 2011
    Posts
    3
    Rep Power
    4

    Default [SOLVED] display first name and last name

    Hi,

    I'm a newbie here. And I have to manage zimbra mail of one of my company's client. Right now, I've trying to find command on how to display the first name and last name of the user.

    like command 'zmprove -l gaa', it will display 'user@domain'.

    But in my situation, my client want it to display 'firstname lastname'. I'm using version,

    Release 6.0.7_GA_2470.RHEL4_64_20100610200901 CentOS4_64 NETWORK edition.

    I need help from anybody who can solve my problem. And your co-operation is highly appreciated.
    Thank you in advance.

  2. #2
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    5

    Default

    # su - zimbra
    $ zmprov ga user@domain displayName

    Its usually First name and Last name that make up the display name in zimbra. This command will give you that. To get all results of all accounts at once, run this script as zimbra user.
    $ for i in `zmprov -l gaa`; do zmprov ga $i displayName; done

    I hope this helps.

  3. #3
    Join Date
    Jun 2011
    Posts
    3
    Rep Power
    4

    Default

    thanks fyd for replying me.

    i've try the 'zmprov ga $i displayName' cmd that you give but there is an error display.


    ERROR: account.NO_SUCH_ACCOUNT (no such account: displayName)

    Is there any file or cmd that i have to use or to create before i can view all the user account in just only name without domain?

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by ainazmi View Post
    i've try the 'zmprov ga $i displayName' cmd that you give but there is an error display.
    That wasn't the command you were given, read the post again or the zmprov help.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    5

    Default

    Quote Originally Posted by ainazmi View Post
    thanks fyd for replying me.

    i've try the 'zmprov ga $i displayName' cmd that you give but there is an error display.


    ERROR: account.NO_SUCH_ACCOUNT (no such account: displayName)

    Is there any file or cmd that i have to use or to create before i can view all the user account in just only name without domain?
    Hey ainazmi,

    This is the actual command we have to run as user zimbra to get the result --- zmprov ga user@domain.com displayName

    Now we are going to get results for all accounts on your server. Use this command as zimbra user. Give this completely.
    for i in `zmprov -l gaa`; do zmprov ga $i displayName; done

  6. #6
    Join Date
    Jun 2011
    Posts
    3
    Rep Power
    4

    Default

    phoenix,
    sorry, my mistake. I thought 'for' and 'do' is to complete the sentence.

    fyd,
    i'm so sorry for not using the whole cmd that you give. my misunderstood.

    Thank you so much for helping to both of you.

  7. #7
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    5

    Default

    Quote Originally Posted by ainazmi View Post
    fyd,
    i'm so sorry for not using the whole cmd that you give. my misunderstood.

    Thank you so much for helping to both of you.
    Happy we could help you ainazmi, tc and good luck with your work.
    Last edited by fyd; 06-23-2011 at 04:14 PM.

  8. #8
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    5

    Default

    Quote Originally Posted by ainazmi View Post
    sorry, my mistake. I thought 'for' and 'do' is to complete the sentence.
    By the way, that says you are a good reader of commands. Cheers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •