Results 1 to 3 of 3

Thread: Postfix Fails to Start. Permission Errors

Hybrid View

  1. #1
    Join Date
    Jun 2011
    Posts
    2
    Rep Power
    4

    Exclamation Postfix Fails to Start. Permission Errors

    Hey all, I'm new here and am not totally sure whether or not to post this here. Awhile back, I had Zimbra 6 installed on an Ubuntu box with no problems. A couple days ago I decided to install Zimbra 7.1.1 on my new Ubuntu Server. The installation went fine and everything seemed to be working fine. After downloading some security updates to the system and rebooting I went to check on Zimbra with
    Code:
    zmcontrol status
    . I got this back:
    Code:
    Host oyster.andersentechwiki.net
    	antispam                Running
    	antivirus               Running
    	ldap                    Running
    	logger                  Running
    	mailbox                 Running
    	mta                     Stopped
    		postfix is not running
    	snmp                    Running
    	spell                   Running
    	stats                   Running
    	zmconfigd               Running
    I assumed that postfix just got skipped over in the startup for some reason. I went to start postfix manually and got a permissions error
    Code:
    postfix start
    postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.7.4.2z/conf/main.cf
    postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.7.4.2z/conf/master.cf
    I went online and found this script:
    Code:
    ./zmfixperms --extended --verbose
    I ran the script and then restarted Zimbra with the usually stop and start commands.

    I went to check the status and once again postfix wasn't started. I was a bit confused as the permissions were once again messed up. I ran
    Code:
    while sleep 1; do ls -l; done
    as root inside of the postfix directory. As I ran the zmcontrol start command I noticed that it changed the permissions. I manually changed the permissions to match the other files using
    Code:
    chown -R root:postfix ./master.cf
    chown -R root:postfix ./main.cf
    chmod +rw ./master.cf
    chmod +rw ./main.cf
    then I tried to start postfix manually. At that point the script didn't output anything and just seemed to hang there. I tried looking in the logfile
    Code:
    tail -f /var/log/zimbra.log
    but it was empty.

    At this point I'm out of ideas. Any suggestions?

  2. #2
    Join Date
    Jul 2007
    Posts
    17
    Rep Power
    8

    Default

    It is a bug in the fixperms scripts. Found this a few days back when the support team had to run the fixperms to solve another problem and it ended up causing postfix start to fail.

    Go to /opt/zimbra/data/postfix and set the following:

    chown postfixostfix master.lock
    chown postfixostfix prng_exch

    Also do the same in /opt/zimbra/data/postfix/data

    Why both I do not know.

    This should fix it though.

  3. #3
    Join Date
    Jun 2011
    Posts
    2
    Rep Power
    4

    Default

    Quote Originally Posted by stillaway View Post
    It is a bug in the fixperms scripts. Found this a few days back when the support team had to run the fixperms to solve another problem and it ended up causing postfix start to fail.

    Go to /opt/zimbra/data/postfix and set the following:

    chown postfixostfix master.lock
    chown postfixostfix prng_exch

    Also do the same in /opt/zimbra/data/postfix/data

    Why both I do not know.

    This should fix it though.
    I ran the commands
    Code:
    chown postfix:postfix master.lock 
    chown postfix:postfix prng_exch
    in the /opt/zimbra/data/postfix/data but I didn't find the files in /opt/zimbra/data/postfix I tried restarting to see if it worked, but sadly I'm stuck in the same stop.

Similar Threads

  1. postdrop fail to create file after upgrade to 5.0.3
    By echoadisan in forum Installation
    Replies: 23
    Last Post: 07-15-2013, 03:02 PM
  2. postdrop Permission denied errors
    By mrios in forum Administrators
    Replies: 3
    Last Post: 07-06-2013, 08:50 PM
  3. The installer was interrupted...
    By spiderbo in forum Zimbra Connector for Outlook
    Replies: 9
    Last Post: 05-23-2013, 06:33 AM
  4. Backup issues
    By telescop in forum Administrators
    Replies: 3
    Last Post: 03-01-2007, 05:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •