It looks like, since upgrading to zcs-NETWORK-7.0.1_GA_3105.UBUNTU8.20110304195620 in March, our HSM isn't working:

2011-06-30 03:22:14,568 WARN [BlobMover] [name=REDACTED;mid=1730;] hsm - Search 'before:-30day message:in:junk:before:-7day' failed. Skipping
at com.zimbra.cs.hsm.BlobMover.moveBlobs(BlobMover.ja va:166)
at com.zimbra.cs.hsm.BlobMoverThread.run(BlobMoverThr ead.java:95)
2011-06-30 03:22:14,568 INFO [BlobMover] [name=REDACTED;mid=1730;] hsm - Found no blobs that need to be moved.
2011-06-30 03:22:14,614 WARN [BlobMover] [name=REDACTED;mid=1754;] hsm - Search 'before:-30day message:in:junk:before:-7day' failed. Skipping
at com.zimbra.cs.hsm.BlobMover.moveBlobs(BlobMover.ja va:166)
at com.zimbra.cs.hsm.BlobMoverThread.run(BlobMoverThr ead.java:95)
2011-06-30 03:22:14,614 WARN [BlobMover] [name=REDACTED;mid=1754;] hsm - Search 'before:-30day message:in:junk:before:-7day' failed. Skipping
at com.zimbra.cs.hsm.BlobMover.moveBlobs(BlobMover.ja va:166)
at com.zimbra.cs.hsm.BlobMoverThread.run(BlobMoverThr ead.java:95)
2011-06-30 03:22:14,614 INFO [BlobMover] [name=REDACTED;mid=1754;] hsm - Found no blobs that need to be moved.
2011-06-30 03:22:14,661 WARN [BlobMover] [name=REDACTED;mid=2242;] hsm - Search 'before:-30day message:in:junk:before:-7day' failed. Skippin
at com.zimbra.cs.hsm.BlobMover.moveBlobs(BlobMover.ja va:166)
at com.zimbra.cs.hsm.BlobMoverThread.run(BlobMoverThr ead.java:95)

This happens for all accounts:

Last HSM Session Stats
----------------------
Start time: Thu Jun 30 03:22:12 EDT 2011
End time: Thu Jun 30 03:22:40 EDT 2011
Query :before:-30day message:in:junk:before:-7day
Not currently running.
Moved 0 blobs to volume 3.
Mailboxes processed: 673 out of 675.

No blobs are moved, and I don't see any having been moved since before the upgrade.

zmblobchk --incorrect-revision-rename-file --missing-blob-delete-item --no-export start

has been run. Anyone have any ideas?