Results 1 to 6 of 6

Thread: Delegated Admin can not create new Accounts

Hybrid View

  1. #1
    Join Date
    Jul 2006
    Location
    Stuttgart / Germany
    Posts
    223
    Rep Power
    9

    Default Delegated Admin can not create new Accounts

    Hi all,

    we are currently planning an update of one of our Zimbra Servers from 6.0.12 (NE) to 7.1.1 patch 2 (NE).
    As there are a lot of users on that machine I did some tests with 7.1.1.

    What I found out is, that it seems to be impossible for a delegated admin to create new accounts in 7.1.1.
    The delegated admin can modify existing accounts or delete existing accounts, but the button to
    create new account is not existent.

    I tested with a delegated admin who had the checkbox "Assign the default domain administrator view and rights"
    enabled, as well as a delegated admin with a specific set of rights including the "domainADminRights", "createAccount"
    and "domainADminCosRights". These Rights should be sufficient to create a new account...

    Can sombody confirm this behavior? Is this a bug or a feature that I have not fully understood :-)

    Regards
    Thomas

  2. #2
    Join Date
    Jul 2011
    Posts
    1
    Rep Power
    4

    Default

    Hello Thomas,

    We are Running 7.1.1 at the moment and we are experiencing the same issue. Our domain admins cannot create new accounts because the button has disappeared. All the rights have been set and haven't been changed after the update.

    I hope Zimbra will fix this bug soon.
    Last edited by marnux; 07-07-2011 at 07:47 AM. Reason: typo's

  3. #3
    Join Date
    Jul 2006
    Location
    Stuttgart / Germany
    Posts
    223
    Rep Power
    9

    Default

    Quote Originally Posted by marnux View Post
    Hello Thomas,

    We are Running 7.1.1 at the moment and we are experiencing the same issue. Our domain admins cannot create new accounts because the button has disappeard. All the rights have been set and haven't been changed after de update.

    I hope Zimbra will fix this bug soon.
    It's not really a bug. In the Admin UI edit the account of the delgated admin, go to "Admin Views" and add "Domain List View" which is disabled by default. Then click on "Configure Grants" and make sure the user has the "listDomain" right on the domain level.

    This should be enough for the delegated admin to create new accounts and dls.

    Regards
    Thomas

  4. #4
    Join Date
    Nov 2006
    Posts
    12
    Rep Power
    8

    Default

    Quote Originally Posted by deepblue View Post
    It's not really a bug. In the Admin UI edit the account of the delgated admin, go to "Admin Views" and add "Domain List View" which is disabled by default. Then click on "Configure Grants" and make sure the user has the "listDomain" right on the domain level.

    This should be enough for the delegated admin to create new accounts and dls.
    We have just come across this issue as well and I think it is a bug (in the upgrade scripts if nothing else).

    If I understand you correctly, to fix this we have to go into every delegated admin account across all the domains we host & manually add the Domain List View right to each of them.

    That is a royal pain to do manually across all the domains, is there any way to automate that process?

    thanks
    Ben Sommerville

  5. #5
    Join Date
    Mar 2006
    Location
    Greenwood, IN
    Posts
    90
    Rep Power
    9

    Default

    Try:

    Code:
    zmprov ma adminaccount@domain.com +zimbraAdminConsoleUIComponents domainListView

  6. #6
    Join Date
    Nov 2006
    Posts
    12
    Rep Power
    8

    Default

    Hi Iggy,

    Thanks that worked

    For anyone else who wants to do a bulk update, this script should work

    Code:
    #!/bin/sh
    
    for user_name in `/opt/zimbra/bin/zmprov -l gaaa` ; do
            echo "$user_name"
            /opt/zimbra/bin/zmprov ma $user_name +zimbraAdminConsoleUIComponents domainListView
    done
    cheers
    Ben

Similar Threads

  1. Does Admin, spam, ham, wiki count as licensed accounts?
    By ksebastiant in forum Administrators
    Replies: 2
    Last Post: 12-11-2007, 08:03 AM
  2. Cant send emails/Cant create accounts
    By Asish in forum Installation
    Replies: 8
    Last Post: 05-22-2007, 03:24 AM
  3. Can Not create new accounts 3.2.0_M2_224.FC4.
    By jdmonc in forum Administrators
    Replies: 3
    Last Post: 08-01-2006, 01:51 PM
  4. Replies: 4
    Last Post: 07-13-2006, 08:55 PM
  5. how to create admin from CLI
    By jonas in forum Administrators
    Replies: 1
    Last Post: 02-17-2006, 02:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •