Results 1 to 7 of 7

Thread: zmcontrol start - postfix still won't start

  1. #1
    Join Date
    Oct 2006
    Posts
    16
    Rep Power
    9

    Unhappy zmcontrol start - postfix still won't start

    I created a user postfix and placed it in the postfix group that Zimbra created . The error:
    Code:
            Starting spell...FAILED
    Syntax error on line 232 of /opt/zimbra/conf/httpd.conf:
    Cannot load /opt/zimbra/httpd-2.0.54/modules/libphp5.so into server: /opt/zimbra/httpd-2.0.54/modules/libphp5.so: cannot restore segment prot after reloc: Permission denied
    still occurs but I'll live without the spell checking.

    However, I know get the error:
    Code:
            Starting mta...FAILED
    postsuper: fatal: scan_dir_push: open directory defer: Permission denied
    postfix failed to start
    I had done
    Code:
    chown zimbra -R /opt/zimbra/
    Is there yet another user that needs creating?

  2. #2
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Not 100% sure, but you can try, as root:

    Code:
    cd /opt/zimbra/libexec
    ./zmfixperms
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  3. #3
    Join Date
    Oct 2006
    Posts
    16
    Rep Power
    9

    Smile zmfixperms

    still get the error with the spell ,
    but mta started

  4. #4
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Quote Originally Posted by crp
    still get the error with the spell ,
    but mta started

    Is the following same on your system?

    Code:
    [root@arihant libexec]# ls -al /opt/zimbra/httpd-2.0.54/modules/libphp5.so
    -rwxr-xr-x  1 zimbra zimbra 7366155 Jul 12 20:13 /opt/zimbra/httpd-2.0.54/modules/libphp5.so
    That is, same ownership and permissions?
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  5. #5
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    I found this thread on th fedora forums: http://forums.fedoraforum.org/showthread.php?t=59163
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  6. #6
    Join Date
    Oct 2006
    Posts
    16
    Rep Power
    9

    Default spoke too soon :(

    Quote Originally Posted by czaveri
    I found this thread on th fedora forums: http://forums.fedoraforum.org/showthread.php?t=59163
    This is the output after doing the chcon
    Code:
    [zimbra@xeons modules]$ ls --context
    -rw-r--r--  zimbra   zimbra   system_u:object_r:usr_t          httpd.exp
    -rwxr-xr-x  zimbra   zimbra   system_u:object_r:lib_t          libphp5.so
    but I still get the error message about
    Cannot load /opt/zimbra/httpd-2.0.54/modules/libphp5.so into server

    I can not make a connection to 7071/zimbraAdmin either.
    I guess the spell not loading is preventing apache.
    Code:
    Host xeons.afts.com
            antispam                Running
            antivirus               Running
            ldap                    Running
            logger                  Running
            mailbox                 Running
            mta                     Running
            snmp                    Running
            spell                   Stopped
                    zmapachectl is not running

  7. #7
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    It looks like apache does not have proper rights to load libphp.

    I am not particularly much acquainted with SELinux; so can't say whether these permissions are conservative or not.

    Can you not disable it for /opt/zimbra completely?
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. Zimbra .pids / service monitoring
    By bin2hex in forum Administrators
    Replies: 24
    Last Post: 04-03-2010, 10:12 PM
  3. Replies: 3
    Last Post: 11-03-2007, 11:55 PM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •