Results 1 to 4 of 4

Thread: 32-64 migration - Password problems?

  1. #1
    kbmunkholm Guest

    Default 32-64 migration - Password problems?

    I am trying to migrate up to the latest ZCS, starting at 5.x, 32 bit on Ubuntu 6.04 and moving to 5.x 64 bit on Ubuntu 8.04, with a change in IP, but not hostname.

    I am following the "Network Edition: Moving from 32-bit to 64-bit Server" wiki entry.

    imapproxy and memcached were running on the old server. When I do a full install on the new server, copy over /store, /index, and so on and restart, I get the imapproxy error.

    I then disable the imapproxy and memcached services with zmprov.

    Everything seems to go well until I do a restart and check status.
    ZMlogswatchctl, zmmtaconfig, mailboxd, and zmmailboxdctl are not running.

    I check passwords.
    (as zimbra) I issue the mysql command. It connects.
    (as zimbra) I issue the logmysql command. Access Denied.

    I followed the procedure in "Issues with mysql and logmysql passwords" but still get the Access Denied problem with logmysql.

    Not sure where to go from here.
    hosts and hostname are setup identical from server to server, with the exception of the IP.

    Should I disable imapproxy and memcached on the old server before I copy over? Does that only affect the ldap backup?

    What to look at next?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    Quote Originally Posted by kbmunkholm View Post
    imapproxy and memcached were running on the old server.
    Why? If this is a single server then why did you have the imapproxy and memcached installed, it can cause you problems. I'd suggest you disable them and mark them as not installed (search the forums for details on how to to that) and then follow the wiki article exactly for the move to the new server.


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    kbmunkholm Guest


    Disable imapproxy on production server.
    Full reinstall of ZCS 5.x on new 8.04 server, following the 32>64 bit migration wiki article. New server has same hostname and IP of production server.

    ZMcontrol start
    Zmcontrol status results in
    logmysql.server is not running ( as well as others) exists, ps aux | grep logger/mysql returns three results, one of which has the mysql pid. exists, however it is stale. ps aux | grep logswatch returns one process, with a different pid. Repeating this step returns a different pid each time.

    (as zimbra) logmysql returns error 1045 Access Denied...
    (as Zimbra) mysql returns error 1045 Access Denied...

    Follow procedure in "Issues with mysql and logmysql passwords" wiki entry.
    This now allows me to execute:
    (as zimbra) logmysql
    (as zimbra) mysql

    ** So part of my problem was with passwords in mysql**

    Zmcontrol status returns
    mailboxd and zmmailboxdctl not running.

    Reviewing zmmailboxd.out shows the error
    Unbound server sockets not implemented
    It tried to bind to 110 and 995
    netstat -an shows nothing bound to 110 and 995

    Research indicates possible cert problem and reinstall will correct.
    Reinstall (upgrade)
    No resolution

    Do I need to follow the Recreating self signed SSL Certificate wiki?

  4. #4
    kbmunkholm Guest

    Default [solved] 32-64 migration - Password problems?

    The issue was a couple of problems.
    The password issue with mysql, as solved with the Issues with mysql and logmysql passwords - Zimbra :: Wiki

    The next was the certs.
    Recreating the certs took care of the problem.

    *As root:
    cd /opt/zimbra/jetty/etc
    mv keystore
    /opt/zimbra/bin/zmcertmgr createcrt -new
    /opt/zimbra/bin/zmcertmgr deploycrt

    Then restart zmcontrol.
    su - zimbra
    zmcontrol stop
    zmcontrol start

    Support walked me through this and was quite pleasant in doing so.

Similar Threads

  1. password changed in migration
    By vks_goa in forum Migration
    Replies: 4
    Last Post: 05-16-2011, 02:53 AM
  2. exchange 2000 migration problems
    By tleong in forum Administrators
    Replies: 3
    Last Post: 02-21-2007, 10:20 PM
  3. Migration problems
    By andrewl in forum Migration
    Replies: 8
    Last Post: 12-14-2006, 06:06 AM
  4. Port and Password Problems
    By dennosius in forum Installation
    Replies: 3
    Last Post: 11-21-2006, 01:25 PM
  5. User Migration / Account / Password Question
    By nexus in forum Installation
    Replies: 1
    Last Post: 07-28-2006, 09:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts