Hi All,

A weird problem has cropped up in the last few days. Using Zimbra 6.0.10 Network ed in a multi-server setup (auth server, 2 mta servers, mailbox server.) We're set up to migrate users & groups from an Exchange 2003 server, and we're nearly finished. The Zimbra is configured to authenticate against Active Directory 2003.

A user I created last week seemed to be working just fine, but it never showed up in the GAL. I had created an AD user object and configured it, including the email address, and then configured the Zimbra account. Everything appeared to work just fine. The user was able to logon to both Windows & Zimbra, and able to send and receive mail with no problems or errors. The user received mail addressed to dist groups that she was a member of. However her supervisor noticed that she didn't appear in the GAL. First I made sure that the account wasn't hidden in the GAL, and it wasn't. Just in case I hid it, then un-hid it, but that didn't help. Next I tried re-typing the email address in the AD account but that didn't help. Later on I deleted and re-created the Zimbra account, which also didn't help. Next I deleted both the AD and Zimbra accounts, then re-created both. Still no help. Just to be sure that there wasn't an issue with a service, I created a dummy account with the same configuration and group memberships, and the dummy account DID appear in the GAL. I was (and still am) stumped! A co-worker suggested that I delete the Zimbra account, create and Exchange mailbox for the AD account, then use the migration wizard to migrate the account over to Zimbra. It worked, and now the user IS showing up in the GAL. Unfortunately this won't be an option once the migration is complete and we decommission the Exchange server.

We also learned that a distribution group is also not showing up in the GAL as well. My co-worker tried deleting and re-creating the group, but it still refuses to show in the GAL.

Zmcontrol status shows that all services are running on the servers, and I've checked the logs on the auth and mailbox servers, and haven't seen any errors that might point to a problem.

Does anybody have an idea of what might be causing this? Any help or hints would be much appreciated!