Results 1 to 10 of 11

Thread: ZCS 7.1.1 on Centos 5.6 (x86) installation problem

Hybrid View

  1. #1
    Join Date
    Aug 2011
    Posts
    6
    Rep Power
    4

    Question ZCS 7.1.1 on Centos 5.6 (x86) installation problem

    hi,

    i have a problem which is all installation has done but each time occure an error below while sending mail.

    ďno route to hostĒ

    checking firewall and dns settings or gateway settings but doesnít work. besides, cannot receive mail from the other domain. i have tried again and again but it didnít. why do i take the error? iíll be so glad to help me.

    Best regards,
    Cem

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    I'll move this to the correct forum as it's not a question about Zimbra Desktop (which is where you've posted).

    Quote Originally Posted by theblasphemous View Post
    i have a problem which is all installation has done but each time occure an error below while sending mail.

    ďno route to hostĒ
    Did you search the forums for that error message? site:zimbra.com +

    Quote Originally Posted by theblasphemous View Post
    checking firewall and dns settings or gateway settings but doesnít work. besides, cannot receive mail from the other domain. i have tried again and again but it didnít. why do i take the error? iíll be so glad to help me.
    As you're behind a NAT router or firewall, did you set-up a Split DNS (you should)?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Aug 2011
    Posts
    6
    Rep Power
    4

    Default

    yes i seted-up. it doesn't seem to be any mistake during installation. it's not problem receive/send mail on local. (etc. @cem.com) but when i try to send a mail to different domain (etc.hotmail.com or @anotherdomain.com) it couldn't. moreover, many of documents on internet about "no route to host" but each solution are different each other. because of that i confused :/ i'm seeing now a thing on wrong way that i know right before. i've tested all steps. after centos installation and dns settings, everything's ok. nslookup, dig, host command works correctly. and zimbra installed without any errror.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by theblasphemous View Post
    ...after centos installation and dns settings, everything's ok. nslookup, dig, host command works correctly. and zimbra installed without any errror.
    Really? I'd suggest you go to the 'Verify...' section of the Split DNS article and run all the commands in there and post the output. You should also verify that your firewall is not blocking any inbound/outbound traffic to your mail server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Aug 2011
    Posts
    6
    Rep Power
    4

    Default

    i use dns bind server. and there is record file text below.

    Code:
    $ttl 38400
    test.foreksegitim.net.	IN	SOA	test.foreksegitim.net. admin.test.foreksegitim.net. (
    			1312952673
    			10800
    			3600
    			604800
    			38400 )
    test.foreksegitim.net.	IN	NS	test.foreksegitim.net.
    test.foreksegitim.net.	IN	MX	10 mail.test.foreksegitim.net.
    test.foreksegitim.net.	IN	A	192.168.1.123
    mail.test.foreksegitim.net.	IN	A	192.168.1.123
    Code:
    root@test ~]# nslookup test.foreksegitim.net
    Server:         192.168.1.123
    Address:        192.168.1.123#53
    
    Name:   test.foreksegitim.net
    Address: 192.168.1.123

    Code:
    oot@test ~]# dig test.foreksegitim.net any
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> test.foreksegitim.net any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33691
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;test.foreksegitim.net.         IN      ANY
    
    ;; ANSWER SECTION:
    test.foreksegitim.net.  38400   IN      SOA     test.foreksegitim.net. admin.test.foreksegitim.net. 1312952673 10800 3600 604800 38400
    test.foreksegitim.net.  38400   IN      NS      test.foreksegitim.net.
    test.foreksegitim.net.  38400   IN      MX      10 mail.test.foreksegitim.net.
    test.foreksegitim.net.  38400   IN      A       192.168.1.123
    
    ;; ADDITIONAL SECTION:
    test.foreksegitim.net.  38400   IN      A       192.168.1.123
    mail.test.foreksegitim.net. 38400 IN    A       192.168.1.123
    Code:
    [root@test ~]# dig test.foreksegitim.net mx
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> test.foreksegitim.net mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35691
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;test.foreksegitim.net.         IN      MX
    
    ;; ANSWER SECTION:
    test.foreksegitim.net.  38400   IN      MX      10 mail.test.foreksegitim.net.
    
    ;; AUTHORITY SECTION:
    test.foreksegitim.net.  38400   IN      NS      test.foreksegitim.net.
    
    ;; ADDITIONAL SECTION:
    mail.test.foreksegitim.net. 38400 IN    A       192.168.1.123
    test.foreksegitim.net.  38400   IN      A       192.168.1.123

    Code:
    [root@test ~]# host test.foreksegitim.net
    test.foreksegitim.net has address 192.168.1.123
    test.foreksegitim.net mail is handled by 10 mail.test.foreksegitim.net.
    Code:
    --hosts file--
    127.0.0.1          localhost.localdomain      localhost
    192.168.1.123   test.foreksegitim.net       test
    Code:
    --resolvf.conf file--
    search             foreksegitim.net
    nameserver      192.168.1.123
    is there any error ?

    Best regards and thanks.
    Last edited by phoenix; 08-09-2011 at 11:59 PM.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by theblasphemous View Post
    is there any error?
    Yes, there is. The first point, just the output of the commands in the Split DNS article are enough to diagnose the problem and the "host" command should have been this: "host $(hostname)".

    The problem depends on what you domain name actually is. in your host command you have the following as the FQDN:

    Code:
    test.foreksegitim.net
    indicating that your domain name is: "foreksegitim.net". You have then done the dig commands with the following (which is a sub-domain):

    Code:
    dig test.foreksegitim.net any
    when it should have been the following:

    Code:
    dig foreksegitim.net any
    If you use the correct domain name what output do you get from the commands?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    In essence, yes that output looks OK. I'll say this again, do not use nslookup nor the host command that you used, use the ones in the article - the host commend specifically does a lookup for the FQDN of the server and that's what needs checking. You also didn't post the output of your hosts file nor the resolv.conf. Is it working now or not? If it's not then try some of the tips in these posts for checking what's wrong.

    BTW, you should use an IP address for your DNS records.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Aug 2011
    Posts
    6
    Rep Power
    4

    Default

    Hi again, i re-installed and it doesn't work of course there is results i'm taking below.
    Code:
    --named.conf--
    options {
    	directory "/etc";
    	pid-file "/var/run/named/named.pid";
    	};
    
    zone "." {
    	type hint;
    	file "/etc/db.cache";
    	};
    
    zone "foreksegitim.net" {
    	type master;
    	file "/var/named/foreksegitim.net.hosts";
    	};
    zone "1.168.192.in-addr.arpa" {
    	type master;
    	file "/var/named/192.168.1.rev";
    	};
    ----------

    Code:
    --foreksegitim.net.hosts--
    
    $ttl 38400
    foreksegitim.net.	IN	SOA	cem.foreksegitim.net. root.foreksegitim.net. (
    			1313755222
    			10800
    			3600
    			604800
    			38400 )
    foreksegitim.net.	IN	NS	cem.foreksegitim.net.
    foreksegitim.net.	IN	A	192.168.1.123
    www.foreksegitim.net.	IN	CNAME	foreksegitim.net.
    mail.foreksegitim.net.	IN	CNAME	foreksegitim.net.
    ftp.foreksegitim.net.	IN	CNAME	foreksegitim.net.
    foreksegitim.net.	IN	MX	10 mail.foreksegitim.net.
    cem.foreksegitim.net.	IN	A	192.168.1.123
    Code:
    --192.168.1.rev--
    $ttl 38400
    1.168.192.in-addr.arpa.	IN	SOA	cem.foreksegitim.net. root.foreksegitim.net. (
    			1313756138
    			10800
    			3600
    			604800
    			38400 )
    1.168.192.in-addr.arpa.	IN	NS	cem.foreksegitim.net.
    123.1.168.192.in-addr.arpa.	IN	PTR	cem.foreksegitim.net.
    www.1.168.192.in-addr.arpa.	IN	CNAME	foreksegitim.net.
    mail.1.168.192.in-addr.arpa.	IN	CNAME	foreksegitim.net.
    ftp.1.168.192.in-addr.arpa.	IN	CNAME	foreksegitim.net.
    Code:
    --hosts file--
    127.0.0.1           localhost.localdomain localhost
    192.168.1.123    cem.foreksegitim.net  cem mail cem ftp
    Code:
    --resolve.conf file--
    search          foreksegitim.net
    nameserver  192.168.1.123
    --command returns--

    Code:
    [root@cem ~]# host cem.foreksegitim.net
    cem.foreksegitim.net has address 192.168.1.123
    Code:
    [root@cem ~]# host foreksegitim.net
    foreksegitim.net has address 192.168.1.123
    foreksegitim.net mail is handled by 10 mail.foreksegitim.net.
    [root@cem ~]# nslookup cem.foreksegitim.net
    Server:         192.168.1.123
    Address:        192.168.1.123#53
    
    Name:   cem.foreksegitim.net
    Address: 192.168.1.123
    
    [root@cem ~]# nslookup foreksegitim.net
    Server:         192.168.1.123
    Address:        192.168.1.123#53
    
    Name:   foreksegitim.net
    Address: 192.168.1.123
    Code:
    [root@cem ~]# nslookup mail.foreksegitim.net
    Server:         192.168.1.123
    Address:        192.168.1.123#53
    
    mail.foreksegitim.net   canonical name = foreksegitim.net.
    Name:   foreksegitim.net
    Address: 192.168.1.123
    Code:
    root@cem ~][# dig cem.foreksegitim.net any
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> cem.foreksegitim.net any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18832
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;cem.foreksegitim.net.          IN      ANY
    
    ;; ANSWER SECTION:
    cem.foreksegitim.net.   38400   IN      A       192.168.1.123
    
    ;; AUTHORITY SECTION:
    foreksegitim.net.       38400   IN      NS      cem.foreksegitim.net.
    
    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.123#53(192.168.1.123)
    ;; WHEN: Tue Aug 23 14:44:19 2011
    ;; MSG SIZE  rcvd: 68
    Code:
    [root@cem ~]# dig cem.foreksegitim.net mx
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> cem.foreksegitim.net mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9131
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;cem.foreksegitim.net.          IN      MX
    
    ;; AUTHORITY SECTION:
    foreksegitim.net.       38400   IN      SOA     cem.foreksegitim.net. root.foreksegitim.net. 1313755222 10800 3600 604800 38400
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.123#53(192.168.1.123)
    ;; WHEN: Tue Aug 23 14:44:22 2011
    ;; MSG SIZE  rcvd: 79
    Code:
    [root@cem ~]# dig foreksegitim.net any
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> foreksegitim.net any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12302
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;foreksegitim.net.              IN      ANY
    
    ;; ANSWER SECTION:
    foreksegitim.net.       38400   IN      MX      10 mail.foreksegitim.net.
    foreksegitim.net.       38400   IN      SOA     cem.foreksegitim.net. root.foreksegitim.net. 1313755222 10800 3600 604800 38400
    foreksegitim.net.       38400   IN      NS      cem.foreksegitim.net.
    foreksegitim.net.       38400   IN      A       192.168.1.123
    
    ;; ADDITIONAL SECTION:
    cem.foreksegitim.net.   38400   IN      A       192.168.1.123
    
    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.123#53(192.168.1.123)
    ;; WHEN: Tue Aug 23 14:44:31 2011
    ;; MSG SIZE  rcvd: 146
    Code:
    [root@cem ~]# dig foreksegitim.net mx
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> foreksegitim.net mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19183
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;foreksegitim.net.              IN      MX
    
    ;; ANSWER SECTION:
    foreksegitim.net.       38400   IN      MX      10 mail.foreksegitim.net.
    
    ;; AUTHORITY SECTION:
    foreksegitim.net.       38400   IN      NS      cem.foreksegitim.net.
    
    ;; ADDITIONAL SECTION:
    cem.foreksegitim.net.   38400   IN      A       192.168.1.123
    
    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.123#53(192.168.1.123)
    ;; WHEN: Tue Aug 23 14:44:43 2011
    ;; MSG SIZE  rcvd: 89
    Code:
    [root@cem ~]# dig mail.foreksegitim.net any
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> mail.foreksegitim.net any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9968
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;mail.foreksegitim.net.         IN      ANY
    
    ;; ANSWER SECTION:
    mail.foreksegitim.net.  38400   IN      CNAME   foreksegitim.net.
    
    ;; AUTHORITY SECTION:
    foreksegitim.net.       38400   IN      NS      cem.foreksegitim.net.
    
    ;; ADDITIONAL SECTION:
    cem.foreksegitim.net.   38400   IN      A       192.168.1.123
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.123#53(192.168.1.123)
    ;; WHEN: Tue Aug 23 14:44:47 2011
    ;; MSG SIZE  rcvd: 87
    Code:
    [root@cem ~]# dig mail.foreksegitim.net mx
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> mail.foreksegitim.net mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 51816
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;mail.foreksegitim.net.         IN      MX
    
    ;; ANSWER SECTION:
    mail.foreksegitim.net.  38400   IN      CNAME   foreksegitim.net.
    foreksegitim.net.       38400   IN      MX      10 mail.foreksegitim.net.
    
    ;; AUTHORITY SECTION:
    foreksegitim.net.       38400   IN      NS      cem.foreksegitim.net.
    
    ;; ADDITIONAL SECTION:
    cem.foreksegitim.net.   38400   IN      A       192.168.1.123
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.123#53(192.168.1.123)
    ;; WHEN: Tue Aug 23 14:44:54 2011
    ;; MSG SIZE  rcvd: 103
    and there is log file below during the process that sending a mail

    Code:
    [root@cem ~]# tail -f /var/log/zimbra.log
    Aug 23 14:53:40 cem zmmailboxdmgr[29237]: status OK
    Aug 23 14:53:40 cem zmmailboxdmgr[29245]: status requested
    Aug 23 14:53:40 cem zmmailboxdmgr[29245]: status OK
    Aug 23 14:54:09 cem zmmailboxdmgr[29706]: status requested
    Aug 23 14:54:09 cem zmmailboxdmgr[29706]: status OK
    Aug 23 14:54:25 cem clamd[5390]: SelfCheck: Database status OK.
    Aug 23 14:54:42 cem zmmailboxdmgr[29914]: status requested
    Aug 23 14:54:42 cem zmmailboxdmgr[29914]: status OK
    Aug 23 14:54:42 cem zmmailboxdmgr[29922]: status requested
    Aug 23 14:54:42 cem zmmailboxdmgr[29922]: status OK
    Aug 23 14:55:12 cem slapd[3329]: slap_queue_csn: queing 0x43aeb56 20110823115512                                                                .522945Z#000000#000#000000
    Aug 23 14:55:12 cem slapd[3329]: slap_graduate_commit_csn: removing 0xaf15d20 20                                                                110823115512.522945Z#000000#000#000000
    Aug 23 14:55:12 cem slapd[3329]: slap_queue_csn: queing 0x1784b56 20110823115512                                                                .771248Z#000000#000#000000
    Aug 23 14:55:12 cem slapd[3329]: slap_graduate_commit_csn: removing 0xe5521b0 20                                                                110823115512.771248Z#000000#000#000000
    Aug 23 14:55:44 cem zmmailboxdmgr[30184]: status requested
    Aug 23 14:55:44 cem zmmailboxdmgr[30184]: status OK
    Aug 23 14:55:44 cem zmmailboxdmgr[30192]: status requested
    Aug 23 14:55:44 cem zmmailboxdmgr[30192]: status OK
    Aug 23 14:56:04 cem zmmailboxdmgr[30647]: status requested
    Aug 23 14:56:04 cem zmmailboxdmgr[30647]: status OK
    Aug 23 14:56:08 cem postfix/smtpd[30756]: connect from cem.foreksegitim.net[192.                                                                168.1.123]
    Aug 23 14:56:08 cem postfix/smtpd[30756]: E8298F98285: client=cem.foreksegitim.n                                                                et[192.168.1.123]
    Aug 23 14:56:08 cem postfix/cleanup[30759]: E8298F98285: message-id=<30773a43-3b                                                                22-4a6a-bd99-9a0c3f643b59@cem.foreksegitim.net>
    Aug 23 14:56:08 cem postfix/qmgr[5596]: E8298F98285: from=<cem@foreksegitim.net>                                                                , size=690, nrcpt=1 (queue active)
    Aug 23 14:56:09 cem postfix/smtpd[30756]: disconnect from cem.foreksegitim.net[1                                                                92.168.1.123]
    Aug 23 14:56:09 cem amavis[4794]: (04794-04) ESMTP::10024 /opt/zimbra/data/amavi                                                                sd/tmp/amavis-20110819T233009-04794: <cem@foreksegitim.net> -> <cemmeke@yahoo.co                                                                m> SIZE=690 Received: from cem.foreksegitim.net ([127.0.0.1]) by localhost (cem.                                                                foreksegitim.net [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <cemmeke@                                                                yahoo.com>; Tue, 23 Aug 2011 14:56:09 +0300 (EEST)
    Aug 23 14:56:09 cem amavis[4794]: (04794-04) Checking: vCpeAAqjgKwC MYNETS [192.                                                                168.1.123] <cem@foreksegitim.net> -> <cemmeke@yahoo.com>
    Aug 23 14:56:11 cem postfix/smtpd[30763]: connect from localhost.localdomain[127                                                                .0.0.1]
    Aug 23 14:56:11 cem postfix/smtpd[30763]: 1934AF9828A: client=localhost.localdom                                                                ain[127.0.0.1]
    Aug 23 14:56:11 cem postfix/cleanup[30759]: 1934AF9828A: message-id=<30773a43-3b                                                                22-4a6a-bd99-9a0c3f643b59@cem.foreksegitim.net>
    Aug 23 14:56:11 cem postfix/smtpd[30763]: disconnect from localhost.localdomain[                                                                127.0.0.1]
    Aug 23 14:56:11 cem postfix/qmgr[5596]: 1934AF9828A: from=<cem@foreksegitim.net>                                                                , size=1152, nrcpt=1 (queue active)
    Aug 23 14:56:11 cem amavis[4794]: (04794-04) FWD via SMTP: <cem@foreksegitim.net                                                                > -> <cemmeke@yahoo.com>,BODY=7BIT 250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.                                                                0.0 Ok: queued as 1934AF9828A
    Aug 23 14:56:11 cem amavis[4794]: (04794-04) Passed CLEAN, MYNETS LOCAL [192.168                                                                .1.123] [192.168.1.123] <cem@foreksegitim.net> -> <cemmeke@yahoo.com>, Message-I                                                                D: <30773a43-3b22-4a6a-bd99-9a0c3f643b59@cem.foreksegitim.net>, mail_id: vCpeAAq                                                                jgKwC, Hits: -2.91, size: 690, queued_as: 1934AF9828A, 1995 ms
    Aug 23 14:56:11 cem postfix/smtp[30760]: E8298F98285: to=<cemmeke@yahoo.com>, re                                                                lay=127.0.0.1[127.0.0.1]:10024, delay=2.3, delays=0.14/0.05/0.07/2, dsn=2.0.0, s                                                                tatus=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 1934A                                                                F9828A)
    Aug 23 14:56:11 cem postfix/qmgr[5596]: E8298F98285: removed
    Aug 23 14:56:32 cem postfix/smtp[30764]: connect to g.mx.mail.yahoo.com[98.137.54.238]:25: Connection timed out
    Aug 23 14:56:46 cem zmmailboxdmgr[30868]: status requested
    Aug 23 14:56:46 cem zmmailboxdmgr[30868]: status OK
    Aug 23 14:56:46 cem zmmailboxdmgr[30876]: status requested
    Aug 23 14:56:46 cem zmmailboxdmgr[30876]: status OK
    Aug 23 14:56:53 cem postfix/smtp[30764]: connect to k.mx.mail.yahoo.com[98.139.54.60]:25: Connection timed out
    Aug 23 14:56:53 cem postfix/smtp[30764]: connect to c.mx.mail.yahoo.com[98.139.175.225]:25: No route to host
    any idea?
    Thanks and best regards.
    Last edited by phoenix; 08-23-2011 at 06:41 AM.

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by theblasphemous View Post
    Hi again, i re-installed and it doesn't work of course

    <snip>

    any idea?
    I see no reference to an A record in the output of the dig command, you need one for the server to do a lookup and it needs to be the FQDN of the server, you also need to set the FQDN of the mail server in your hosts file.

    Your dig command should only use the domain name not the FQDN of your server (I mentioned this in a previous post) as follows:

    Code:
    dig foreksegitim.net mx
    I also don't need to see the BIND config files just the output of all the commands (and only those commands) in the 'Verify...' section of the Split DNS article - that will tell you if everything is configured correctly. You should also surround the out by the "CODE" tags to make it more readable, highlight a piece of text the hit the CODE tag above the edit box (the # symbol).


    BTW, you should never use a CNAME record to point to your mail server, you can end up losing email. Your NS record should point to an IP not the FQDN of the server.
    Last edited by phoenix; 08-23-2011 at 06:43 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    Join Date
    Aug 2011
    Posts
    6
    Rep Power
    4

    Default

    Quote Originally Posted by phoenix View Post
    I see no reference to an A record in the output of the dig command, you need one for the server to do a lookup and it needs to be the FQDN of the server, you also need to set the FQDN of the mail server in your hosts file.

    Your dig command should only use the domain name not the FQDN of your server (I mentioned this in a previous post) as follows:

    Code:
    dig foreksegitim.net mx
    I also don't need to see the BIND config files just the output of all the commands (and only those commands) in the 'Verify...' section of the Split DNS article - that will tell you if everything is configured correctly. You should also surround the out by the "CODE" tags to make it more readable, highlight a piece of text the hit the CODE tag above the edit box (the # symbol).


    BTW, you should never use a CNAME record to point to your mail server, you can end up losing email. Your NS record should point to an IP not the FQDN of the server.
    hi,
    i fixed that you've said and there is log below but same error occured. "no route to host". and i setted the modem dmz.

    $ttl 38400
    foreksegitim.net. IN SOA foreksegitim.net. hosts.foreksegitim.net. (
    1315482533
    10800
    3600
    604800
    38400 )
    foreksegitim.net. IN NS ns.foreksegitim.net.
    foreksegitim.net. IN A 10.0.0.20
    foreksegitim.net. IN MX 10 mail.foreksegitim.net.

    mail.foreksegitim.net. IN A 10.0.0.20
    ns.foreksegitim.net. IN A 10.0.0.20

    -----

    options {
    directory "/etc";
    pid-file "/var/run/named/named.pid";
    forwarders {
    208.67.222.222;
    208.67.220.220;
    };
    };

    zone "." {
    type hint;
    file "/etc/db.cache";
    };

    zone "foreksegitim.net" {
    type master;
    file "/var/named/foreksegitim.net.hosts";
    };
    zone "20.0.0.10.in-addr.arpa" {
    type master;
    file "/var/named/10.0.0.20.rev";
    };

    -----

    [root@mail ~]# host -t mx foreksegitim.net
    foreksegitim.net mail is handled by 10 mail.foreksegitim.net.

    -----

    [root@mail ~]# dig foreksegitim.net mx

    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> foreksegitim.net mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33964
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;foreksegitim.net. IN MX

    ;; ANSWER SECTION:
    foreksegitim.net. 38400 IN MX 10 mail.foreksegitim.net.

    ;; AUTHORITY SECTION:
    foreksegitim.net. 38400 IN NS ns.foreksegitim.net.

    ;; ADDITIONAL SECTION:
    mail.foreksegitim.net. 38400 IN A 10.0.0.20
    ns.foreksegitim.net. 38400 IN A 10.0.0.20

    ;; Query time: 22 msec
    ;; SERVER: 10.0.0.20#53(10.0.0.20)
    ;; WHEN: Fri Sep 9 09:05:24 2011
    ;; MSG SIZE rcvd: 104

    -----
    [root@mail ~]# nslookup foreksegitim.net
    Server: 10.0.0.20
    Address: 10.0.0.20#53

    Name: foreksegitim.net
    Address: 10.0.0.20

    [root@mail ~]# nslookup mail.foreksegitim.net
    Server: 10.0.0.20
    Address: 10.0.0.20#53

    Name: mail.foreksegitim.net
    Address: 10.0.0.20

    -----

    127.0.0.1 localhost.localdomain localhost
    10.0.0.20 mail.foreksegitim.net mail

    ----
    search foreksegitim.net
    nameserver 10.0.0.20

    are these right above?

    and there is tail -f /var/log/zimbra.log below

    Sep 9 09:19:04 mail zmmailboxdmgr[4408]: status requested
    Sep 9 09:19:04 mail zmmailboxdmgr[4408]: status OK
    Sep 9 09:19:05 mail amavis[29751]: (29751-01) ESMTP::10024 /opt/zimbra/data/amavisd/tmp/amavis-20110909T091903-29751: <cem@foreksegitim.net> -> <cemmeke@gmail.com> SIZE=619 Received: from mail.foreksegitim.net ([127.0.0.1]) by localhost (mail.foreksegitim.net [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <cemmeke@gmail.com>; Fri, 9 Sep 2011 09:19:03 +0300 (EEST)
    Sep 9 09:19:05 mail amavis[29751]: (29751-01) Checking: HyZXRbuehiJZ MYNETS [10.0.0.20] <cem@foreksegitim.net> -> <cemmeke@gmail.com>
    Sep 9 09:19:06 mail postfix/smtpd[4294]: connect from localhost.localdomain[127.0.0.1]
    Sep 9 09:19:06 mail postfix/smtpd[4294]: F10A511E8342: client=localhost.localdomain[127.0.0.1]
    Sep 9 09:19:06 mail postfix/cleanup[4289]: F10A511E8342: message-id=<2aabcf1f-ad51-4896-9e51-8445e5518ffb@mail.foreksegitim.net>
    Sep 9 09:19:06 mail postfix/qmgr[30069]: F10A511E8342: from=<cem@foreksegitim.net>, size=1085, nrcpt=1 (queue active)
    Sep 9 09:19:06 mail amavis[29751]: (29751-01) FWD via SMTP: <cem@foreksegitim.net> -> <cemmeke@gmail.com>,BODY=7BIT 250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as F10A511E8342
    Sep 9 09:19:07 mail amavis[29751]: (29751-01) Passed SPAMMY, MYNETS LOCAL [10.0.0.20] [10.0.0.20] <cem@foreksegitim.net> -> <cemmeke@gmail.com>, Message-ID: <2aabcf1f-ad51-4896-9e51-8445e5518ffb@mail.foreksegitim.net>, mail_id: HyZXRbuehiJZ, Hits: 6.914, size: 619, queued_as: F10A511E8342, 4328 ms
    Sep 9 09:19:07 mail postfix/smtp[4291]: E8D1011E833A: to=<cemmeke@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=5.1, delays=0.01/0/1.6/3.5, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as F10A511E8342)
    Sep 9 09:19:07 mail postfix/qmgr[30069]: E8D1011E833A: removed
    Sep 9 09:19:07 mail amavis[29751]: (29751-01) extra modules loaded: /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/Net/SSLeay/autosplit.ix, /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/Net/SSLeay/randomize.al, IO/Socket/SSL.pm, Net/LDAP/Extension.pm, Net/SSLeay.pm
    Sep 9 09:19:09 mail postfix/smtp[4295]: connect to i.mx.mail.yahoo.com[74.6.140.64]:25: Connection timed out
    Sep 9 09:19:10 mail postfix/smtp[4297]: connect to gmail-smtp-in.l.google.com[74.125.39.27]:25: No route to host
    Sep 9 09:19:10 mail postfix/smtp[4297]: connect to alt1.gmail-smtp-in.l.google.com[74.125.127.27]:25: No route to host
    Sep 9 09:19:19 mail postfix/smtp[4297]: connect to alt2.gmail-smtp-in.l.google.com[209.85.225.27]:25: No route to host
    Sep 9 09:19:19 mail postfix/smtp[4297]: connect to alt3.gmail-smtp-in.l.google.com[74.125.159.27]:25: No route to host
    Sep 9 09:19:19 mail postfix/smtp[4297]: connect to alt4.gmail-smtp-in.l.google.com[74.125.93.27]:25: No route to host
    Sep 9 09:19:19 mail postfix/smtp[4297]: F10A511E8342: to=<cemmeke@gmail.com>, relay=none, delay=13, delays=0.01/0/13/0, dsn=4.4.1, status=deferred (connect to alt4.gmail-smtp-in.l.google.com[74.125.93.27]:25: No route to host)

    and domain panel of ISP settings below

    78.168.167.X/24 PTR foreksegitim.net.
    foreksegitim.net NS ns.foreksegitim.net.
    foreksegitim.net A 78.168.167.X
    mail.foreksegitim.net A 78.168.167.X
    foreksegitim.net MX(10) mail.foreksegitim.net.

    IP 78.168.167.X indicate to my ISP of modem internet IP.



    Please help

    Regards.
    Cem
    Last edited by theblasphemous; 09-09-2011 at 01:04 AM.

Similar Threads

  1. Strange permission problem ZCS 7.1.1 p2
    By halley in forum Administrators
    Replies: 2
    Last Post: 06-28-2011, 05:23 AM
  2. first installation ZCS 5.0GA on centos 4.6 failed
    By echoadisan in forum Installation
    Replies: 29
    Last Post: 12-31-2008, 02:59 PM
  3. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 04:46 PM
  4. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 09:01 PM
  5. Installation problem
    By charlie in forum Administrators
    Replies: 1
    Last Post: 10-14-2005, 09:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •