I am facing small problem in webmail client.

In my ZCS web client i have selected default time is :GMT -5:00 US/Canada Eastern. but when ever i received mail, it is showing received time in IST.

I want to change received time automatically based on Default time zone in ZCS Web client. how we can do it, please help me.

Steps in ZCS web client.
Preferences-->General---> default time zone i have selected: GMT -5:00 US/Canada Eastern.

I have done below changes in Zimbra admin console for testing purpose:

Configuration--> Class of Service --> Default ( Edit )

Preferences --> Calander options
Time Zone: Not Set ( Earlier it is IST )

and restarted Zimbra services, still the problem not resolved, Kindly help me how to resolve the issue.

My Server Configuration details:

OS: CentOS 5.5 64 bit
ZCS version: zcs-7.1.1_GA_3196.RHEL5_64.20110527011124
Server Time Zone: IST

please help me...