We have a Zimbra server setup with 4 servers (mta, proxy, ldap and store).

The Store recently crashed and there was some disk corruption. fsck checked the disks and restored it, but the Zimbra database was still corrupted.

We went back to a full back-up that was created earlier, now the database starts again.

We thougt everything was fine again (except for some lost e-mails), but now several accounts are getting corrupted:

Caused by: com.mysql.jdbc.exceptions.MySQLSyntaxErrorExceptio n: Table 'mboxgroup17.mail_item' doesn't exist

These mailboxes worked after restore. Somehow they suddenly couldn't login anymore (hanging). Now I see this error everywhere on the crashed mailboxes.

I tried:
zmblobchk -m 117 start -v
nogo
/opt/zimbra/mysql/bin/mysqlcheck --defaults-file=/opt/zimbra/conf/my.cnf -S /opt/zimbra/db/mysql.sock -A -C -s -u root --password pass --auto-repair
nogo

How can I restore the database or recreate the tables?

I tried to restore with zmlmtpinject to a new account, but that's a big pile of mails without timestamp etc.