OS: Ubuntu 10.04 LTS
ZCS: 7.0 Std Trial 59 days left

I shared out an address book I created to test out the shared address book feature. I got the email and accepted on my other use account that has 'view' permissions. If when in that user account that now can see the share I hover my mouse over the address book I see it says "Contacts: 66". The problem is though even under the 'All' column I can't see any of the contacts!

Under the account owner of the address book they're all there, all 66. I tried clicking on the alpha characters too but there's nothing there in the user who has view permissions. I also tried to elevate the permissions just to see if that would do anything; but it did nothing.

I saw that in the user preferences the share is listed under the shares preference. Preferences > Sharing > 'Item' = /Sales Reps

I tried both IE 7 and FireFox 5 for giggles thinking it might be a browser thing but both browsers act the same.

Any thoughts on what might be going on? I'm stumped!