Results 1 to 9 of 9

Thread: Zimbra, phpLDAPadmin, Google Apps

  1. #1
    Join Date
    Aug 2011
    Posts
    27
    Rep Power
    4

    Default Zimbra, phpLDAPadmin, Google Apps

    How does one go about connecting to the Zimbra-installed LDAP server via phpLDAPadmin? I want to look at the OU structure for the purposes of synchronizing select objects to Google via the Google Directory Sync utility.

    I've tried Login CN = cn=Manager, dc=my-domain, dc=com and password = the one that I set while running install.sh, but this doesn't seem to be working.

  2. #2
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    try using

    uid=zimbra,cn=admins,cn=zimbra

    the password you can get by running

    zmlocalconfig -s | grep zimbra_ldap_password

  3. #3
    Join Date
    Aug 2011
    Posts
    27
    Rep Power
    4

    Default

    where does zmlocalconfig reside? It's location doesn't appear to have been added to my path my the installer, because I get "command not found" when I try to run it.

    Also, the UI for phpLDAPadmin seems to be expecting a user name of format

    cn=Manager, dc=my-domain, dc=com

    So, I'm not sure how to read/use "uid=zimbra,cn=admins,cn=zimbra"

  4. #4
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    you need to su to the user zimbra, then it should be in your path. it's in /opt/zimbra/bin/zmlocalconfig though

    i don't know much about phpldapadmin but i don't believe there is a user named Manager in zimbra

  5. #5
    Join Date
    Aug 2011
    Posts
    27
    Rep Power
    4

    Default

    Thanks, that got me the password, but I'm still stuck. I have no idea what to enter in the "local DN" field (see attached screen-shot).

    I'm hoping that someone who's used phpldapadmin sees this thread.
    Attached Images Attached Images

  6. #6
    Join Date
    May 2009
    Location
    Bremen, Germany
    Posts
    122
    Rep Power
    6

    Default

    Login DN: "uid=zimbra,cn=admins,cn=zimbra"

    Do not append your domain name.

  7. #7
    Join Date
    Aug 2011
    Posts
    27
    Rep Power
    4

    Default

    Thanks, but that didn't work. I'm still getting

    Unable to connect to LDAP server My LDAP Server
    Error: Can't contact LDAP server (-1) for user
    error Failed to Authenticate to server
    Invalid Username or Password.

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by agenerette View Post
    Thanks, but that didn't work. I'm still getting

    Unable to connect to LDAP server My LDAP Server
    Error: Can't contact LDAP server (-1) for user
    error Failed to Authenticate to server
    Invalid Username or Password.
    Then you're using the wrong credentials.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Aug 2011
    Posts
    27
    Rep Power
    4

    Default

    I actually found that though I couldn't connect with phpldapadmin, I could with LDAPManager.

Similar Threads

  1. Cleanup after many upgrades
    By tobru in forum Installation
    Replies: 1
    Last Post: 12-23-2007, 08:21 AM
  2. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  3. Replies: 16
    Last Post: 09-07-2006, 06:39 AM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •