Results 1 to 10 of 10

Thread: Changing the port Zimbra uses

  1. #1
    Join Date
    Oct 2006
    Posts
    16
    Rep Power
    9

    Default Changing the port Zimbra uses

    I read the forum titled " Ability to designate an IP Address"
    and it seems to stop at a dead end.

    Is there a way to get Zimbra to *not* use port 80 ?

  2. #2
    Join Date
    Apr 2006
    Location
    Ridgefield, CT
    Posts
    152
    Rep Power
    9

    Default Yes

    When you go through the installation, you are given the option of changing all port numbers

  3. #3
    Join Date
    Nov 2005
    Posts
    55
    Rep Power
    9

    Default

    If you are simply interested in only using port 443 (SSL) you can use 'zmtlsctl https'.

    If you really want to completely change ports the easiest way is to do it via the installation process, because there are things in LDAP and config files that you would have to match up.

  4. #4
    Join Date
    Oct 2006
    Posts
    16
    Rep Power
    9

    Default ok, I'll reinstall

    A few questions first:
    1. is uninstalling a must?
    2. has anyone figured out how to get SELinux to allow the spell checker php?
    3. I know of using port 8080 instead of 80 for http, is there a standard alternate port for https ?


    thanks.

  5. #5
    Join Date
    Nov 2005
    Posts
    55
    Rep Power
    9

    Default Trying to change the port

    I usually use 8443 for an alt SSL port, but its not quite as common as 8080.

    If all you care about are ports for HTTP/HTTPS you could try the following and see if it works for you (it should)...

    Code:
    zmprov mcf zimbraMailPort 8080
    zmprov mcf zimbraMailSSLPort 8443
    tomcat stop
    tomcat start

  6. #6
    Join Date
    Oct 2006
    Posts
    16
    Rep Power
    9

    Default

    nope, didn't work.
    Code:
    [zimbra@xeons ~]$ zmprov mcf zimbraMailPort 8080
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    [zimbra@xeons ~]$ zmcontrol start
    Host xeons.afts.com
            Starting ldap...Done.
            Starting logger...Done.
            Starting mailbox...Done.
            Starting antispam...Done.
            Starting antivirus...Done.
            Starting snmp...Done.
            Starting spell...Done.
            Starting mta...Done.
    [zimbra@xeons ~]$ zmprov mcf zimbraMailPort 8080
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)

  7. #7
    Join Date
    Nov 2005
    Posts
    55
    Rep Power
    9

    Default Yeah - you got errors

    Can't help you there. Looks like you've got some firewall or security issues going on.

  8. #8
    Join Date
    Oct 2006
    Location
    Bangalore, India
    Posts
    95
    Rep Power
    8

    Default hostname resolution

    hi,

    Check whether your email server's hostname is correctly resolved to your localhost address as well as your ip addresses. And also check whether you proceeded the command from the correct path itself.

    premoddev

  9. #9
    Join Date
    Oct 2006
    Posts
    16
    Rep Power
    9

    Default hmm, SELinux again?

    Quote Originally Posted by Coilcore
    Can't help you there. Looks like you've got some firewall or security issues going on.
    wonder if it SELinux stopping things.
    Has anyone developed a template to use so that Zimbra can be fully used within SELinux ?

  10. #10
    Join Date
    Oct 2006
    Posts
    16
    Rep Power
    9

    Default hmm, interesting - no mail at all since zimbra installed

    Quote Originally Posted by premoddev
    hi,

    Check whether your email server's hostname is correctly resolved to your localhost address as well as your ip addresses. And also check whether you proceeded the command from the correct path itself.

    premoddev
    here is the (munged) contents of /etc/hosts
    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost.localdomain localhost
    178.194.201.107     xeons.fats.org xeons localhost
    And I do notice that since sendmail was disabled in order to have the Zimbra postfix running, that the logwatch email has stopped coming to the internal root address. I am going to try to setup sendmail to use port 2525 and see what happens overnight.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. Removing hostname from hosts file fixed prob.
    By lemur in forum Installation
    Replies: 10
    Last Post: 06-13-2007, 06:29 PM
  3. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  4. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 10:34 PM
  5. Replies: 1
    Last Post: 11-23-2005, 12:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •