Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Can't connect to SMTP, POP3 works

  1. #1
    Join Date
    Sep 2011
    Posts
    27
    Rep Power
    4

    Default Can't connect to SMTP, POP3 works

    Can send/receive mail from inside the web admin, but when I use Outlook to test the connection pop3 works but SMTP hangs (asks me for the password again).

    I've changed the default Zimbra port(80) to 81.

    Been trying to figure it out this evening but no luck so far. What could be the possible cause of this problem?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by SkyHiRider View Post
    Been trying to figure it out this evening but no luck so far. What could be the possible cause of this problem?
    You need to look in the log files for the errors. Just posting 'it doesn't work' doesn't really tell us much that would aid in debugging the problem - although this question is most likely answered already in the forums. Did you ever correct your DNS records and hosts file mentioned in your earlier thread - those errors will cause you problems if not corrected.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Sep 2011
    Posts
    27
    Rep Power
    4

    Default

    Thanks for the reply - yes I managed to fix my DNS server thanks to your advice, the DNS testing commands paste the correct output and the two domains that are set are working correctly as far as I can tell (can send and receive)

    I tried looking into the general Linux log files (system log and mail log) but nothing was there that mentioned the failed SMTP connects.

    I've attached the mailbox.log file. Are SMTP access attempts logged in there or should I look into another file?
    Attached Files Attached Files

  4. #4
    Join Date
    Sep 2011
    Posts
    27
    Rep Power
    4

    Default

    Here's my output from split dns:

    Code:
    root@ns:/# dig andreansky.eu mx; dig andreansky.eu any; host $(hostname)
    
    ; <<>> DiG 9.7.0-P1 <<>> andreansky.eu mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18950
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;andreansky.eu.                 IN      MX
    
    ;; ANSWER SECTION:
    andreansky.eu.          604800  IN      MX      10 ns.andreansky.eu.
    
    ;; AUTHORITY SECTION:
    andreansky.eu.          604800  IN      NS      ns.andreansky.eu.
    
    ;; ADDITIONAL SECTION:
    ns.andreansky.eu.       604800  IN      A       192.168.77.87
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.77.87#53(192.168.77.87)
    ;; WHEN: Mon Sep 12 11:58:27 2011
    ;; MSG SIZE  rcvd: 80
    
    
    ; <<>> DiG 9.7.0-P1 <<>> andreansky.eu any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36693
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;andreansky.eu.                 IN      ANY
    
    ;; ANSWER SECTION:
    andreansky.eu.          604800  IN      SOA     ns.andreansky.eu. admin.andreansky.eu. 13 604800 86400 2419200 604800
    andreansky.eu.          604800  IN      MX      10 ns.andreansky.eu.
    andreansky.eu.          604800  IN      A       192.168.77.87
    andreansky.eu.          604800  IN      NS      ns.andreansky.eu.
    
    ;; ADDITIONAL SECTION:
    ns.andreansky.eu.       604800  IN      A       192.168.77.87
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.77.87#53(192.168.77.87)
    ;; WHEN: Mon Sep 12 11:58:27 2011
    ;; MSG SIZE  rcvd: 138
    
    ns.andreansky.eu has address 192.168.77.87

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by SkyHiRider View Post
    Here's my output from split dns:
    What's the output of the other commands in the Split DNS article? Those records are not as I advised, you should give the server a unique FQDN (that what an FQDN is for) not use the DNS records for your nameserver.

    BTW, you need to look in /var/log/zimbra.log for the errors on sending mail.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Sep 2011
    Posts
    27
    Rep Power
    4

    Default

    Here's the rest:

    Code:
    root@ns:/# cat /etc/resolv.conf
    search andreansky.eu
    nameserver 192.168.77.87
    nameserver 2001:7b8:3:4f:202:b3ff:fe46:bec
    nameserver 2001:b18:0:1000:2e0:81ff:fe61:ae
    
    root@ns:/# cat /etc/hosts
    127.0.0.1       localhost #ns.andreansky.eu
    194.1.130.117   #       ns mail.andreansky.eu mail
    192.168.77.87 ns.andreansky.eu www.branyadvere.sk  www.dvereabrany.sk www.andreansky.eu www.peciatky.sk peciatky.sk
    # The following lines are desirable for IPv6 capable hosts
    ::1     localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    root@ns:/home/andrej#

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    The hosts file is still incorrect, it does not follow the instructions in the Split DNS article - you will continue to have problems until you fix that and modify your DNS records.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Sep 2011
    Posts
    27
    Rep Power
    4

    Default

    Hmm, I've tried to send a message via telnet from another computer and that works, Ourlook Express seems to work too. Are there any documented problems with using Microsoft Outlook with Zimbra and smtp?

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by SkyHiRider View Post
    Hmm, I've tried to send a message via telnet from another computer and that works, Ourlook Express seems to work too. Are there any documented problems with using Microsoft Outlook with Zimbra and smtp?
    No there aren't, it works without problems - this is likely to be a configuration problem and as I've already mentioned you will need to fix your hosts file and DNS records. You should also be using port 587 as the Submission port (that requires authentication) in any client that connects to your server. You will find the errors for your connection/sending problems in the log files and you should look at them.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    Join Date
    Sep 2011
    Posts
    27
    Rep Power
    4

    Default

    Never mind, I tried sending mail by using a password but it seems that when I don't try to outh the mails go through (as long as the ip is in the whitelist) :/

    Can you explain why can't the nameserver and mail server have the same DNS record and both point to ns.andreansky.eu ?

    I want to understand the problem so that I can avoid the problem in the future.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 04:32 PM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •