Results 1 to 4 of 4

Thread: Upgrade from "Zimbra 6.0.14 Debian 4 32Bit" to "Ubuntu Server 10.04 LTS 64Bit"

  1. #1
    Join Date
    Sep 2011
    Posts
    2
    Rep Power
    4

    Default Upgrade from "Zimbra 6.0.14 Debian 4 32Bit" to "Ubuntu Server 10.04 LTS 64Bit"

    Hi all, I have Zimbra 6.0.14 installed on a Debian 4 32 Bits and I need to move this instalation to a Ubuntu 10.04 Server 64Bits and I don't know how to.

    I've tried to copy the opt/zimbra directory to the new server and then install Zimbra 6.0.14 64Bits Ubuntu 10.04 version but it didn't work.

    Can anyone help me?

    Thanks in advance

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by erickdel.santos View Post
    I've tried to copy the opt/zimbra directory to the new server and then install Zimbra 6.0.14 64Bits Ubuntu 10.04 version but it didn't work.
    That's not surprising, you can't directly copy a 32bit version to a 64bit server. You'll need to follow the wiki (link to the wiki at the top of this page) article on moving from a 32bit to 64bit server - it's a Network Edition article and it works for the OSS version as well, just ignore the NE steps. Search the wiki or the forums for the article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jul 2006
    Location
    Verona, Italy
    Posts
    153
    Rep Power
    9

    Default

    Hi Erick,

    I've done many migrations like this and alfter many "headaches" I have found ZxMig.

    Hope this helps

    Federico
    www.studiostorti.com

  4. #4
    Join Date
    Sep 2011
    Posts
    2
    Rep Power
    4

    Default

    Thanks for the answers, the ZxMig tool didn't work for me, the restore procedure returned errors (tried twice)...

    So, i went through the Zimbra Wiki suggestion and at the end of the steps, the mailbox service wasn't starting... Checking the logs I found that the problem was related to the certificate... so, as root, I removed the certificate with

    rm /opt/zimbra/mailboxd/etc/keystore

    and recreated with

    /opt/zimbra/bin/zmcertmgr deploycrt self

    after that, I had permission problems when trying to do anything through any logged in zimbra user. To solve this, as root, I ran:

    chown -R zimbra:zimbra /opt/zimbra/*
    /opt/zimbra/libexec/zmfixperms


    And finally... everything is working fine!
    Thanks for your attention.

    Erick

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Server rename and multi-server upgrade.
    By Tim Mothery in forum Administrators
    Replies: 0
    Last Post: 07-21-2007, 06:20 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. Ubuntu 6.06 LTS server install problems
    By Kavey1978 in forum Installation
    Replies: 17
    Last Post: 05-30-2007, 01:49 AM
  5. Insallation failed (Debian server)
    By popui007 in forum Installation
    Replies: 5
    Last Post: 09-29-2005, 02:27 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •