Results 1 to 2 of 2

Thread: Changing hostname & other problems

  1. #1
    Join Date
    Sep 2011
    Posts
    4
    Rep Power
    4

    Question Changing hostname & other problems

    Though they would call this 'wasting time'

    What they apparently did was tried to change the hostname repeatedly.
    I tried using zmsetup.pl to fix. But that script not only runs stupidly slow
    (I mean it's a bash script, for god's sake, why does it take 1 minute to respond when i just hit 'r'?? And no it is NOT a slow machine)
    But the only way to 'exit' it is to do so without applying the changes.
    (Yes I can save it to a file, but can only discard to exit. No Apply. WTFIT)

    I have been able to get it back up and limping,
    But now I have 3 different servers that appear in 'statistics'
    The other 2 don't even exist, don't show as servers,
    But still appear in 'Server status'. Not critical if i've got it flowing.
    But irritating, as I have no idea where it's pulling those from.

    On the one that actually needs fixing I am now down to
    anti-spam anti-virus and zmconfigd that are not running.

    Here's the error zmconfigd spits,
    (and no, zmfixpermissions doesnt do anything before you ask...)

    Traceback (most recent call last):
    File "/opt/zimbra/libexec/zmconfigd", line 24, in <module>
    import conf
    IOError: [Errno 2] File not found - /opt/zimbra/zimbramon/pylibs/conf$py.class (Permission denied)

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    I'll move this post to it's own thread.

    Quote Originally Posted by arinath View Post
    What they apparently did was tried to change the hostname repeatedly.
    I tried using zmsetup.pl to fix. But that script not only runs stupidly slow
    (I mean it's a bash script, for god's sake, why does it take 1 minute to respond when i just hit 'r'?? And no it is NOT a slow machine)
    But the only way to 'exit' it is to do so without applying the changes.
    (Yes I can save it to a file, but can only discard to exit. No Apply. WTFIT)
    What exactly were they trying to do, just change the hostname of the Zimbra server? The correct method of doing this is to use the zmsetservername command but I don't really want you to run that command yet.


    Quote Originally Posted by arinath View Post
    I have been able to get it back up and limping,
    But now I have 3 different servers that appear in 'statistics'
    The other 2 don't even exist, don't show as servers,
    But still appear in 'Server status'. Not critical if i've got it flowing.
    But irritating, as I have no idea where it's pulling those from.
    For the moment you can leave this problem to one side, it won't cause you any problem with the server and it's just an inconvenience - we'll address this later. So, the server is 'limping' along but generally working (sending & receiving mail)? You've changed the hostname of this server to the new one that you wanted? Did you also modify the /etc/hosts file and any DNS records for this server?

    Quote Originally Posted by arinath View Post
    On the one that actually needs fixing I am now down to
    anti-spam anti-virus and zmconfigd that are not running.
    How many Zimbra servers do you actually have. just the one or more than one? Which services are running? Post the output of a "zmcontrol status".

    Quote Originally Posted by arinath View Post
    Here's the error zmconfigd spits,
    (and no, zmfixpermissions doesnt do anything before you ask...)

    Traceback (most recent call last):
    File "/opt/zimbra/libexec/zmconfigd", line 24, in <module>
    import conf
    IOError: [Errno 2] File not found - /opt/zimbra/zimbramon/pylibs/conf$py.class (Permission denied)
    Which operating system is this server running? Have you tried to upgrade this server recently?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Problems after changing host name....
    By iviksons in forum Administrators
    Replies: 1
    Last Post: 02-18-2011, 01:38 AM
  2. Changing Your Hostname
    By manthrax3 in forum Administrators
    Replies: 2
    Last Post: 12-27-2007, 06:15 PM
  3. Server Statistics dont work after changing hostname
    By rnuno in forum Administrators
    Replies: 1
    Last Post: 06-08-2007, 08:54 PM
  4. Logger problems after changing hostname
    By Eric in forum Administrators
    Replies: 5
    Last Post: 06-04-2007, 05:41 AM
  5. MTA is Dying after yum update
    By tonyawbrey in forum Administrators
    Replies: 27
    Last Post: 04-02-2006, 07:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •