Results 1 to 2 of 2

Thread: sending with large attachments times out, but message is sent anyway

  1. #1
    Join Date
    Sep 2011
    Posts
    2
    Rep Power
    4

    Default sending with large attachments times out, but message is sent anyway

    We are running zcs-6.0.9_GA_2686.UBUNTU10_64.20101115235226 on Ubuntu 10.04 w/ split dns (dnscache + tinydns), for quite some time and haven't had any issues.

    last week the web interface began acting strangely when sending messages with large attachments to external users. Oddly I've been told that the desktop version does not exhibit this problem, but I have not tested that myself.

    Using fiddler I've tracked this down to this browser post:
    Code:
    POST /service/soap/SendMsgRequest
    The web request times out after exactly 4 minutes

    Code:
    ServerConnected:	10:19:21.170
    FiddlerBeginRequest:	10:19:21.217
    ServerGotRequest:	10:19:21.217
    ServerBeginResponse:	10:23:22.099
    ServerDoneResponse:	10:23:22.100
    ClientBeginResponse:	10:23:22.100
    ClientDoneResponse:	10:23:22.101
    
    Overall Elapsed:	00:04:00.8837891
    this exception is recorded in mailbox.log

    Code:
    2011-10-04 10:23:24,548 INFO  [btpool0-210://zimbra.c.ca/service/soap/SendMsgRequest] [name=bkc@c.ca;mid=10;ip=192.168.1.149;ua=ZimbraWebClient - FF3.0 (Win)/6.0.9_GA_2686;] SoapEngine - handler exception
    com.zimbra.common.service.ServiceException: system failure: Unable to send message
    		ExceptionId:btpool0-210://zimbra.c.ca/service/soap/SendMsgRequest:1317738204547:1355a48a4fe8e32a
    		Code:service.FAILURE
    			at com.zimbra.common.service.ServiceException.FAILURE(ServiceException.java:248)
    			at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(MailSender.java:477)
    			at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(MailSender.java:309)
    			at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(MailSender.java:266)
    
    ...
    Caused by: com.zimbra.cs.mailbox.MailSender$SafeMessagingException: Exception reading response; chained exception is:
    			java.net.SocketTimeoutException: Read timed out
    			at com.sun.mail.smtp.SMTPTransport.readServerResponse(SMTPTransport.java:1764)
    			at com.sun.mail.smtp.SMTPTransport.close(SMTPTransport.java:823)
    			at com.zimbra.cs.mailbox.MailSender.sendMessageToHost(MailSender.java:785)
    			at com.zimbra.cs.mailbox.MailSender.sendMessage(MailSender.java:702)
    			at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(MailSender.java:412)
    oddly, the message *is* sent to the external recipient with the attachment.
    But the message also stays in the drafts folder.

    when sending to a local recipient, the message is not sent after the 4 minute timeout.

    During the 4 minute period, load on the server is very low, nothing is happening.

    I suppose this is probably some kind of dns timeout issue. I have checked dns carefully and I believe it is setup correctly.

    I cannot find a 240 second timeout in any config file. The delay occurs for all external recipients receiving large messages, though I have only tested one recipient to calculate the 'exact' 4 minute timeout.

    The message that is received (after the 4 minute delay) has these headers:

    Code:
    Received: from zimbra.x.com ([24.97.99.250]) by na3sys009amx212.postini.com ([74.125.148.11]) with SMTP;
    	Tue, 04 Oct 2011 14:25:25 GMT
    Received: from localhost (localhost.localdomain [127.0.0.1])
    	by zimbra.x.com (Postfix) with ESMTP id A9007426B2
    	for <bkc@murkworks.com>; Tue,  4 Oct 2011 10:25:23 -0400 (EDT)
    X-Virus-Scanned: amavisd-new at zimbra.x.com
    Received: from zimbra.x.com ([127.0.0.1])
    	by localhost (zimbra.x.com [127.0.0.1]) (amavisd-new, port 10024)
    	with ESMTP id KaY4+uehwz7D for <bkc@z.com>;
    	Tue,  4 Oct 2011 10:25:23 -0400 (EDT)
    Received: from zimbra.x.com (zimbra.x.com [192.168.1.208])
    	by zimbra.x.com (Postfix) with ESMTP id 32F854251C
    	for <bkc@z.com>; Tue,  4 Oct 2011 10:19:24 -0400 (EDT)
    (host names altered above)

    related lines from mailbox.log
    Code:
    2011-10-04 10:19:23,670 INFO  [btpool0-210://zimbra.c.ca/service/soap/SendMsgRequest] [name=bkc@c.ca;mid=10;ip=192.168.1.149;ua=ZimbraWebClient - FF3.0 (Win)/6.0.9_GA_2686;] soap - SendMsgRequest
    2011-10-04 10:19:24,128 INFO  [btpool0-210://zimbra.c.ca/service/soap/SendMsgRequest] [name=bkc@c.ca;mid=10;ip=192.168.1.149;ua=ZimbraWebClient - FF3.0 (Win)/6.0.9_GA_2686;] mailop - Adding Message: id=4
    60, Message-ID=<494151752.368.1317737963671.JavaMail.root@zimbra>, parentId=-1, folderId=5, folderName=Sent.
    2011-10-04 10:19:24,201 INFO  [btpool0-198://zimbra.c.ca/service/soap/NoOpRequest] [name=bkc@c.ca;mid=10;ip=192.168.1.149;ua=ZimbraWebClient - FF3.0 (Win)/6.0.9_GA_2686;] soap - NoOpRequest
    2011-10-04 10:19:24,202 INFO  [btpool0-210://zimbra.c.ca/service/soap/SendMsgRequest] [name=bkc@c.ca;mid=10;ip=192.168.1.149;ua=ZimbraWebClient - FF3.0 (Win)/6.0.9_GA_2686;] smtp - Sending message to MTA
     at zimbra.x.com: Message-ID=<494151752.368.1317737963671.JavaMail.root@zimbra>, replyType=r
    2011-10-04 10:19:24,748 INFO  [btpool0-196://zimbra.c.ca/service/soap/NoOpRequest] [name=bkc@c.ca;mid=10;ip=192.168.1.149;ua=ZimbraWebClient - FF3.0 (Win)/6.0.9_GA_2686;] soap - NoOpRequest
    2011-10-04 10:19:55,899 INFO  [btpool0-196://zimbra.c.ca/service/soap/NoOpRequest] [name=bkc@c.ca;mid=10;ip=192.168.1.149;ua=ZimbraWebClient - FF3.0 (Win)/6.0.9_GA_2686;] soap - NoOpRequest	
    2011-10-04 10:19:56,410 INFO  [btpool0-215://zimbra.c.ca/service/soap/NoOpRequest] [name=bkc@c.ca;mid=10;ip=192.168.1.149;ua=ZimbraWebClient - FF3.0 (Win)/6.0.9_GA_2686;] soap - NoOpRequest	
    2011-10-04 10:23:24,433 INFO  [btpool0-210://zimbra.c.ca/service/soap/SendMsgRequest] [name=bkc@c.ca;mid=10;ip=192.168.1.149;ua=ZimbraWebClient - FF3.0 (Win)/6.0.9_GA_2686;] mailop - Deleting Message (id=460).
    2011-10-04 10:23:24,547 INFO  [btpool0-215://zimbra.c.ca/service/soap/NoOpRequest] [name=bkc@c.ca;mid=10;ip=192.168.1.149;ua=ZimbraWebClient - FF3.0 (Win)/6.0.9_GA_2686;] soap - NoOpRequest
    2011-10-04 10:23:24,548 INFO  [btpool0-210://zimbra.c.ca/service/soap/SendMsgRequest] [name=bkc@c.ca;mid=10;ip=192.168.1.149;ua=ZimbraWebClient - FF3.0 (Win)/6.0.9_GA_2686;] SoapEngine - handler exception
    any ideas?

    thanks

  2. #2
    Join Date
    Sep 2011
    Posts
    2
    Rep Power
    4

    Default

    The person who told me that sending w/ large attachments works in zimbra desktop just said "no, it's not working". I thought they were wrong, and now we know.. it doesn't work using either the plain web interface or zimbra desktop.

Similar Threads

  1. [SOLVED] Lot of mails deferred
    By pigui in forum Administrators
    Replies: 17
    Last Post: 04-10-2012, 06:15 AM
  2. single message sending thousands of times
    By matilda in forum Zimbra Connector for Outlook
    Replies: 24
    Last Post: 10-14-2011, 10:57 AM
  3. Zimbra Crashes every day
    By feiticeir0 in forum Administrators
    Replies: 10
    Last Post: 10-13-2011, 07:53 AM
  4. Emails bouncing with "Error Text: 401,'null'"
    By sholden in forum Zimbra Connector for Outlook
    Replies: 27
    Last Post: 08-20-2008, 05:59 PM
  5. Replies: 3
    Last Post: 07-19-2007, 03:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •