Results 1 to 7 of 7

Thread: failed upgrade to 7.1.3 on Ubuntu 10.4 LTS 64bit

Hybrid View

  1. #1
    Join Date
    Jun 2010
    Posts
    126
    Rep Power
    5

    Default failed upgrade to 7.1.3 on Ubuntu 10.4 LTS 64bit

    Getting the following error:

    Code:
    Operations logged to /tmp/zmsetup.10102011-074001.log
    Upgrading from 6.0.8_GA_2661 to 7.1.3_GA_3346
    Stopping zimbra services...done.
    Verifying /opt/zimbra/conf/my.cnf
    Starting mysql...done.
    This appears to be 6.0.8_GA
    Checking ldap status...not running.
    Running zmldapapplyldif...done.
    Checking ldap status...already running.
    Running mysql_upgrade...done.
    Stopping mysql...done.
    Updating from 6.0.9_GA
    Updating from 6.0.10_GA
    Updating from 6.0.11_GA
    Can't call method "get_value" on an undefined value at /opt/zimbra/libexec/zmupgrade.pm line 3416, <OUTPUT> line 3.
    
    
    root@wheelie:~/zcs-NETWORK-7.1.3_GA_3346.UBUNTU10_64.20110928134705# su -c ls
    README.txt  bin  data  docs  install.sh  lib  packages	readme_binary_en_US.txt  util
    root@wheelie:~/zcs-NETWORK-7.1.3_GA_3346.UBUNTU10_64.20110928134705# su - zimbra -c date | wc -l
    1
    1) Im already running 7.1.1, so why does it say its upgrade from 6.8?

    2) I found this bug that is related to the get_value error: https://bugzilla.zimbra.com/show_bug.cgi?id=47713,
    but it doesnt appear to apply to mine as you can see above, im getting the right result there.

    Here is line 3416 on the zmupgrade.pm file:

    Code:
        my @attrvals=$entry->get_value("olcDbIndex");
    Any ideas?

  2. #2
    Join Date
    Sep 2011
    Location
    Texas
    Posts
    150
    Rep Power
    4

    Default

    Quote Originally Posted by MACscr View Post
    1) Im already running 7.1.1, so why does it say its upgrade from 6.8?
    Are you sure about that? Your profile shows the following:
    Code:
    ZCS/ZD Version: Release 6.0.10_GA_2692.UBUNTU10_64 UBUNTU10_64 NETWORK edition.
    What is the current output of the following command?

    Code:
    zmcontrol -v

  3. #3
    Join Date
    Jun 2010
    Posts
    126
    Rep Power
    5

    Default

    LOL, im sorry if i dont have time to micro manage my profile with every update. Obviously if i state a version that im using, thats the version im using and you can disregard the profile.

    zmcontrol -v output is: Release 7.1.1_GA_3196.UBUNTU10_64 UBUNTU10_64 NETWORK edition.

  4. #4
    Join Date
    Jun 2010
    Posts
    126
    Rep Power
    5

    Default

    Tried upgrading again, still problems. Its very odd how its finds two different versions.

    Code:
    root@wheelie:~/zcs-NETWORK-7.1.3_GA_3346.UBUNTU10_64.20110928134705# ./install.sh 
    
    Operations logged to /tmp/install.log.30796
    Checking for existing installation...
        zimbra-ldap...FOUND zimbra-ldap-7.1.1_GA_3196.UBUNTU10_64
        zimbra-logger...FOUND zimbra-logger-7.1.1_GA_3196.UBUNTU10_64
        zimbra-mta...FOUND zimbra-mta-7.1.1_GA_3196.UBUNTU10_64
        zimbra-snmp...FOUND zimbra-snmp-7.1.1_GA_3196.UBUNTU10_64
        zimbra-store...FOUND zimbra-store-7.1.1_GA_3196.UBUNTU10_64
        zimbra-apache...FOUND zimbra-apache-7.1.1_GA_3196.UBUNTU10_64
        zimbra-spell...FOUND zimbra-spell-7.1.1_GA_3196.UBUNTU10_64
        zimbra-convertd...FOUND zimbra-convertd-7.1.1_GA_3196.UBUNTU10_64
        zimbra-memcached...FOUND zimbra-memcached-7.1.1_GA_3196.UBUNTU10_64
        zimbra-proxy...FOUND zimbra-proxy-7.1.1_GA_3196.UBUNTU10_64
        zimbra-archiving...FOUND zimbra-archiving-7.1.1_GA_3196.UBUNTU10_64
        zimbra-cluster...NOT FOUND
        zimbra-core...FOUND zimbra-core-7.1.1_GA_3196.UBUNTU10_64
    ZCS upgrade from 7.1.1 to 7.1.3 will be performed.
    Checking for available license file...
    Current Users=22 Licensed Users=400
    
    Saving existing configuration file to /opt/zimbra/.saveconfig
    
    
    ........................
    
    
    
    
    Do you agree with the terms of the software license agreement? [N] y
    
    Checking for prerequisites...
         FOUND: NPTL
         FOUND: netcat-openbsd-1.89-3ubuntu2
         FOUND: sudo-1.7.2p1-1ubuntu5.3
         FOUND: libidn11-1.15-2
         FOUND: libpcre3-7.8-3build1
         FOUND: libgmp3c2-2:4.3.2+dfsg-1ubuntu1
         FOUND: libexpat1-2.0.1-7ubuntu1
         FOUND: libstdc++6-4.4.3-4ubuntu5
         FOUND: libperl5.10-5.10.1-8ubuntu2.1
    Checking for suggested prerequisites...
         FOUND: perl-5.10.1
         FOUND: sysstat
         FOUND: sqlite3
    Prerequisite check complete.
    Checking current number of databases...
    Checking for a recent backup
    
    Do you want to verify message store database integrity? [Y] y
    Verifying integrity of message store databases.  This may take a while.
    mysqld is alive
    Database errors found.
    /opt/zimbra/mysql/bin/mysqlcheck --defaults-file=/opt/zimbra/conf/my.cnf -S /opt/zimbra/db/mysql.sock -A -C -s -u root --password=...................... --auto-repair
    mboxgroup22.open_conversation
     Warning  : InnoDB: Index 'i_conv_id' contains 1294 entries, should be 1293.
     error    : Corrupt
     mysql.general_log
     Error    : You can't use locks with log tables.
     mysql.slow_log
     Error    : You can't use locks with log tables.
     mboxgroup22.open_conversation
     note     : The storage engine for the table doesn't support repair
    
    Checking for installable packages
    
    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell
    Found zimbra-convertd
    Found zimbra-memcached
    Found zimbra-proxy
    Found zimbra-archiving
    
    
    The Zimbra Collaboration Suite appears already to be installed.
    It can be upgraded with no effect on existing accounts,
    or the current installation can be completely removed prior
    to installation for a clean install.
    
    Do you wish to upgrade? [Y] Y
    
    Select the packages to install
        Upgrading zimbra-core
        Upgrading zimbra-ldap
        Upgrading zimbra-logger
        Upgrading zimbra-mta
        Upgrading zimbra-snmp
        Upgrading zimbra-store
        Upgrading zimbra-apache
        Upgrading zimbra-spell
        Upgrading zimbra-convertd
        Upgrading zimbra-memcached
        Upgrading zimbra-proxy
        Upgrading zimbra-archiving
    Checking required space for zimbra-core
    checking space for zimbra-store
    
    Installing:
        zimbra-core
        zimbra-ldap
        zimbra-logger
        zimbra-mta
        zimbra-snmp
        zimbra-store
        zimbra-apache
        zimbra-spell
        zimbra-convertd
        zimbra-memcached
        zimbra-proxy
        zimbra-archiving
    
    The system will be modified.  Continue? [N] Y
    
    Shutting down zimbra mail
    
    Backing up the ldap database...done.
    
    Removing existing packages
    
       zimbra-ldap...done
       zimbra-logger...done
       zimbra-mta...done
       zimbra-snmp...done
       zimbra-store...done
       zimbra-spell...done
       zimbra-convertd...done
       zimbra-memcached...done
       zimbra-proxy...done
       zimbra-archiving...done
       zimbra-apache...done
       zimbra-core...done
    
    Removing deployed webapp directories
    Installing packages
    
        zimbra-core......zimbra-core_7.1.3_GA_3346.UBUNTU10_64_amd64.deb...done
        zimbra-ldap......zimbra-ldap_7.1.3_GA_3346.UBUNTU10_64_amd64.deb...done
        zimbra-logger......zimbra-logger_7.1.3_GA_3346.UBUNTU10_64_amd64.deb...done
        zimbra-mta......zimbra-mta_7.1.3_GA_3346.UBUNTU10_64_amd64.deb...done
        zimbra-snmp......zimbra-snmp_7.1.3_GA_3346.UBUNTU10_64_amd64.deb...done
        zimbra-store......zimbra-store_7.1.3_GA_3346.UBUNTU10_64_amd64.deb...done
        zimbra-apache......zimbra-apache_7.1.3_GA_3346.UBUNTU10_64_amd64.deb...done
        zimbra-spell......zimbra-spell_7.1.3_GA_3346.UBUNTU10_64_amd64.deb...done
        zimbra-convertd......zimbra-convertd_7.1.3_GA_3346.UBUNTU10_64_amd64.deb...done
        zimbra-memcached......zimbra-memcached_7.1.3_GA_3346.UBUNTU10_64_amd64.deb...done
        zimbra-proxy......zimbra-proxy_7.1.3_GA_3346.UBUNTU10_64_amd64.deb...done
        zimbra-archiving......zimbra-archiving_7.1.3_GA_3346.UBUNTU10_64_amd64.deb...done
    
    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
    ............................
    Restoring existing configuration file from /opt/zimbra/.saveconfig/localconfig.xml...done
    Operations logged to /tmp/zmsetup.11232011-183911.log
    Upgrading from 6.0.8_GA_2661 to 7.1.3_GA_3346
    Stopping zimbra services...done.
    Verifying /opt/zimbra/conf/my.cnf
    Starting mysql...done.
    This appears to be 6.0.8_GA
    Checking ldap status...not running.
    Running zmldapapplyldif...done.
    Checking ldap status...already running.
    Running mysql_upgrade...done.
    Stopping mysql...done.
    Updating from 6.0.9_GA
    Updating from 6.0.10_GA
    Updating from 6.0.11_GA
    Can't call method "get_value" on an undefined value at /opt/zimbra/libexec/zmupgrade.pm line 3416, <OUTPUT> line 3.
    root@wheelie:~/zcs-NETWORK-7.1.3_GA_3346.UBUNTU10_64.20110928134705#

  5. #5
    Join Date
    Jun 2010
    Posts
    126
    Rep Power
    5

    Default

    I found this old bug report: https://bugzilla.zimbra.com/show_bug.cgi?id=47713, closet thing i coudl find to my issue, but when i run the test at the bottom, it does return just: 1, so i should be ok according to it.

  6. #6
    Join Date
    Jun 2010
    Posts
    126
    Rep Power
    5

    Default

    Also, line 3416 in that file that shows in the last error is:

    Code:
    my @attrvals=$entry->get_value("olcDbIndex");
    LOL, just noticed i repeated information from the first time i tried to upgrade. Doh!

    Really wish i could figure this out. Its very frustrating.

  7. #7
    Join Date
    Jun 2010
    Posts
    126
    Rep Power
    5

    Default

    So are all my files 7.1.1, but my mysql db seems to only be 6.0.8? I just dont get it.

Similar Threads

  1. Replies: 5
    Last Post: 05-11-2012, 02:16 PM
  2. Upgrade from 6.0.10 to 7 beta4
    By alex70 in forum Installation
    Replies: 14
    Last Post: 05-11-2012, 02:02 PM
  3. MySQL errors
    By mludwig in forum Administrators
    Replies: 1
    Last Post: 07-11-2011, 03:40 AM
  4. Replies: 6
    Last Post: 03-14-2011, 04:21 AM
  5. [SOLVED] New zcs 7 install : database errors founds
    By dkbk in forum Administrators
    Replies: 4
    Last Post: 03-01-2011, 05:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •