Getting the following error:

Code:
Operations logged to /tmp/zmsetup.10102011-074001.log
Upgrading from 6.0.8_GA_2661 to 7.1.3_GA_3346
Stopping zimbra services...done.
Verifying /opt/zimbra/conf/my.cnf
Starting mysql...done.
This appears to be 6.0.8_GA
Checking ldap status...not running.
Running zmldapapplyldif...done.
Checking ldap status...already running.
Running mysql_upgrade...done.
Stopping mysql...done.
Updating from 6.0.9_GA
Updating from 6.0.10_GA
Updating from 6.0.11_GA
Can't call method "get_value" on an undefined value at /opt/zimbra/libexec/zmupgrade.pm line 3416, <OUTPUT> line 3.


root@wheelie:~/zcs-NETWORK-7.1.3_GA_3346.UBUNTU10_64.20110928134705# su -c ls
README.txt  bin  data  docs  install.sh  lib  packages	readme_binary_en_US.txt  util
root@wheelie:~/zcs-NETWORK-7.1.3_GA_3346.UBUNTU10_64.20110928134705# su - zimbra -c date | wc -l
1
1) Im already running 7.1.1, so why does it say its upgrade from 6.8?

2) I found this bug that is related to the get_value error: https://bugzilla.zimbra.com/show_bug.cgi?id=47713,
but it doesnt appear to apply to mine as you can see above, im getting the right result there.

Here is line 3416 on the zmupgrade.pm file:

Code:
    my @attrvals=$entry->get_value("olcDbIndex");
Any ideas?