Results 1 to 3 of 3

Thread: Multi-Stage Update with Debian Linux

  1. #1
    Join Date
    Dec 2007
    Location
    Stockton, CA
    Posts
    164
    Rep Power
    7

    Default Multi-Stage Update with Debian Linux

    Hey All,

    We're pretty far behind in Zimbra updates. We're currently running 6.0.5_GA_2213.DEBIAN4.0.FOSS and want to upgrade to the latest version. We have a new "fearless leader" and he wants to move to Google Apps...but before we make any decisions I want to level the playing field by upgrading to the latest version of Zimbra. It's a long story...

    Since we're so far behind, our server is running Debian 4 (Etch). Ultimately, I'd like to move to Ubuntu LTS 10.04 64-bit, but we need to update before I have time to do that.

    What is the best way for me to ensure that I update the server to Debian 5 (Lenny)? Our current sources.list file is the following:

    Code:
    deb http://sluglug.ucsc.edu/debian/ etch main
    deb-src http://sluglug.ucsc.edu/debian/ etch main
    
    deb http://security.debian.org/ etch/updates main
    deb-src http://security.debian.org/ etch/updates main
    Can I simply change "etch" to "lenny" and then do an apt-get upgrade, or will I need to do an apt-get dist-upgrade? I want to ensure that I upgrade to Lenny and NOT Squeeze (6).

    How will this affect my current Zimbra install, and will this massive change affect my upgrade success?

    Any help is much appreciated!

  2. #2
    Join Date
    Dec 2007
    Location
    Stockton, CA
    Posts
    164
    Rep Power
    7

    Default

    I've copied our Zimbra install to an external hard drive and will try this in a testing environment. I have an older server running Debian 4. My plan is to "re-install" the version of Zimbra we are working, verify that it works, then update Debian to Lenny and install the latest version of Zimbra.

    I'll report back on my success and/or failure!

  3. #3
    Join Date
    Dec 2007
    Location
    Stockton, CA
    Posts
    164
    Rep Power
    7

    Default

    Short answer - failure!

    I received a common error when the the message database integrity was being checked. It was resolved by downgrading perl. However, I received another error after everything was installed. I didn't feel comfortable with it at this point so I ditched it.

    It looks like the version we're running (6.0.5) is supported on Ubuntu 8.0.4 LTS. It looks like Ubuntu 8.0.4 LTS is supported until 2013, so I it look like I will need to move to this first.

    1. Move current Zimbra install to Ubunt 8.0.4 LTS
    2. upgrade to latest version of Zimbra

    Until next time...

Similar Threads

  1. ZD 7.1.1 Linux update
    By kevindods in forum General Questions
    Replies: 0
    Last Post: 08-11-2011, 03:29 AM
  2. Replies: 7
    Last Post: 11-02-2007, 11:30 PM
  3. Update Received Date in Folder-Listing
    By Oswald-Kolle in forum Installation
    Replies: 25
    Last Post: 08-21-2007, 04:21 PM
  4. Antivirus suddenly stop
    By kowell in forum Administrators
    Replies: 17
    Last Post: 03-27-2007, 04:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •