Results 1 to 9 of 9

Thread: Zimbra log full of errors

Hybrid View

  1. #1
    Join Date
    Nov 2011
    Posts
    5
    Rep Power
    4

    Default Zimbra log full of errors

    Hi all,

    I'm new to this forum so hope this is the right place to post this info. I have noticed every morning, the mail server starts to get accessible later and later. It used to be accessible around 4 AM but then recently, it's down until 5:30 and today it was down until 5:40 AM.

    I checked Zimbra status and everything was normal. Checked zimbra.log file and it was huge (the size was over 28Mb). I see a block of data being repeated in the log, would you please tell me if I should be worried or this is a normal behavior for Zimbra?

    Thanks in advance
    Code:
    Nov  2 05:11:10 mail zimbramon[26141]: 26141:info: zmmtaconfig: Sleeping...Key lookup failed. 
    Nov  2 05:11:16 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping Global system configuration update. 
    Nov  2 05:11:16 mail zimbramon[26141]: 26141:info: zmmtaconfig: gacf ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException name.domain.com:389)  
    Nov  2 05:11:17 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping All Reverse Proxy URLs update. 
    Nov  2 05:11:17 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping getAllReverseProxyURLs ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException name.domain.com:389)  
    Nov  2 05:11:17 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping All Reverse Proxy Backends update. 
    Nov  2 05:11:17 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping getAllReverseProxyBackends ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException name.domain.com:389)  
    Nov  2 05:11:18 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping All Memcached Servers update. 
    Nov  2 05:11:18 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping getAllMemcachedServers ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException name.domain.com:389)  
    Nov  2 05:11:19 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping All MTA Authentication Target URLs update. 
    Nov  2 05:11:19 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping getAllMtaAuthURLs ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException name.domain.com:389)  
    Nov  2 05:11:19 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping Configuration for server name.domain.com update. 
    Nov  2 05:11:19 mail zimbramon[26141]: 26141:info: zmmtaconfig: gs:name.domain.com ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException name.domain.com:389)

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by sparkling View Post
    I'm new to this forum so hope this is the right place to post this info.
    No it's not in the correct forum. You've posted it in the Zimbra Desktop forum, I'll move it.

    Quote Originally Posted by sparkling View Post
    II have noticed every morning, the mail server starts to get accessible later and later. It used to be accessible around 4 AM but then recently, it's down until 5:30 and today it was down until 5:40 AM.

    I checked Zimbra status and everything was normal. Checked zimbra.log file and it was huge (the size was over 28Mb). I see a block of data being repeated in the log, would you please tell me if I should be worried or this is a normal behavior for Zimbra?

    Thanks in advance
    Code:
    Nov  2 05:11:10 mail zimbramon[26141]: 26141:info: zmmtaconfig: Sleeping...Key lookup failed. 
    Nov  2 05:11:16 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping Global system configuration update. 
    Nov  2 05:11:16 mail zimbramon[26141]: 26141:info: zmmtaconfig: gacf ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException name.domain.com:389)  
    Nov  2 05:11:17 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping All Reverse Proxy URLs update. 
    Nov  2 05:11:17 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping getAllReverseProxyURLs ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException name.domain.com:389)  
    Nov  2 05:11:17 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping All Reverse Proxy Backends update. 
    Nov  2 05:11:17 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping getAllReverseProxyBackends ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException name.domain.com:389)  
    Nov  2 05:11:18 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping All Memcached Servers update. 
    Nov  2 05:11:18 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping getAllMemcachedServers ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException name.domain.com:389)  
    Nov  2 05:11:19 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping All MTA Authentication Target URLs update. 
    Nov  2 05:11:19 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping getAllMtaAuthURLs ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException name.domain.com:389)  
    Nov  2 05:11:19 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping Configuration for server name.domain.com update. 
    Nov  2 05:11:19 mail zimbramon[26141]: 26141:info: zmmtaconfig: gs:name.domain.com ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException name.domain.com:389)
    If this is a single server installation, why do you have memcahced enabled (you appear to)? Is the ZCS version information in your profile correct? For how long has this problem been happening? When did it start?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Nov 2011
    Posts
    5
    Rep Power
    4

    Default

    Phoenix,

    Thanks for your reply and sorry for not posting it in the correct place.

    The information in my profile is correct, I was asked to run a command when I was signing up at this forum and that was the output I was supposed to paste in there.

    Looks like the server started working at 5:39 AM:

    Code:
    Nov  2 05:39:20 mail zimbramon[13217]: 13217:info: Starting services initiated by zmcontrol 
    Nov  2 05:39:23 mail slapd[13419]: @(#) $OpenLDAP: slapd 2.3.42 (May 29 2008 13:41:01) $ 	build@build11:/home/build/p4/main/ThirdParty/openldap/openldap-2.3.42.6z/servers/slapd 
    Nov  2 05:39:25 mail zimbramon[26141]: 26141:info: zmmtaconfig: Skipping Global system configuration update. 
    Nov  2 05:39:25 mail zimbramon[26141]: 26141:info: zmmtaconfig: gacf ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException name.domain.com:389)  
    Nov  2 05:39:25 mail slapd[13533]: slapd starting 
    Nov  2 05:39:31 mail zimbramon[13217]: 13217:info: Rewriting configs  antispam amavis antivirus amavis imapproxy   webxml mailbox amavis antispam antivirus mta sasl    
    Nov  2 05:39:32 mail zimbramon[26141]: 26141:info: zmmtaconfig: Sleeping...Key lookup failed. 
    Nov  2 05:39:44 mail zimbramon[13217]: 13217:info: Starting logger via zmcontrol 
    Nov  2 05:39:45 mail zimbramon[13217]: 13217:info: Starting mailbox via zmcontrol 
    Nov  2 05:39:45 mail zimbramon[14567]: 14567:info: zmmtaconfig: zmmtaconfig already running at 26141 
    Nov  2 05:40:06 mail zmmailboxdmgr[15520]: status requested
    Nov  2 05:40:06 mail zmmailboxdmgr[15520]: file /opt/zimbra/log/zmmailboxd_manager.pid does not exist
    Nov  2 05:40:06 mail zmmailboxdmgr[15520]: assuming no other instance is running
    Nov  2 05:40:06 mail zmmailboxdmgr[15520]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    Nov  2 05:40:06 mail zmmailboxdmgr[15520]: assuming no other instance is running
    Nov  2 05:40:06 mail zmmailboxdmgr[15520]: no manager process is running
    Nov  2 05:40:06 mail zmmailboxdmgr[15527]: start requested
    Nov  2 05:40:06 mail zmmailboxdmgr[15527]: checking if another instance of manager is already running
    Nov  2 05:40:06 mail zmmailboxdmgr[15527]: file /opt/zimbra/log/zmmailboxd_manager.pid does not exist
    Nov  2 05:40:06 mail zmmailboxdmgr[15527]: assuming no other instance is running
    Nov  2 05:40:06 mail zmmailboxdmgr[15527]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    Nov  2 05:40:06 mail zmmailboxdmgr[15527]: assuming no other instance is running
    Nov  2 05:40:06 mail zimbramon[13217]: 13217:info: Starting imapproxy via zmcontrol 
    Nov  2 05:40:06 mail zmmailboxdmgr[15528]: wrote manager pid 15528 to /opt/zimbra/log/zmmailboxd_manager.pid
    Nov  2 05:40:06 mail zmmailboxdmgr[15528]: manager started mailboxd/JVM with pid 15535
    Nov  2 05:40:06 mail zmmailboxdmgr[15535]: wrote java pid 15535 to /opt/zimbra/log/zmmailboxd_java.pid
    Nov  2 05:40:07 mail zimbramon[13217]: 13217:info: Starting antispam via zmcontrol 
    Nov  2 05:40:08 mail zimbramon[15586]: 15586:info: zmmtaconfig: zmmtaconfig already running at 26141
    The person who set this server up is gone and I have no idea how he has it setup, standalone or not...Are the errors telling something serious is wrong with the server?

    Thanks in advance for you help

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by sparkling View Post
    The person who set this server up is gone and I have no idea how he has it setup, standalone or not...Are the errors telling something serious is wrong with the server?
    If you jst have one server with ZCS installed then it's a single server. Please post the output of the following command (run on the zimbra server):

    Code:
    su - zimbra
    zmcontrol status
    That will show the status of all the running services. How much RAM is on this server and how many users?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Nov 2011
    Posts
    5
    Rep Power
    4

    Default

    Hi Bill,

    I believe it's a single server then. Here's the output:
    Code:
     
            antispam                Running
            antivirus               Running
            imapproxy               Running
            ldap                    Running
            logger                  Running
            mailbox                 Running
            mta                     Running
            snmp                    Running
            spell                   Running
            stats                   Running
    There are 181 users, RAM info is:

    [zimbra@mail ~]$ dmesg | grep RAM
    BIOS-provided physical RAM map:
    hda: ATAPI 48X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache, UDMA(66)

    Thanks in advance

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by sparkling View Post
    I believe it's a single server then.
    Yes, that's correct it's a single server.

    Quote Originally Posted by sparkling View Post
    Here's the output:
    Code:
     
            antispam                Running
            antivirus               Running
            imapproxy               Running
            ldap                    Running
            logger                  Running
            mailbox                 Running
            mta                     Running
            snmp                    Running
            spell                   Running
            stats                   Running
    You should not have imapproxy running on a single server, I'd suggest you disable and remove the services.

    To get rid of the service(s) and reset the ports you need to follow the instructions in this thread: http://www.zimbra.com/forums/adminis...snt-exist.html I would, however, caution you to take a backup of your /opt/zimbra directory structure (with Zimbra stopped) before you make any changes - just in case.

    Just for confirmation, can you go to the 'Verify.....' sections of the Split DNS article and run all the commands there (run the commands on the Zimbra server) and post the output in this thread - please do that before you make any changes to the server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Nov 2011
    Posts
    5
    Rep Power
    4

    Default

    phoenix,

    Thanks four your reply. I ran all the commands in the verify section of split DNS and got outputs similar to what the wiki page had. Unfortunately I'm not authorized to post the outputs here as they contain our IP address and very sensitive info.

    Regarding the IMAPProxy, how would I know if it's being used? I'm afraid if I stop the service something breaks.

    I noticed the Zimbra mail server was not accessible to the users from 3:30 AM to 5:30 AM this morning. Is this a normal behaviour?

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by sparkling View Post
    Thanks four your reply. I ran all the commands in the verify section of split DNS and got outputs similar to what the wiki page had. Unfortunately I'm not authorized to post the outputs here as they contain our IP address and very sensitive info.
    You can obfuscate the information in the output to 'hide' sensitive information.

    Quote Originally Posted by sparkling View Post
    Regarding the IMAPProxy, how would I know if it's being used? I'm afraid if I stop the service something breaks.
    It's being used becasue you have it listed as a running service.

    Quote Originally Posted by sparkling View Post
    I noticed the Zimbra mail server was not accessible to the users from 3:30 AM to 5:30 AM this morning. Is this a normal behaviour?
    No, of course that's not normal behaviour.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Nov 2011
    Posts
    5
    Rep Power
    4

    Default

    Hi phoenix,

    Sorry for the late reply. I found out that the mail server is trying to get backed up with Bacula on another server, that's why it's unreachable during those hours. I will report back if I had more questions, just wanted to thank you for your helpful replies.

    Regards,
    Sparkling

Similar Threads

  1. The installer was interrupted...
    By spiderbo in forum Zimbra Connector for Outlook
    Replies: 9
    Last Post: 05-23-2013, 07:33 AM
  2. Issues after upgrading from 6.0.10 to 7
    By rhorist in forum Administrators
    Replies: 8
    Last Post: 02-25-2011, 08:38 AM
  3. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 09:56 PM
  4. [SOLVED] Error Installing Zimbra on RHEL 5
    By harris7139 in forum Installation
    Replies: 10
    Last Post: 09-25-2007, 12:39 PM
  5. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 12:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •