Results 1 to 5 of 5

Thread: problems with changed timezone

  1. #1
    Join Date
    Apr 2011
    Location
    Russia
    Posts
    10
    Rep Power
    4

    Default problems with changed timezone

    Hi,
    Not a while ago, goverment cancelled daylight saving time in Russia, so every russian zone changed, for example Europe/Moscow now is GMT+4 MSK, not GMT+3/+4 MSK/MSD.
    As last update for zimbra opensource didnt contains update for timezones, I tried to change them manually: edited zimbra/conf/timezone.ics so Moscow timezone looks like this:
    Code:
    BEGIN:VTIMEZONE
    TZID:Europe/Moscow
    LAST-MODIFIED:20111109T120700Z
    X-ZIMBRA-TZ-PRIMARY:TRUE
    X-ZIMBRA-TZ-MATCH-SCORE:100
    X-ZIMBRA-TZ-ALIAS:(GMT+04.00) Moscow / St. Petersburg / Volgograd
    X-ZIMBRA-TZ-ALIAS:(UTC+04.00) Moscow / St. Petersburg / Volgograd
    BEGIN:STANDARD
    TZNAME:MSK
    DTSTART:19710101T020000
    TZOFFSETTO:+0400
    TZOFFSETFROM:+0400
    END:STANDARD
    END:VTIMEZONE
    then restarted mailboxd.

    Well, as i can tell it works fine - time in appointments is set correctly. However, description in web interface (in admin or personal settings, in COS settins, in domain settings) still labels this zone as "(GMT+03) Moscow St.Petersburg Volgograd", same phrase is put in invitations cards:
    Code:
    Description:
    	
    
    The following is a new meeting request: Subject: test4 Organizer: "Демченко Юрий Александрович" <y.demchenko@csbigroup.ru> Time: Friday, November 11, 2011, 12:00:00 PM - 12:30:00 PM GMT +03:00 Moscow, St. Petersburg, Volgograd Invitees: demchenko.ya@gmail.com
    And while in web-interface, calendar shows meetings in right cells (for example, i set up meeting from noon to 13:00 - it shows in cells from noon to 13:00), but when i move up cursor above it - popup shows wrong time (from 13:00 to 14:00).

    So, my question is - how do i fix this? I need Moscow timezone to be GMT+4 without errors.

    Another problem - I set preferences for default COS - timezone "Europe/Moscow", same in preferences for my domain, same in personal account preferences, but still for new meetings i get wrong timezone set by default - GMT+4 Tbilisi (before i changed timezone.ics, i tried just to change default COS settings and set this timezone as default). How do i fix this?

  2. #2
    Join Date
    Apr 2011
    Location
    Russia
    Posts
    10
    Rep Power
    4

    Default

    am I only one who uses ZCS in Russia? noone else had that problem?

  3. #3
    Join Date
    Dec 2009
    Location
    Moscow, Russia
    Posts
    9
    Rep Power
    5

    Default

    Agree with the question. Can we wait in 7.1.4 the patch with fixing a problem with changing the time zone for russian users?

  4. #4
    Join Date
    Sep 2010
    Location
    Russia, Abakan
    Posts
    18
    Rep Power
    5

    Default

    I have this problem too. I also as you changed timezones.ics, but problem not resolved. I also converted existing appointments according this guide Changing ZCS Time Zones - Zimbra :: Wiki May be we should submit a bug report? I'm not sure that zimbra guys know about cancelling daylight saving time in Russia.

  5. #5
    Join Date
    Apr 2011
    Location
    Russia
    Posts
    10
    Rep Power
    4

    Default

    there's an open bug allready in bugzilla, i've voted for it
    Bug 66542 &ndash; Problems with Russian Time Zone - Europe/Moscow

Similar Threads

  1. Replies: 1
    Last Post: 11-09-2011, 03:45 PM
  2. Outlook having problems connecting to Zimbra server
    By Labsy in forum Administrators
    Replies: 3
    Last Post: 03-09-2011, 11:33 AM
  3. 5.0 Install tasks
    By JoshuaPrismon in forum Installation
    Replies: 2
    Last Post: 06-06-2007, 12:18 PM
  4. httpd resident in memory but not accessible
    By AlexanderH in forum Installation
    Replies: 3
    Last Post: 05-11-2007, 09:19 AM
  5. Calender entry Timezone problems (iCal)
    By gero in forum Administrators
    Replies: 0
    Last Post: 02-06-2007, 04:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •