Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Change Hostname Zimbra 7.0

  1. #11
    Join Date
    Jun 2009
    Posts
    10
    Rep Power
    6

    Default [SOLVED] in zimbra 7

    Quote Originally Posted by cloudmafia View Post
    I think i can help you in this...


    First of all...

    If you are using local dns then configure DNS for new hostname and make changes in resolv.conf and hosts file... confirm dns is resolving your queries...
    use dig,nslookup and host commands...Reboot the system...

    Note - Before Processding for next step make sure that your dns server is resolving you hostname A record and MX record.

    Login with root.
    follow the below instructions.

    # su - zimbra

    $ zmcontrol stop

    $ /opt/zimbra/libexec/zmsetservername -force -n new.hostname.com
    (you will receive some errors but ignore them)

    $ /opt/zimbra/libexec/zmsetservername -o old.hostname.com -n new.hostname.com

    (it will not show any error and work fine)


    Set Default Domain-
    $ zmprov -l mcf zimbraDefaultDomainName newdomain.com


    Generate New ssh key for zimbra and update it

    $ zmsshkeygen

    $ zmupdateauthkeys

    $ zmcontrol start


    (it should start your zimbra successfully)


    Now if you are using self signed certificate so you have to create new certificate following below instruction...but before that make sure you system
    timezone and you zimbra server timezones are same.

    $ exit

    # su - zimbra -c 'zmcontrol stop'

    # rm -rf /opt/zimbra/ssl/*

    # rm -rf /opt/zimbra/ssl/.rnd

    # /opt/zimbra/java/bin/keytool -delete -alias my_ca -keystore /opt/zimbra/java/jre/lib/security/cacerts -storepass changeit

    # /opt/zimbra/java/bin/keytool -delete -alias jetty -keystore /opt/zimbra/mailboxd/etc/keystore -storepass `su - zimbra -c 'zmlocalconfig -s -m nokey mailboxd_keystore_password'`

    # vim /opt/zimbra/bin/zmcertmgr

    Find line
    SUBJECT="/C=US/ST=N\/A/L=N\/A/O=Zimbra Collaboration Suite/OU=Zimbra Collaboration Suite/CN=${zimbra_server_hostname}"
    and change to your company name

    then find and change you want value days expire cert validation_days=365 to validation_days=3650

    (save & exit)

    # /opt/zimbra/bin/zmcertmgr createca -new

    # /opt/zimbra/bin/zmcertmgr deployca -localonly

    # /opt/zimbra/bin/zmcertmgr createcrt self -new

    # /opt/zimbra/bin/zmcertmgr deploycrt self

    # su - zimbra -c 'zmcontrol start'

    It should start all the services successfully without any error.



    # /opt/zimbra/bin/zmcertmgr deploycrt self

    # /opt/zimbra/bin/zmcertmgr deployca

    # su - zimbra -c 'zmupdateauthkeys'

    # /opt/zimbra/bin/zmcertmgr viewdeployedcrt


    Login to Web link and check whether everything is working well or not.
    Check newly installed certificates and running services.


    https://<ip address> >>> web mail login

    https://<ip address>:7071/zimbraAdmin >>> Admin console login


    Enjoy...
    Cheers

    ------
    Neo
    Thanks with the solution, i had a problem to start ldap i have used
    As Root:
    rm -rf /opt/zimbra/ssl
    mkdir /opt/zimbra/ssl
    chown zimbra:zimbra /opt/zimbra/ssl
    chown zimbra:zimbra /opt/zimbra/java/jre/lib/security/cacerts
    chmod 644 /opt/zimbra/java/jre/lib/security/cacerts


    and it was OK, thank again

  2. #12
    Join Date
    Aug 2007
    Location
    London, UK
    Posts
    297
    Rep Power
    8

    Default

    @cloudmafia
    Thanks for the excellent write-up on these steps! I can confirm this worked for a server migration on Zimbra 7.2.3
    My Zimbra Bugs Wishlist: 16411, 24567, 35676, 36430, 37770, 41872, 43733, 44384, 46383, 47759
    And a way to associate mailto: handlers with a Zimbra Prism webapp

Similar Threads

  1. ZCS7 Beta only Listens on IPv6
    By tobru in forum Installation
    Replies: 2
    Last Post: 03-25-2011, 03:31 AM
  2. [SOLVED] Error Installing Zimbra on RHEL 5
    By harris7139 in forum Installation
    Replies: 10
    Last Post: 09-25-2007, 11:39 AM
  3. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 02:30 PM
  4. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •