Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: mail.NO_SUCH_BLOB error on most accounts

  1. #11
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    148
    Rep Power
    7

    Default

    Ajcody-Notes-No-Such-Blob - Zimbra :: Wiki - there's no reference to whether or not this applies to 7.1.x and it says right at the top it's not "official" as it's user contributed. It seems that such a heavily developed solution that is far from inexpensive has no easy-to-find official up-to-date information on an issue that is affecting a number of admins. Perhaps it is there but I've gone through all sorts of things and so far I'm not sure what I should do about this. For example on the Ajcody notes it says at the top
    # On 5.0.6+ there's a script, /opt/zimbra/bin/zmblobchk , that you can use instead of this.
    Well, zmblobchk doesn't behave quite the same as indicated in the article so it's hard to know which steps to follow and which not to.

  2. #12
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    148
    Rep Power
    7

    Default Some Help From Support on No Such Blob Issues

    So the steps I'm following as directed by Zimbra support:

    When logged in as user zimbra, first I did an ls on /opt/zimbra/store/0/ to find out what the highest mailbox number was in the blob store. In my case it was 201.

    Next I did a quick script to run through 1-201 to get a list of blob errors using:
    zmblobchk -m$NUMBER --export-dir /tmp/zmblobchk start | grep "unexpected blob" >>/tmp/BlobErrors.txt
    * In my case I replace $NUMBER with the mailbox number from 1-201

    Next I get the email account name for each number
    mysql zimbra -Ne 'select comment from mailbox where id=$NUMBER'

    Now this part was a little trickier. I took the information in /tmp/BlobErrors.txt to extract the path and filename, connected it to the correct account name and came up with the command to insert the missing blob:
    zmmailbox -z -m sysadmin@mydomainname.com am /Inbox /opt/zimbra/store/0/24/msg/210/860520-961900.msg

    UPDATE: I had to add rm -f /opt/zimbra/store/0/24/msg/210/860520-961900.msg for each blob to remove the old orphaned blob file once the insert was completed. NOTE!!! You may want to back this file and location etc. up in case things go awry...

    I'm running these from the zimbra user in a shell script and it looks like the messages are importing.
    Last edited by rotorboy; 04-13-2012 at 05:03 PM.

  3. #13
    Join Date
    Nov 2011
    Posts
    7
    Rep Power
    4

    Default

    Ok, I've written a script to extract the blob errors. There are 401,951 errors.

    I ran the command:
    mysql zimbra -Ne 'select id,comment from mailbox where id is not null'
    to extract a list of id's and users.

    Now, I need to run:
    zmmailbox -z -m User@Domain.com am /Inbox Message.msg

    I'm just asking this to be sure? There are 401951 errors in the blob list. How long will it take to fix these errors? Can I do it in batches?

  4. #14
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    148
    Rep Power
    7

    Default

    I only had 6500 errors and it took a few hours to run... I did split mine into 3 batches.

Similar Threads

  1. Multiple Mail Accounts, Folders
    By skwdenyer in forum Users
    Replies: 12
    Last Post: 12-01-2013, 08:52 PM
  2. Import/Export accounts from one computer to another?
    By Rand Bliss in forum General Questions
    Replies: 1
    Last Post: 08-18-2013, 05:29 PM
  3. Missing Accounts in Backup!
    By Yopofun in forum Administrators
    Replies: 2
    Last Post: 12-08-2010, 01:22 PM
  4. Delete old archive accounts?
    By fnbwaseca in forum Administrators
    Replies: 0
    Last Post: 11-29-2010, 09:17 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •