I am updaing 6.0.7 to 6.0.9_GA_2686.UBUNTU10_64 UBUNTU10_64 FOSS edition on Ubuntu 10.04 LTS.

Everything goes OK until it tries to set the zimbraMTAAuthHost. This is what I see in the zmsetup.log...

Fri Dec  2 12:50:02 2011 Setting MTA auth host...
Fri Dec  2 12:50:02 2011 Updating cached config attribute for Server mail.bkivv.org: zimbraMtaAuthHost=mail.bkivv.org
Fri Dec  2 12:50:02 2011 *** Running as zimbra user: /opt/zimbra/bin/zmprov -m -l ms mail.bkivv.org zimbraMtaAuthHost 'mail.bkivv.org'
ERROR: service.INVALID_REQUEST (invalid request: specified zimbraMtaAuthHost does not correspond to a valid service hostname: mail.bkivv.org)
Fri Dec  2 12:50:04 2011 failed.
The server I am working on is a clone, so yes, the IP address doesn't match the global DNS settings. However I have set the hosts file correctly and temporarily installed dnsmasq to keep any DNS checks happy. Ping, dig and nslookup all now report the IP address to be the local machine's IP address.

The entry in the /etc/hosts file is...
Code:             mail.bkivv.org  mail
nslookup response is...

Name:   mail.bkivv.org
I've tried setting zimbraMtaAuthHost at the command line but get the same error as I see in the install log.