Results 1 to 4 of 4

Thread: [SOLVED] Zimbra mail queue error

  1. #1
    Join Date
    Oct 2006
    Rep Power

    Default [SOLVED] Zimbra mail queue error

    Zimbra show error while we navigate to the mail queue monitoring part (admin console). It show a error related to ssh key authentication. When I tried to search for the solution in forum, they have mentioned two type of solution which are as follows.

    Error :
    Message: system failure: exception during auth {RemoteManager:>}

    com.zimbra.cs.service.ServiceException: system failure: exception during auth {RemoteManager:>}

    at com.zimbra.cs.service.ServiceException.FAILURE(Ser

    at com.zimbra.cs.rmgmt.RemoteManager.getSession(Remot

    at com.zimbra.cs.rmgmt.RemoteManager.execute(RemoteMa

    at com.zimbra.cs.service.admin.GetMailQueueInfo.handl e(

    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng

    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:162)

    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)

    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:223)

    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)

    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra

    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)

    at ternalDoFilter(

    at Filter(

    at org.apache.catalina.core.StandardWrapperValve.invo ke(

    at org.apache.catalina.core.StandardContextValve.invo ke(

    at org.apache.catalina.core.StandardHostValve.invoke(

    at org.apache.catalina.valves.ErrorReportValve.invoke (

    at org.apache.catalina.core.StandardEngineValve.invok e(

    at org.apache.catalina.valves.AccessLogValve.invoke(A

    at org.apache.catalina.connector.CoyoteAdapter.servic e(

    at org.apache.coyote.http11.Http11Processor.process(H

    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt

    at Socket(

    at ead.runIt(

    at org.apache.tomcat.util.threads.ThreadPool$ControlR


    Caused by: auth failed

    at com.zimbra.cs.rmgmt.RemoteManager.getSession(Remot

    ... 24 more

    Error code: service.FAILURE

    Method: ZmCsfeCommand.prototype.invoke


    First Solution:

    1) they have asked us following set of commands
    2) su -zimbra
    3) zmsshkeygen
    4) zmupdateauthkeys
    5) tomcat restart

    Second Solution:

    1) the identification public key in ~zimbra/.ssh/
    2) we have to manually copying the key from this file ~zimbra/.ssh/ and we have paste them in the following file .( we need to create those file )
    a) ~zimbra/.ssh/authorized_hosts
    b) ~zimbra/.ssh/known_hosts

    i have tried both the solution , still the problem persist . can any 1 guide me regarding this
    Last edited by chenthil; 11-12-2006 at 11:46 PM.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    Is there a firewall or SElinux active? If so, disable them both? Is the sshd daemon running? Is the rest of zimbra working OK? Which operating system & version/release of zimbra?
    Last edited by phoenix; 11-13-2006 at 12:20 AM.


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Oct 2006
    Rep Power

    Thumbs up problem solved

    I have blocked all the ssh user in the configuration file and i have enabled selinux in them also ..

    After unblocking them , things seems to be fine .. now

    thanks for the replying me

  4. #4
    Join Date
    Feb 2008
    Rep Power

    Smile how to fix it.

    To explain this one a bit further, as this KILLED us for several days....

    One of the more common ways to secure a Linux box is to tweak your sshd_conf file. Commonly in /etc/ssh. One of the things you do is PermitRootLogin=no.

    Some, such as myself, add the following after that section;
    add "AllowUsers user1 user2" where user1, user2, etc are the users that are allowed to login (all other users will be denied through ssh, including zimbra)

    Then restart sshd. Pretty standard basic ssh security. The only problem is that when you specify what users can use ssh, zimbra can't, thus breaking the mail queue screen. Not sure why it is just that screen, but this fixes it.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. Replies: 31
    Last Post: 12-15-2007, 08:05 PM
  3. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 10:30 PM
  4. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 03:33 PM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts