Results 1 to 10 of 31

Thread: Renewing certificate failed zimbra 6

Threaded View

  1. #1
    Join Date
    Nov 2011
    Posts
    6
    Rep Power
    3

    Default Renewing certificate failed zimbra 6

    Hi
    I've installed zimbra on RHEL5 and It was working fine for about a year when it failed to start.
    I'm running zimbra behind an adsl router with port forwarding enabled on that.
    when I try to start the service it gives the following msg.

    [zimbra@mail ~]$ zmcontrol start
    Host mail.mail-server.com
    Unable to determine enabled services from ldap.
    Unable to determine enabled services. Cache is out of date or doesn't exist.
    [zimbra@mail ~]$

    some of the threads which discussed similar matters in the web said this caused due to wrong configuration of SPLIT DNS ! but since It worked really well for a year That seems to be doubtful here.

    When i checked my certificate expiration using "/opt/zimbra/bin/zmcertmgr viewdeployedcrt" it showed that they are expired.


    Im using ZCS v6.0.8

    [zimbra@mail ~]$ zmcontrol -v

    Release 6.0.8_GA_2661.RHEL5_20100820051652 RHEL5 FOSS edition.
    [zimbra@mail ~]$

    I used following link to recreate Zimbra certificates
    Administration Console and CLI Certificate Tools - Zimbra :: Wiki

    but when I run the 2nd step of "Single-Node Self-Signed Certificate" the command faild with following output !

    [root@mail zimbra]# /opt/zimbra/bin/zmcertmgr createcrt -new -days 365
    Validation days: 365
    ** Creating /opt/zimbra/conf/zmssl.cnf...done
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20111212212528
    ** Generating a server csr for download self -new -keysize 1024
    ** Creating /opt/zimbra/conf/zmssl.cnf...done
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20111212212528
    ** Retrieving Commercial CA cert from ldap...failed.
    ** Creating server cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    ** Saving server config key zimbraSSLPrivateKey...failed.
    ** Signing cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    [root@mail zimbra]#



    It tries to Retrieve commercial Certificate. But I did installed the free version
    and saving server config key zimbraSSLPrivatekey.... faild ??


    Any Help Regarding the above matter would be Highly appriciated.

    Thanx in Advanced !
    Last edited by phoenix; 12-12-2011 at 08:34 AM.

Similar Threads

  1. Did I miss something? (Zimbra GA 6.0.8 on Ubuntu 10.04)
    By vpetersson in forum Installation
    Replies: 2
    Last Post: 10-26-2010, 06:29 AM
  2. Old Backup stay in TO_DELETE status and no clearing..
    By bartounet in forum Administrators
    Replies: 0
    Last Post: 10-05-2010, 07:40 AM
  3. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 01:00 AM
  4. Big Fubar on 5 FOSS GA Upgrade
    By uxbod in forum Administrators
    Replies: 24
    Last Post: 01-21-2008, 02:37 AM
  5. My Zimbra server down ... please help :)
    By frankb in forum Administrators
    Replies: 2
    Last Post: 12-12-2007, 10:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •