Results 1 to 3 of 3

Thread: Unable to receive mail

  1. #1
    Join Date
    Dec 2011
    Rep Power

    Default Unable to receive mail


    I have the following error messages which I hoped would explain why my server cannot deliver mail:

    From zimbra.log:

    Dec 17 01:58:08 mail postfix/qmgr[10457]: 8ED02460BB5: from=<>, size=2428, nrcpt=1 (queue active)
    Dec 17 01:58:08 mail amavis[6968]: (06968-01) (!)connect_to_ldap: unable to connect to host ldap://
    Dec 17 01:58:08 mail amavis[6968]: (06968-01) (!!)TROUBLE in process_request: connect_to_ldap: unable to connect at (eval 98) line 104, <GEN14> line 5.
    Dec 17 01:58:08 mail amavis[6968]: (06968-01) (!)Requesting process rundown after fatal error
    Dec 17 01:58:08 mail postfix/smtp[19055]: 8ED02460BB5: to=<>, relay=[]:10024, delay=8830, delays=8829/0.01/0.01/0.11, dsn=4.3.2, status=deferred (host[] said: 421 4.3.2 Service shutting down, closing channel (in reply to RCPT TO command))

    The above sequence is obtained by requeing a message that is currently held. I have searched for amavis information but I have found nothing relating to ldap.

    When I try to send a message from one local user to another with the webmail client then I get this error (at the webmail client, nothing in zimbra.log):

    method: [unknown]
    msg: system failure: Unable to get SMTP session for [com.zimbra.cs.account.ldap.LdapAccount]
    code: service.FAILURE
    detail: soap:Receiver
    trace: com.zimbra.common.service.ServiceException: system failure: Unable to get SMTP session for [com.zimbra.cs.account.ldap.LdapAccount] ExceptionId:btpool0-11:// Code:service.FAILURE at com.zimbra.common.service.ServiceException.FAILURE ( at com.zimbra.cs.mailbox.Mailbox.getMailSender(Mailbo at com.zimbra.cs.service.mail.SendMsg.doSendMessage(S at com.zimbra.cs.service.mail.SendMsg.handle(SendMsg. java:154) at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:287) at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:158) at com.zimbra.soap.SoapServlet.doWork(SoapServlet.jav a:294) at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:215) at javax.servlet.http.HttpServlet.service(HttpServlet .java:725) at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra at javax.servlet.http.HttpServlet.service(HttpServlet .java:814) at org.mortbay.jetty.servlet.ServletHolder.handle(Ser at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter( at com.zimbra.cs.servlet.SetHeaderFilter.doFilter(Set at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter( at org.mortbay.servlet.UserAgentFilter.doFilter(UserA at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132) at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter( at org.mortbay.jetty.servlet.ServletHandler.handle(Se at at org.mortbay.jetty.servlet.SessionHandler.handle(Se at org.mortbay.jetty.handler.ContextHandler.handle(Co at org.mortbay.jetty.webapp.WebAppContext.handle(WebA at org.mortbay.jetty.handler.ContextHandlerCollection .handle( at org.mortbay.jetty.handler.HandlerCollection.handle ( at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle( at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha at org.mortbay.jetty.handler.DebugHandler.handle(Debu at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha at org.mortbay.jetty.Server.handle( at org.mortbay.jetty.HttpConnection.handleRequest(Htt at org.mortbay.jetty.HttpConnection$ ntent( at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:756) at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa at org.mortbay.jetty.HttpConnection.handle(HttpConnec at at org.mortbay.thread.BoundedThreadPool$ n( Caused by: javax.mail.MessagingException: No SMTP hosts available for domain at com.zimbra.cs.util.JMSession.getSmtpSession(JMSess at com.zimbra.cs.util.JMSession.getSmtpSession(JMSess at com.zimbra.cs.mailbox.Mailbox.getMailSender(Mailbo ... 37 more

    I am authenticating users via an openldap server on another box, and that is working since I can log on in the webmail client.

    Any ideas anyone?

  2. #2
    Join Date
    Dec 2011
    Rep Power

    Default Solved!

    Firstly thanks for your reply. In the end I stayed up until 4:30 am this morning and found the problem, and it seems that you would have pointed me in the right direction as well!

    For a reason that I don't understand as yet, my FQDN had become attached to the IPV6 address in /etc/hosts and therefore as LDAP was running and listening on port 389, it was not accepting connections to the IPV4 address that was being returned by the (split mode) DNS query.

    I fixed the /etc/hosts and all is OK.

    As I say I'm not what triggered this.

    And, no I do not administer, I have, well, censored my post.

    thanks again.

  3. #3
    Join Date
    Dec 2011
    Rep Power


    yes can be marked as solved.

Similar Threads

  1. Replies: 8
    Last Post: 04-10-2011, 09:14 AM
  2. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  3. Problem with Postfix and MTA
    By ZMilton in forum Administrators
    Replies: 16
    Last Post: 04-16-2008, 06:47 AM
  4. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  5. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 06:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts