Results 1 to 2 of 2

Thread: [SOLVED] some users getting login errors using ActiveSync

  1. #1
    Join Date
    Nov 2008
    Location
    Grand Rapids, MI
    Posts
    123
    Rep Power
    6

    Default [SOLVED] some users getting login errors using ActiveSync

    So, I had users getting strange errors trying to connect via ActiveSync to ZCS NE 7.1.3 after installing zimbra-proxy. Google found nobody that was getting these errors, so I'm mostly posting this so it'll show up in searches for any future people who run into this error.

    The users who were unable to log in would have errors like this show up in mailbox.log:

    2011-12-31 11:43:28,642 INFO [btpool0-76://mailbox1.hostname.com/service/extension/nginx-lookup] [] nginx - user not found:username@domain.com@our.public.service.hostn ame.com

    Note the two @ signs in there. Turns out several of our users had put the domain name of the server into their "Domain" field in the ActiveSync setup. When talking to Zimbra's mailbox server directly it apparently takes this. The proxy authentication within nginx does not. In order for authentication via nginx to work, the users needed to leave the "Domain" field blank in their ActiveSync config.

  2. #2
    Join Date
    Nov 2008
    Location
    Grand Rapids, MI
    Posts
    123
    Rep Power
    6

    Default

    Also, taking a wild guess, I suspect that leaving the @domain.name off of your username and placing that in the domain field by itself would likely work, too, but we didn't try that yet. I suspect if you're using ActiveDirectory on the back end that the domain might actually matter, but since we're not...

Similar Threads

  1. users login with full email address
    By utsile in forum Users
    Replies: 4
    Last Post: 11-06-2011, 11:03 PM
  2. [SOLVED] List all activesync users
    By i2ambler in forum Administrators
    Replies: 2
    Last Post: 04-22-2011, 11:10 AM
  3. [SOLVED] AD Users cannot login
    By acelmanaged in forum Administrators
    Replies: 12
    Last Post: 03-30-2011, 09:19 AM
  4. Login showing wrong users email
    By gfdos.sys in forum Administrators
    Replies: 10
    Last Post: 04-08-2008, 08:13 AM
  5. get a login user's phone number from GAL
    By Yokomie in forum Zimlets
    Replies: 0
    Last Post: 04-16-2007, 12:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •