Results 1 to 10 of 10

Thread: mailing between different Zimbra mail domains

  1. #1
    Join Date
    Oct 2005
    Posts
    206
    Rep Power
    9

    Default mailing between different Zimbra mail domains

    Hello,

    As I understand with Zimbra it's possible to configure different (Zimbra) mail-domains :-)


    Will such Zimbra-user be able to send/receive mails to users from different Zimbra mail domains "out of the box"?
    Or are there some special things to consider/configure ?


    Thank you!

    John

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    I'll move this to the correct forum as it's not a question about the Installation of Zimbra (which is where you posted).

    Quote Originally Posted by john99 View Post
    As I understand with Zimbra it's possible to configure different (Zimbra) mail-domains :-)
    Yes.

    Quote Originally Posted by john99 View Post
    Will such Zimbra-user be able to send/receive mails to users from different Zimbra mail domains "out of the box"?
    Of course you can send mail to each of the domains on the same server.

    Quote Originally Posted by john99 View Post
    Or are there some special things to consider/configure ?
    Only the same things you'd configure for a single domain e.g. DNS A & MX records.
    Last edited by phoenix; 01-12-2012 at 11:05 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Oct 2005
    Posts
    206
    Rep Power
    9

    Default

    Thank's for the help Bill!

    Should that work as well, if the Postfix-MTA and Fetchmail are not yet installed/configured properly (e.g. for demonstration purposes) ?


    Thank you!

    John


    PS:
    But if Split-DNS is working properly :-)

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by john99 View Post
    Should that work as well, if the Postfix-MTA and Fetchmail are not yet installed/configured properly (e.g. for demonstration purposes) ?
    I don't quite understand that question. The Postfix-MTA on your server is not required (if that's what you're talking about) by zimbra nor is fetchmail (that just gets mail from an external accounts).

    Quote Originally Posted by john99 View Post
    But if Split-DNS is working properly :-)
    If you already have a Split DNS set-up then just adding DNS A & MX records for the additional domain(s) will allow you to send mail between each of those domains. You'd also need valid DNS A & MX records for the additional domain(s) on an external DNS server so that they can additionally receive mail from the internet.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Oct 2005
    Posts
    206
    Rep Power
    9

    Default

    Quote Originally Posted by phoenix View Post
    If you already have a Split DNS set-up then just adding DNS A & MX records for the additional domain(s) will allow you to send mail between each of those domains. You'd also need valid DNS A & MX records for the additional domain(s) on an external DNS server so that they can additionally receive mail from the internet.

    Ok the following was our db.lan.mycompanyname.com file:

    ************************************************** ******
    -> ; BIND data file for local loopback interface
    -> ;
    -> $TTL 604800
    -> @ IN SOA nsizhma01.lan.mycompanyname.com. admin.nsizhns01.lan.mycompanyname.com. (
    -> 9 ; Serial
    -> 604800 ; Refresh
    -> 86400 ; Retry
    -> 2419200 ; Expire
    -> 604800 ) ; Negative Cache TTL
    -> ;
    -> @ IN NS nsizhns01
    -> @ IN MX 10 nsizhma01
    -> nsizhns01 IN A 10.0.1.50
    -> nsizhma01 IN A 10.0.1.10

    ************************************************** ******
    PS:
    - nsizhns01 IN A 10.0.1.50 (this is the DNS-server)
    - nsizhma01 IN A 10.0.1.10 (this is the mailserver/ZCS)
    ************************************************** ******


    Question:
    Do you mean, the additional mail-domains should have been added just after the following entries ?

    @ IN SOA nsizhma01.lan.mycompanyname.com. admin.nsizhns01.lan.mycompanyname.com.



    Thank's a lot for any additonal feadback!

    John

  6. #6
    Join Date
    Oct 2005
    Posts
    206
    Rep Power
    9

    Default

    I would appreciate additional help very much in order to be able to set up a running Zimbra environment soon :-)


    Thank you very much!

    John

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by john99 View Post
    I would appreciate additional help very much in order to be able to set up a running Zimbra environment soon :-)
    I've already given you the answer to this just add additional records for the new domain. Go to the Split DNS and see the requirements for the BIND DNS server (I don't like the format you're using for your records).

    If you want an easier way to manage the DNS you could install webmin on your server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Oct 2005
    Posts
    206
    Rep Power
    9

    Default

    Thank's a lot Bill for the help!

    Quote Originally Posted by phoenix View Post
    I don't like the format you're using for your records.
    Thank's, I am willing to learn :-)


    Originally I was not my intention to have different mail domains. According my "log-file", during installation of Zimbra, i get the following message:

    DNS Error resolving MX for nsizhma01.lan.mycompanyname.com
    It is suggested that the domain name have an MX record configured in DNS
    Change doamain name? [Yes]yes
    Create domain: [nsizhma01.lan.mycompanyname.com]lan mycompanyname.com


    Was this [Yes] the reason that finally in the Zimbra-Admin GUI, I had the following mail domains ?

    - (admin@)lan.mycompanyname.com[/email]
    - (user@)mycompanyname.com[/email]


    Thank you!

    John


    PS
    Unfortunately I am not sure anymore if during installation of Zimbra my zone file looked really the way I posted it in this thread ...
    Last edited by john99; 01-28-2012 at 12:57 AM. Reason: spelling eror

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by john99 View Post
    Thank's, I am willing to learn :-)
    It's just a personal preference but I prefer that the domain name and FQDN of the server is spelt out, that way it's easier to see if you have the correct domain and you can easily add multiple domains without too much confusion.

    Quote Originally Posted by john99 View Post
    Was this [Yes] the reason that finally in the Zimbra-Admin GUI, I had the following mail domains ?
    Yes it was the reason. When doing the initial installation Zimbra will, if you enter 'No', use the FQDN of your server as the domain name. Is this all working correctly now?
    Last edited by phoenix; 06-21-2013 at 04:44 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    Join Date
    Oct 2005
    Posts
    206
    Rep Power
    9

    Default

    Quote Originally Posted by phoenix View Post
    Yes it was the reason. When doing the initial installation Zimbra will, if you enter 'No', use the FQDN of your server as the domain name. Is this all working correctly now?
    Thank you very much Bill for your help. I promise that I am soon going to (re-)install Zimbra :-)

    Best regards,

    John


    PS
    This was an old issue and I was at this point in time not able to install ZSC properly.

Similar Threads

  1. What to clean on a Zimbra mail server?
    By tezarin in forum Administrators
    Replies: 11
    Last Post: 12-16-2011, 11:43 AM
  2. Replies: 12
    Last Post: 03-23-2011, 09:39 PM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  4. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 02:30 PM
  5. fatal: Queue report unavailable - mail system is down
    By zzzzsg in forum Administrators
    Replies: 16
    Last Post: 08-24-2006, 02:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •