Results 1 to 5 of 5

Thread: mailbox mysql.server stats is not running

Hybrid View

  1. #1
    Join Date
    Jan 2012
    Posts
    2
    Rep Power
    3

    Unhappy mailbox mysql.server stats is not running

    Good day

    I'm new to zimbra.
    My version is:

    zmcontrol -v
    Release 5.0.16_GA_2921.UBUNTU8 UBUNTU8 FOSS edition

    We have been running this zombra server successfull for 3 years + now with only minor hicups here and there. We have about 260 mail users.

    when doing zmcontrol status I get:

    zimbra@zimbra:~/log$ zmcontrol status
    Host zimbra.mastercare.co.za
    antispam Running
    antivirus Running
    ldap Running
    mailbox Stopped
    mysql.server is not running.
    mta Running
    snmp Running
    spell Running
    stats Stopped

    When doing zmcontrol stop I get:

    zimbra@zimbra:~/log$ zmcontrol stop
    Host zimbra.mastercare.co.za
    Stopping stats...Done
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done
    Stopping archiving...Done
    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done
    Stopping logger...Done
    Stopping ldap...Done

    When starting zmcontrol:

    zimbra@zimbra:~/log$ zmcontrol start
    Host zimbra.mastercare.co.za
    Starting ldap...Done.
    Starting mailbox...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...Done.
    Starting spell...Done.
    Starting mta...Done.
    Starting stats...Done.

    But when checking the status:

    zimbra@zimbra:~/log$ zmcontrol status
    Host zimbra.mastercare.co.za
    antispam Running
    antivirus Running
    ldap Running
    mailbox Stopped
    mysql.server is not running.
    mta Running
    snmp Running
    spell Running
    stats Stopped

    When manualy restarting mysql.server it starts but when doing zmcontrol status is is still not running.

    /opt/zimbra/log/myslow.log displays this:

    /opt/zimbra/mysql/libexec/mysqld, Version: 5.0.67-log (Source distribution). started with:
    Tcp port: 7306 Unix socket: /opt/zimbra/db/mysql.sock
    Time Id Command Argument
    /opt/zimbra/mysql/libexec/mysqld, Version: 5.0.67-log (Source distribution). started with:
    Tcp port: 7306 Unix socket: /opt/zimbra/db/mysql.sock
    Time Id Command Argument
    /opt/zimbra/mysql/libexec/mysqld, Version: 5.0.67-log (Source distribution). started with:
    Tcp port: 7306 Unix socket: /opt/zimbra/db/mysql.sock
    Time Id Command Argument
    /opt/zimbra/mysql/libexec/mysqld, Version: 5.0.67-log (Source distribution). started with:
    Tcp port: 7306 Unix socket: /opt/zimbra/db/mysql.sock
    Time Id Command Argument
    /opt/zimbra/mysql/libexec/mysqld, Version: 5.0.67-log (Source distribution). started with:
    Tcp port: 7306 Unix socket: /opt/zimbra/db/mysql.sock
    Time Id Command Argument
    /opt/zimbra/mysql/libexec/mysqld, Version: 5.0.67-log (Source distribution). started with:
    Tcp port: 7306 Unix socket: /opt/zimbra/db/mysql.sock
    Time Id Command Argument
    /opt/zimbra/mysql/libexec/mysqld, Version: 5.0.67-log (Source distribution). started with:
    Tcp port: 7306 Unix socket: /opt/zimbra/db/mysql.sock
    Time Id Command Argument
    /opt/zimbra/mysql/libexec/mysqld, Version: 5.0.67-log (Source distribution).


    What is very alarming to me is that the /opt/zimbra/db* is EMPTY...

    zimbra@zimbra:~/db$ ls -al /opt/zimbra/db/
    total 8
    drwxr-xr-x 2 zimbra zimbra 4096 May 29 2011 .
    drwxr-xr-x 50 root root 4096 May 29 2011 ..


    /opt/zimbra/store contains
    zimbra@zimbra:~/store$ ls -al
    total 28
    drwxr-xr-x 5 zimbra zimbra 4096 May 23 2011 .
    drwxr-xr-x 50 root root 4096 May 29 2011 ..
    drwxr-x--- 256 zimbra zimbra 12288 Nov 3 13:45 0
    drwxr-x--- 2 zimbra zimbra 4096 Jun 22 2011 incoming
    drwxrwxrwx 2 zimbra zimbra 4096 May 23 2011 temp

    The /opt/zimbra/store/incoming and /opt/zimbra/store temp is empty
    /opt/zimbra/store/0 contains data:

    drwxr-x--- 3 zimbra zimbra 4096 Mar 29 2011 953
    drwxr-x--- 3 zimbra zimbra 4096 Mar 30 2011 954
    drwxr-x--- 3 zimbra zimbra 4096 Apr 1 2011 955
    drwxr-x--- 3 zimbra zimbra 4096 Apr 5 2011 956
    drwxr-x--- 3 zimbra zimbra 4096 Apr 13 2011 958
    drwxr-x--- 3 zimbra zimbra 4096 Apr 11 2011 959
    drwxr-x--- 3 zimbra zimbra 4096 Apr 12 2011 960
    drwxr-x--- 3 zimbra zimbra 4096 Apr 19 2011 961
    drwxr-x--- 3 zimbra zimbra 4096 May 4 2011 962
    drwxr-x--- 3 zimbra zimbra 4096 May 4 2011 963
    drwxr-x--- 3 zimbra zimbra 4096 May 6 2011 964
    drwxr-x--- 3 zimbra zimbra 4096 May 12 2011 968
    drwxr-x--- 3 zimbra zimbra 4096 May 13 2011 969
    drwxr-x--- 3 zimbra zimbra 4096 Jun 19 2009 97
    drwxr-x--- 3 zimbra zimbra 4096 May 24 2011 970
    drwxr-x--- 3 zimbra zimbra 4096 May 27 2011 971
    drwxr-x--- 3 zimbra zimbra 4096 Jun 2 2011 972
    drwxr-x--- 3 zimbra zimbra 4096 Jun 3 2011 973
    drwxr-x--- 3 zimbra zimbra 4096 Jun 3 2011 974
    drwxr-x--- 3 zimbra zimbra 4096 Jun 6 2011 975
    drwxr-x--- 3 zimbra zimbra 4096 Jun 6 2011 976
    drwxr-x--- 3 zimbra zimbra 4096 Jun 7 2011 977
    drwxr-x--- 3 zimbra zimbra 4096 Jun 21 2011 978

    Our administration console also does not work anymore.

    Please help me. What do I need to do to fix this?
    Does this mean that the mysql directory is wiped clean?
    How could this have happend?

    Best Regards
    McH

  2. #2
    Join Date
    Jan 2012
    Posts
    2
    Rep Power
    3

    Default

    zimbra@zimbra:~/store/0$ mysql mysql
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)

  3. #3
    Join Date
    Apr 2010
    Location
    Italy
    Posts
    160
    Rep Power
    5

    Default

    Quote Originally Posted by McH View Post
    zimbra@zimbra:~/store/0$ mysql mysql
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    Maybe yhe following theard could help you:

    http://www.zimbra.com/forums/adminis...ql-server.html

    Regards

  4. #4
    Join Date
    Jan 2009
    Location
    near Munich (Germany)
    Posts
    27
    Rep Power
    6

    Default

    Hi,

    I'm running ZCS Open Edition "Release 7.1.1_GA_3196.UBUNTU10_64 UBUNTU10_64 FOSS edition" since over a year.

    I struggled a lot with the logger but honestly I was not paying to much attention to it. Everything worked fine so I was not caring to much about it.

    Today I wanted to upgrade to 7.2 but I was stopped when Zimbra Upgrade procedure tried to start mysql. It just hang. I found out the reason in another post here in the forum so I restored my VM to the last state before the upgrade and suddenly I have a different error.

    ZMCONTROL is telling me mailbox stopped - mysql.server is not running.

    The strange thing is: mailtraffice works. I got a lot of messages in the meantime and I'm also able to reply or send new ones.

    What is happening to my mailbox service???

    Anyone an idea?
    And is there a better way to upgrade to 7.2 - or did I just ran into an trap?

    Thanks for your answers.

  5. #5
    Join Date
    Jan 2009
    Location
    near Munich (Germany)
    Posts
    27
    Rep Power
    6

    Default

    Hi!

    I figured out the error was the user zimbra was not able to connect to the database.

    This great article helped me!

    Issues with mysql and logmysql passwords - Zimbra :: Wiki

    Best regards

    Alexander

Similar Threads

  1. [SOLVED] Unable to start all of the blackberry services
    By scasperson in forum Zimbra Connector for BlackBerry
    Replies: 8
    Last Post: 11-18-2011, 06:30 AM
  2. mailbox & mysql.server not running
    By ozlivingstone in forum Administrators
    Replies: 3
    Last Post: 12-24-2008, 12:41 PM
  3. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM
  4. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •